Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-02-2013, 05:51 PM
Premium Member
 
Join Date: Dec 2010
Posts: 408
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 73826
Mashie has a reputation beyond reputeMashie has a reputation beyond reputeMashie has a reputation beyond reputeMashie has a reputation beyond reputeMashie has a reputation beyond reputeMashie has a reputation beyond reputeMashie has a reputation beyond reputeMashie has a reputation beyond reputeMashie has a reputation beyond reputeMashie has a reputation beyond reputeMashie has a reputation beyond repute
Here is a strange problem

Last week I got my Jeep back from the dealership after they replaced the fuel pump and TIPM which was the cause of the starting issues.

Now everything seems to be working fine except....

When I turn on the passenger turn signal, the signal in the side mirror and rear signal turns on, however instead of the front signal turning on, both fog lights blink?!

My guess is they switched some wires when installing the TIPM but before I head back to the dealership, I was wondering if anyone here had any ideas and if this was a possible easy fix?!

definitely a strange issue
__________________

__________________
2014 JCG Summit 4x4 Black
Tech Package, Dual-Pane Sunroof
Hemi V8, Purchased 11/15/2013
Reply With Quote
  #2  
Old 11-02-2013, 08:10 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Aug 2011
Location: Canada
Posts: 137
Thanks: 1
Thanked 2 Times in 2 Posts
Rep Power: 1618
ernestd is on a distinguished road
Re: Here is a strange problem

I had my TIPM changed at 200 kilometers and everything worked fine.
The TIPM appears to be a series of motherboards stacked upon each other,so any one or all of those boards could be defective.Also keep in mind that there are several other computers on board of these cars that could also be the source of your issue.
I'm sure that a good technician can diagnose this issue properly and have you back on the road with a smile.
Cheers
__________________

Reply With Quote
  #3  
Old 11-22-2013, 09:33 AM
rosado057's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jan 2012
Location: Brooklyn NY
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1370
rosado057 is on a distinguished road
Happened to me as well. Found out tipm was refurbished and defective they need to install a new one. It's one piece they swap out just plug and play


Sent from my iPhone using Tapatalk
Reply With Quote
  #4  
Old 01-14-2015, 09:44 PM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Aug 2012
Location: Cleveland, TN
Posts: 11
Thanks: 5
Thanked 0 Times in 0 Posts
Rep Power: 1114
Wk-Hokie is on a distinguished road
Re: Here is a strange problem

We have the exact same thing. Had the TIPM replaced about a week ago and now the front fog lights and the left turn signal blink when we turn on the right turn signal. Left turn works fine. Hazards work ok except for right light. Taking it back to the stealer in the morning.


Sent from my iPad using JeepGarage
__________________
2012 WK2 Overland, 5.7L V8 HEMI, Black Forest Green; 2005 WK Limited, 5.7L HEMI, Black; father-n-laws 1949 CJ3a, red/rust, starting restoration
Reply With Quote
  #5  
Old 01-15-2015, 02:43 PM
Joey.Donatelli's Avatar
Premium Member
My Jeep: 2015 3.6L WK2
 
Join Date: Feb 2014
Location: Colorado
Posts: 136
Thanks: 12
Thanked 11 Times in 11 Posts
Rep Power: 707
Joey.Donatelli is on a distinguished road
Garage
Re: Here is a strange problem

This is one of the stranger things I have heard about. let us know what the dealer tells you.

Good luck!!
Reply With Quote
  #6  
Old 01-17-2015, 07:57 AM
Member
My Jeep: 2005 5.7L WK
 
Join Date: Aug 2012
Location: Cleveland, TN
Posts: 11
Thanks: 5
Thanked 0 Times in 0 Posts
Rep Power: 1114
Wk-Hokie is on a distinguished road
Re: Here is a strange problem

Dealer said that the new TIPM wires differently. They switched pins 7 and 11 and now it works great again. Hopefully that will be the last problem


Sent from my iPhone using JeepGarage
__________________
2012 WK2 Overland, 5.7L V8 HEMI, Black Forest Green; 2005 WK Limited, 5.7L HEMI, Black; father-n-laws 1949 CJ3a, red/rust, starting restoration
Reply With Quote
  #7  
Old 01-17-2015, 10:45 AM
xj31's Avatar
Member
 
Join Date: Dec 2010
Posts: 123
Thanks: 0
Thanked 8 Times in 5 Posts
Rep Power: 1862
xj31 has a reputation beyond reputexj31 has a reputation beyond repute
Here is a strange problem

The new TIPM comes with instructions in the box telling about rewiring. Sounds like someone missed that part


Sent from my iPad using JeepGarage
__________________

__________________
Fiber makes me sad.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange Stalling Problem 05WKinPA Troubleshooting/Problems Discussion 5 03-09-2013 12:25 PM
strange braking problem hug13 Troubleshooting/Problems 5 01-09-2013 08:07 PM
Strange Flasher/Turn Signal problem !! Overland Neil Troubleshooting/Problems 5 06-10-2012 01:49 AM
Strange Problem, Need Help ASAP Crestwood1001 Grand Cherokee - WK 6 01-30-2011 03:48 PM
Bit of a strange problem.... PDR1 Troubleshooting/Problems 2 05-08-2010 02:31 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.