Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-02-2011, 05:07 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Massachusetts
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1627
hammer1234 is on a distinguished road
Hum at 70+ MPH...windshield install problem?

I had a new windshield (Mopar glass) installed less than 2 weeks ago, and I now am starting to get a loud vibration/hum from the front (can feel it on the dashboard) when going around 70 MPH. I am taking it back to the installer tomorrow for a look, but I was wondering if this is the most likely culprit or if it could be a different issue...
__________________

__________________
Reply With Quote
  #2  
Old 09-02-2011, 07:01 AM
77Cherokee's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jun 2011
Location: NY State
Posts: 652
Thanks: 0
Thanked 21 Times in 19 Posts
Rep Power: 2235
77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute
Re: Hum at 70+ MPH...windshield install problem?

If the windshield is causing the hum I would think it would have started humming right after the installation, but anything is possible.
__________________

__________________
2012 Overland, Deep Cherry w/black/saddle interior, V6, ACC pkg.

My 77 Cherokee- Long gone but not forgotten
___
____________________________________
Reply With Quote
  #3  
Old 09-02-2011, 12:26 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Massachusetts
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1627
hammer1234 is on a distinguished road
Re: Hum at 70+ MPH...windshield install problem?

Didn't think of it...just had the tires rotated recently as well (part of 8K service). If the windshield is OK I'll check with the dealer, maybe they can check the tires.
__________________
Reply With Quote
  #4  
Old 09-03-2011, 11:53 AM
tmclaug1's Avatar
Premium Member
 
Join Date: Mar 2011
Location: Up State NY
Posts: 36
Thanks: 3
Thanked 2 Times in 2 Posts
Rep Power: 1411
tmclaug1 is on a distinguished road
Re: Hum at 70+ MPH...windshield install problem?

I am trading my 08 Esclade because they can't nor wont fix the "hum" in the windshield area. They took the bug deflector, mirrors and mud flaps off but never found it. Very loud on my Cadi.
__________________
Reply With Quote
  #5  
Old 09-03-2011, 05:39 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Massachusetts
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1627
hammer1234 is on a distinguished road
Re: Hum at 70+ MPH...windshield install problem?

Took it to SafeLite...there was an air leak in the newly-installed windshield. They replaced the windshield and it's much quieter now...
__________________
Reply With Quote
  #6  
Old 09-04-2011, 09:56 PM
Member
 
Join Date: Jan 2011
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1447
FUZZ866 is on a distinguished road
Re: Hum at 70+ MPH...windshield install problem?

I know what the problem is! You're driving to fast. So slow down and don't drive over 25 miles per hour.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
V6 Vibrations at 50 to 60 MPH Mlebout Trouble Shooting/Problems/Service 20 09-20-2012 07:57 PM
Steering column hum/drone/moan CrazyJ Trouble Shooting/Problems/Service 3 03-16-2012 05:23 AM
Hum in front end of '04. Rebuild prescribed. Huge $'s. Advice pls? Asap. Ovrlndr Troubleshooting/Problems Discussion 5 05-10-2011 06:43 PM
Side Steps Install Problem brentmc Tech Tips/DIY/How To 3 01-14-2011 06:07 PM
Problem after my install Relwarc Audio, Video, Navigation & Electronic Modifications 14 10-28-2010 06:20 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.