HVAC not working - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-05-2016, 11:27 PM
zzkazu's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Jun 2011
Location: Canberra, ACT
Posts: 500
Thanks: 9
Thanked 10 Times in 9 Posts
Rep Power: 2601
zzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond repute
HVAC not working

The HVAC in my MY12 has stopped working. It also it making a new sound separate to the fan, sounds like a PC HDD.

I have read here that the noise issue could be related to a the blower motor bearing, but not sure why the AC doesn't seem to provide cool air anymore. Wouldn't think these need regassing???

Are there any guides on how to inspect/remove the blower?

thanks

-----
Removed the filter, noise still there without the filter inserted but I discovered the blower location. There are four bolts I can see located on a plastic frame on which the blower is located behind. Although this doesn't seem enough to gain access to it...

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 01-06-2016, 12:44 AM
zzkazu's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Jun 2011
Location: Canberra, ACT
Posts: 500
Thanks: 9
Thanked 10 Times in 9 Posts
Rep Power: 2601
zzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond repute
Re: HVAC not working

Providing updates for historically purposes.

I believe the reason the AC isnt working is due to the AC clutch not engaging.

I have used this reference

http://www.wk2jeeps.com/Misc/Fuses_2011_2013_wk.pdf

But I can't see a reference to the A/C Compressor Clutch relay, which I want to check. I'll keep digging..
Reply With Quote
  #3  
Old 01-07-2016, 09:02 PM
zzkazu's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Jun 2011
Location: Canberra, ACT
Posts: 500
Thanks: 9
Thanked 10 Times in 9 Posts
Rep Power: 2601
zzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond repute
Re: HVAC not working

I have discovered that reference isn't accurate for the Export Diesel model which I have.

This is and it identifies K2 as the Clutch Compressor Relay.

After swapping the relays the issue remains so mostly likely isn't electrical
Attached Images
File Type: jpg AC Compressor Relay TIPM.JPG (277.7 KB, 4 views)
Reply With Quote
  #4  
Old 01-08-2016, 05:27 AM
Premium Member
My Jeep: 2015 3.0L WK2
 
Join Date: Dec 2011
Location: Gold Coast Australia
Posts: 760
Thanks: 33
Thanked 123 Times in 107 Posts
Rep Power: 35827
John47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond reputeJohn47 has a reputation beyond repute
Re: HVAC not working

You obviously are systematically working your way through, and if the clutch isn't engaging then obviously no a/c can result.
It is strange that the a/c clutch relay isn't clearly identified on the 2011 WK2 Jeeps .pdf, and on the export .pdf you loaded, as far as I could see doesn't clearly note that K2 was the clutch.
Going back to the WK2 site I checked the.pdf for the later models and the TIPM layout matches with our 2015 and clearly identifies the a/c clutch relay.
I reckon there might still be something tricky going on with the earlier wiring.
Don't give up. I wonder if there is a way you can fudge the clutch engagement (without setting fire to your pride and joy).
And just for info - our 2012 CRD a/c gave up the ghost at 97,000km, diagnosed as a cracked condenser inlet pipe. Fixed under extended warranty with a new condenser and not an uncommon problem it seems. In fairness ours had done heaps of rough road work.
Good luck
John
__________________
2015 Laredo CRD
Billet Silver with Quadralift, front recovery hook, Mopar towbar
Upgraded from 2012 CRD that did the job brilliantly for 4 years
1975 Holden HJ 308 Monaro 4dr - oldie but a goodie
Reply With Quote
  #5  
Old 01-08-2016, 07:03 PM
zzkazu's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Jun 2011
Location: Canberra, ACT
Posts: 500
Thanks: 9
Thanked 10 Times in 9 Posts
Rep Power: 2601
zzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond repute
Re: HVAC not working

Thanks John, I have been using this great resource, with my VIN number

https://techauthorityonlinedemo.extr...ew/classic.htm

To get to these wiring diagrams for the HVAC.

These show the Relay "Run" in the TIPM as being the only relevant apart from the Blower Relay which is K9. What I plan to do next is to see if 12V is present on the Compressor connector when AC is ON.
Attached Images
File Type: jpg HVAC Wiring Diagram 1.JPG (122.5 KB, 8 views)
File Type: jpg HVAC Wiring Diagram 2.JPG (133.6 KB, 4 views)
File Type: jpg HVAC Wiring Diagram 3.JPG (61.0 KB, 3 views)
Reply With Quote
  #6  
Old 01-09-2016, 06:13 PM
zzkazu's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Jun 2011
Location: Canberra, ACT
Posts: 500
Thanks: 9
Thanked 10 Times in 9 Posts
Rep Power: 2601
zzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond repute
Re: HVAC not working

Next update, bypassed relay and shorted "switch side" (30/87) of relay circuit. Still no banana.

I next want to apply 12V directly to AC Clutch Compressor, but first I need to work out how to disconnect connector. Limited room and I don't want to break it..

This is what techauthority outlines it is..
Attached Images
File Type: jpg AC Compressor Clutch connector.JPG (57.8 KB, 2 views)
Reply With Quote
  #7  
Old 01-10-2016, 11:54 PM
zzkazu's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Jun 2011
Location: Canberra, ACT
Posts: 500
Thanks: 9
Thanked 10 Times in 9 Posts
Rep Power: 2601
zzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond repute
Re: HVAC not working

Looks like the AC condenser has taking a hit. The want $1100 for the oem here in Aus. I have gone for an non-oem part for $380.
Reply With Quote
  #8  
Old 01-13-2016, 07:41 PM
zzkazu's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Jun 2011
Location: Canberra, ACT
Posts: 500
Thanks: 9
Thanked 10 Times in 9 Posts
Rep Power: 2601
zzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond reputezzkazu has a reputation beyond repute
Re: HVAC not working

To close thread the issue was the condenser, had two leaks but not apparent with the naked eye.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't control HVAC - Looking for part number for HVAC Circuit Control Board GoldenBear03 Trouble Shooting/Problems/Service 8 05-03-2014 11:51 AM
Trailer lighting not working, Fuses not pushed in...Give me some help here FD12ME Trouble Shooting/Problems/Service 5 05-28-2013 07:11 PM
HVAC Blower not working ooja3k Trouble Shooting/Problems/Service 0 10-18-2012 12:26 AM
Tech tip for dome light not shutting off/windows not working 67 Wagoneer Troubleshooting/Problems 2 04-20-2012 11:16 AM
Power mirror not working. Dealer not much help. brent Grand Cherokee - WK 10 02-18-2010 10:24 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:30 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.