Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 10-11-2012, 02:39 PM
SixZeroFour's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jan 2011
Location: Vancouver BC
Posts: 542
Thanks: 11
Thanked 38 Times in 25 Posts
Rep Power: 54453
SixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond repute
Re: I messed up

^ I would assume the shut-down would only happen the next time the vehicle was shifted into into park not while your doing 70 down the highway
__________________

__________________
:: Blackberry Pearl Overland HEMI :: [265/65/18] Silent Armours :: CF Wrapped Interior Trim :: SRT Steering Wheel :: SRT Shift Knob :: Mopar Pedals/E-brake :: Weathertech Digital Fit Liners :: Mopar Cargo Mat :: Skid Plates :: Tow Package :: Ejector Seat ::
Reply With Quote
  #26  
Old 10-11-2012, 03:13 PM
Jeff_Jeske's Avatar
Member
 
Join Date: Aug 2010
Posts: 468
Thanks: 3
Thanked 5 Times in 5 Posts
Rep Power: 2291
Jeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond reputeJeff_Jeske has a reputation beyond repute
Re: I messed up

First thing I would do is disconnect the battery to reset the ecu.
__________________

__________________
2013 Ford Edge Sport AWD
2011 Jeep Grand Cherokee Overland w/Hemi
2006 Mitsubishi Evolution 9 - Highly Modified Time Attack Car - DYNO (PUMP/E85)
Reply With Quote
  #27  
Old 10-11-2012, 05:03 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: AZ
Posts: 642
Thanks: 1
Thanked 10 Times in 7 Posts
Rep Power: 2769
eibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond reputeeibyer has a reputation beyond repute
Re: I messed up

Quote:
Originally Posted by SixZeroFour View Post
^ I would assume the shut-down would only happen the next time the vehicle was shifted into into park not while your doing 70 down the highway
This would have been my suggestion also, only when in Park.
__________________
Reply With Quote
  #28  
Old 10-11-2012, 05:35 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Sep 2011
Location: Cherry Valley, IL
Posts: 345
Thanks: 0
Thanked 7 Times in 5 Posts
Rep Power: 4676
brandont has a reputation beyond reputebrandont has a reputation beyond reputebrandont has a reputation beyond reputebrandont has a reputation beyond reputebrandont has a reputation beyond reputebrandont has a reputation beyond reputebrandont has a reputation beyond reputebrandont has a reputation beyond reputebrandont has a reputation beyond reputebrandont has a reputation beyond reputebrandont has a reputation beyond repute
Re: I messed up

I seriously doubt if the fuel pump would be damaged that badly from running dry one time. I would pull the battery connection for 30min to reset the CPU. Then give it a good run on the freeway to clear any possible deposits in the cat. If neither of those works, time to see the dealer. I would not hesitate to tell them that it ran dry. Your car should be able to run out of gas without damaging anything. Doing so should not void your warranty so I would just be up front about it. (You can safely leave out the part about leaving it running at the airport, that's funny but not relevant).
__________________
Reply With Quote
  #29  
Old 10-14-2012, 06:44 PM
andyh's Avatar
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jan 2011
Location: ILM, NC
Posts: 372
Thanks: 2
Thanked 6 Times in 6 Posts
Rep Power: 2303
andyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond reputeandyh has a reputation beyond repute
Give it an Italian tune up.
__________________
This is my sig
Reply With Quote
  #30  
Old 07-24-2013, 11:40 AM
ibleedoil's Avatar
Premium Member
 
Join Date: Jan 2011
Location: Edmonton, AB
Posts: 91
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1535
ibleedoil is on a distinguished road
Re: I messed up

Hey guys, so I haven't been on the forum in quite a while. I've been busy on another forum and modding my Camaro.

Anyway, this issue has still not gone away, I've disconnected the battery, ran fuel cleaner, did multiple italian tune ups, pretty much everything suggested.

I've also taken it to multiple dealerships to see if they could figure it out or fix it, and I've gotten no solution. One actually told me to wind it out on the hwy a couple times.

It doesnt happen all the time, maybe 60% of start ups, and it hasnt gotten any better or worse.

Has anyone had similar issues or can think of anything else it might be
__________________
2011 Overland 4x4
- Hemi
- Off-Road II
- ACC
- Natural Green Pearl / Saddle Brown
Reply With Quote
  #31  
Old 07-24-2013, 05:48 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Illinois
Posts: 36
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 644
MTC595 is on a distinguished road
Re: I messed up

This is a little off the wall, but it could be your battery.

I have had several cars where the electronics get really weird as the battery got week. Door locks behave strange along with intermittent starting problems.

A car running at idle doesn't always provide a strong charge, and if you were idling overnight, the headlights would have been a small drain on the system.

Its not enough to kill a battery, but as the battery ages, it doesn't charge as well either, so this could have shorted the its life.

Other than that, my 2nd vote is also the fuel pump.
One other thing to try is to turn on accessory power, but not start the engine. Wait 5 seconds or so, and then start it. It gives the pump a few seconds to build up pressure.

Mike
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I think I messed up.... real bad jkt009 Troubleshooting/Problems 4 08-08-2012 01:47 PM
Is your Chrome Bumper molding messed up? JeepMonster Interior/Exterior/Visual 3 05-24-2012 02:29 PM
HELP! Bilstein shocks just delivered and I think one is messed up rayjr2785 Grand Cherokee - WK 11 05-05-2011 01:15 PM
I think the dealer Messed w/my car. TimmyB Grand Cherokee - WK 10 04-03-2010 08:33 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:52 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.