Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #145  
Old 06-29-2013, 09:01 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,195
Thanks: 214
Thanked 172 Times in 137 Posts
Rep Power: 89723
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

I've been following this thread since its inception, and I just want to comment that I've never experienced the shifting problems described here. I leave it in eco mode almost all of the time, and acceleration is just fine. Coming to a stop, I don't experience any harsh downshifting. I wonder if my dealer disconnected the battery before delivery to reset everything? I've driven my Jeep pretty much like I stole it from day one (old family tradition), and I've owned a couple of sports and high performance cars in my day. Although my Jeep certainly isn't a Trans Am, it moves pretty damn good for the boat it is!
__________________

__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
The Following User Says Thank You to jacko15 For This Useful Post:
  #146  
Old 06-29-2013, 09:05 AM
davekarn's Avatar
Member
 
Join Date: Aug 2012
Posts: 215
Thanks: 29
Thanked 4 Times in 4 Posts
Rep Power: 1076
davekarn is on a distinguished road
I've done the reset and while it's a little better, I still have a harsh downshift from 3 to 2 in Sport Mode
__________________

__________________
CURRENT 2014 Overland 4x4 5.7L V-8- Max Steel/Indigo Blue, Advanced Technology Group, Quadra-Drive II

TRADED-IN 2013 Limited 4x4 5.7L V-8- Mineral Grey/Tan, Off-Road Adventure 2, Luxury Group 2, Advanced Technology Group, Trailer Tow Group IV
[SIGPIC][/SIGPIC]
Reply With Quote
  #147  
Old 06-29-2013, 10:56 AM
AZhiCntry's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Prescott, AZ
Posts: 543
Thanks: 280
Thanked 26 Times in 25 Posts
Rep Power: 48986
AZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by jacko15 View Post
I've been following this thread since its inception, and I just want to comment that I've never experienced the shifting problems described here. I leave it in eco mode almost all of the time, and acceleration is just fine. Coming to a stop, I don't experience any harsh downshifting. I wonder if my dealer disconnected the battery before delivery to reset everything? I've driven my Jeep pretty much like I stole it from day one (old family tradition), and I've owned a couple of sports and high performance cars in my day. Although my Jeep certainly isn't a Trans Am, it moves pretty damn good for the boat it is!
X2, no problems with shifting here!
__________________
2014 GC Limited V6 4x4, white w/black & frost beige, LuxII, RA4, ORA II, Cooper Discoverer AT3's. :D:D:D
Reply With Quote
  #148  
Old 06-29-2013, 11:40 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2013
Location: Vermont
Posts: 165
Thanks: 12
Thanked 2 Times in 2 Posts
Rep Power: 48041
VermontJGC14 has a reputation beyond reputeVermontJGC14 has a reputation beyond reputeVermontJGC14 has a reputation beyond reputeVermontJGC14 has a reputation beyond reputeVermontJGC14 has a reputation beyond reputeVermontJGC14 has a reputation beyond reputeVermontJGC14 has a reputation beyond reputeVermontJGC14 has a reputation beyond reputeVermontJGC14 has a reputation beyond reputeVermontJGC14 has a reputation beyond reputeVermontJGC14 has a reputation beyond repute
Garage
Re: I Think I Fixed My Rough Shifting 8sp Transmission

My sluggish 1-2 upshift in ECO mode has now returned, roughly two weeks after the battery reset.
__________________
[SIGPIC][/SIGPIC]
Vermont
JGC14
'01 Cherokee Sport "Goldy" - Consumed by the dreaded RUST MONSTER
'14 Grand Cherokee Limited "The White Walker" - Hemi - ORAII - RA4 - Volant CAI


Reply With Quote
  #149  
Old 06-29-2013, 11:46 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,195
Thanks: 214
Thanked 172 Times in 137 Posts
Rep Power: 89723
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by VermontJGC14 View Post
My sluggish 1-2 upshift in ECO mode has now returned, roughly two weeks after the battery reset.
I certainly don't mean to sound critical of anyone's driving habits, but maybe you're driving style is teaching it to behave this way. How do you normally accelerate from a stop? I know I always give my Jeep a little "spur" out of the hole.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #150  
Old 06-29-2013, 12:21 PM
Captain_Kirk's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: CT
Posts: 47
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 657
Captain_Kirk is on a distinguished road
Garage
Re: I Think I Fixed My Rough Shifting 8sp Transmission

I unhooked the battery a few weeks ago for about 30min and didn't notice much change. tried the fuse a couple of days ago and this has made a world of difference. I used to go back and forth turning Eco on and off depending on the driving conditions (stop/go, hills, etc...) and now I can just leave it in Eco. much better, thanks for the tip!
__________________
Reply With Quote
The Following User Says Thank You to Captain_Kirk For This Useful Post:
  #151  
Old 06-29-2013, 01:08 PM
mrmarks66's Avatar
Member
 
Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 580
mrmarks66 is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Is there a site to down load the unconnect issue. Dealer said an hour or longer to fix. My iPhone and unconnect every time I have to forget device before it will connect again
__________________
Reply With Quote
  #152  
Old 06-29-2013, 01:54 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,195
Thanks: 214
Thanked 172 Times in 137 Posts
Rep Power: 89723
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by mrmarks66 View Post
Is there a site to down load the unconnect issue. Dealer said an hour or longer to fix. My iPhone and unconnect every time I have to forget device before it will connect again
UConnect 13.19.0 - Unofficial
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #153  
Old 06-30-2013, 09:29 PM
FD12ME's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Posts: 126
Thanks: 0
Thanked 16 Times in 9 Posts
Rep Power: 912
FD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond repute
I don't know if it's driving habits. I called to schedule an appointment, I'm at 6400mi and all of a sudden, right of the garage in the morning I'm getting an up shift from 2->3 that feels like
I was rear ended-it's so bad by GF who wouldn't know if her car was on fire even said something. I don't know what's up with it-but it's not a break in issue-I had to install the Uconnect update 2x for it to take, maybe my computer is a slow learner haha- maybe it just needs to be reflashed w the tranny software again-maybe it's a hardware issue-maybe the jeep gods just want me to go back to ford haha.
__________________
Reply With Quote
  #154  
Old 07-01-2013, 07:15 AM
studio1930's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Posts: 268
Thanks: 19
Thanked 21 Times in 13 Posts
Rep Power: 1209
studio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond repute
Garage
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by jacko15 View Post
I certainly don't mean to sound critical of anyone's driving habits, but maybe you're driving style is teaching it to behave this way. How do you normally accelerate from a stop? I know I always give my Jeep a little "spur" out of the hole.
I have a very, very mixed driving habit. Everyday I baby it from a stop light and then later that day I drive it like a race car. Some days I might drive it medium start to stop and other days I might baby it all day long. Some days I drive it in sport mode more than usual and other days I use the paddle shifters. Something is causing these computers to learn some bad shifting and I have never had another car/truck do this. It is not our driving, it is the computers/programming. Too many people on this forum with many different driving habits and traffic styles are experiencing the exact same problems with 1-2-3 or 3-2-1 shifting for it to be driving style.
__________________
--------------------------------------------------------
2014 Grand Cherokee Overland 4x4, Max Steel, Morocco Black int, ORA II, ATG

Reply With Quote
  #155  
Old 07-01-2013, 11:33 AM
Member
 
Join Date: Jun 2013
Posts: 5
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 559
Unclev is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

I just bought a new 2014 Laredo and it has the same tranny problems everyone is describing. I test drove three diff Laredos and every one of them had some type of tranny anomaly. Since we know that the ram memory in the TCM, when reset, does have an impact but not the solution. To rectify the root cause there needs to be a re flash of the firmware in the TCM. I am hoping that enough of us complain to the dealer and eventually they will come out with the TSB for the reflash.
__________________
Reply With Quote
  #156  
Old 07-04-2013, 06:37 PM
Member
 
Join Date: Jul 2013
Posts: 32
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 570
dtrvm is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

I am looking to buy a GC and find this thread very interesting. I also think people test driving the cars do not help the initial learning so the reset seems to make a lot of sense.

Is this a problem with the 6 more than the 8 cylinder?

I sure hope Jeep can fix the software, but I am a little concerned car companies may be more afraid of missing epa mileage requirements than truly satisfying customers. This may mean you need to always start in sport mode on all cars in the future.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Transmission not Shifting gottubes Trouble Shooting/Problems/Service 15 04-30-2013 07:46 PM
Transmission shifting iwearpumas Troubleshooting/Problems 6 06-09-2012 04:58 AM
transmission shifting Delofter77 Trouble Shooting/Problems/Service 4 04-27-2012 02:43 PM
Transmission Shifting Problem txrancher74 Trouble Shooting/Problems/Service 12 06-05-2011 06:15 PM
Transmission shifting right? wjs81866 Trouble Shooting/Problems/Service 4 10-22-2010 09:14 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:29 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.