Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #397  
Old 11-01-2013, 11:47 AM
Member
 
Join Date: Feb 2013
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 797
dannyguo has a reputation beyond reputedannyguo has a reputation beyond reputedannyguo has a reputation beyond reputedannyguo has a reputation beyond reputedannyguo has a reputation beyond repute
Quote:
Originally Posted by FAST_US View Post
For any of you that had the update done: Are you still having problems with the rough transmission? Did the update correct the issue? or the issue returned after a while? I have a GC V6 that I took delivery in April .. Unfortunately my dealer is refusing to install the new update. After several attempts showing them the TSB, RRT, they still say that my GC is fine and my VIN is not included on the list of affected cars. And on top of that they are saying that I have the latest software. How can I have the latest software if I took delivery in April is something that it is beyond me. Has anyone had this GREAT experience with your dealer? Thanks!
I got the same experience as you were. Just came back from the local dealer, the service advisor told me the transmission flash I got in this August (they performed the 1st version flash to my truck this August) was the latest one. I told him the latest one was just released in Oct., but he just ignored what I said and insisted that my truck had the latest transmission flash. So I asked him how come you guys can perform a October released flash in August, which did not make any sense logically. Then the service advisor became very inpatient and told me that they just won't do the update since my truck is not qualified... Sadly they are the only jeep dealer in my town and the second nearest one is about one hour driving.
__________________

__________________
Reply With Quote
  #398  
Old 11-01-2013, 03:04 PM
Jeep4Ron's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Sonoma County, CA USA
Posts: 46
Thanks: 3
Thanked 7 Times in 4 Posts
Rep Power: 734
Jeep4Ron is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by bill_de View Post
I was hoping the suspension flash might sneak that in, but no such luck.
But now, at least, when the Jeep raises from exit mode, not only does the raising light stop flashing, but you get the "Vehicle Has Achieved Normal ... " message in the EVIC.

As for the attorney you are recommending, I hope he has Supreme Court experience.


---
Bad news...the lawyer is only licensed to practice in Guam!
__________________

__________________
-----------------------------
Delivered: Deep Cherry Red 2014 JGC Overland/Pentastar V6/Adv. Tech/ORA :thumbsup:
Reply With Quote
  #399  
Old 11-05-2013, 09:56 AM
New Member
 
Join Date: Nov 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
White2014GC is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

I've been following this thread for a few months now and it really seems like everyone been involved with providing updates and info on your transmission experience since day one. I too have issues surrounding my transmissions were it lurches when decelerating mainly from 5-4 and again 2-1. This had made for a really unenjoyable ride. I seem to never be able to time my breaks right cause there so much drag caused by the transmission the car basically breaks itself. A recent post on this thread by some of u seem to be a complete 180 from previous posts were you were once frustrated with the tranny updated but since your most recent flash and battery pull seems to work wonders. My question for you is, what flash are you talking? I know there are three, the original that came out in August, the second I believe late sept and the Thor which looks like clerical update sometime in October. I've been the the deal three separate occasion for my tranny. The first in August when they applied the first tranny flash, but the problem persisted. After that trip no service department would flash any "new" updates even after the second was released saying I had the most up to date. What steps have you've taken with your car to get it to perform so much better and wha did you have to do with the service department in order or them to provide you a "potential" second flash, if that's what happen?
__________________
Reply With Quote
  #400  
Old 11-05-2013, 10:11 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,197
Thanks: 214
Thanked 173 Times in 138 Posts
Rep Power: 89730
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Here's the TSB for the latest flash. You could print it and take it to your dealer. I haven't had any of the flashes done, and I'm happy with the way my Jeep has learned my driving style. I guess I'm the square peg in the round hole. Good luck, and I hope you can get your Jeep running the way you'd like it to run. When it's running right it's a joy to drive. I'm really enjoying mine!
Attached Files
File Type: pdf tsb_wk2_2100713b.pdf (114.2 KB, 70 views)
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #401  
Old 11-09-2013, 08:18 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 990
Thanks: 6
Thanked 51 Times in 38 Posts
Rep Power: 3666
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by White2014GC View Post

I've been following this thread for a few months now and it really seems like everyone been involved with providing updates and info on your transmission experience since day one. I too have issues surrounding my transmissions were it lurches when decelerating mainly from 5-4 and again 2-1. This had made for a really unenjoyable ride. I seem to never be able to time my breaks right cause there so much drag caused by the transmission the car basically breaks itself. A recent post on this thread by some of u seem to be a complete 180 from previous posts were you were once frustrated with the tranny updated but since your most recent flash and battery pull seems to work wonders. My question for you is, what flash are you talking? I know there are three, the original that came out in August, the second I believe late sept and the Thor which looks like clerical update sometime in October. I've been the the deal three separate occasion for my tranny. The first in August when they applied the first tranny flash, but the problem persisted. After that trip no service department would flash any "new" updates even after the second was released saying I had the most up to date. What steps have you've taken with your car to get it to perform so much better and wha did you have to do with the service department in order or them to provide you a "potential" second flash, if that's what happen?
Just to reiterate, I got the 2nd transmission reflash back in September (dealership refused to give me the 3rd reflash or even to check the vehicles computer in October), and it seemed to help at first, but after a couple weeks or so it started going back to it's rough shifting ways...lower gear downshifts.

So I did my battery disconnect trick again, but this time I left the negative battery cable disconnected for like two hours (after pumping the brakes to dissipate any residual power left in the system). I then reconnected the battery, drove around town for an hour (in ECO, regular, and Sport mode) and then I switched into every possibility of 4WD (sand, snow, rock, etc.) for a bit.

I'd say now after more than a month, the transmission shift quality is at 90%...with ECO mode being the worst (especially in bumper to bumper traffic). The problems that still persist are a brief sticking in 1st gear when first leaving the driveway in the morning, and when in ECO mode...stomping on the gas to merge out onto the highway gets you a BIG dead spot of nothing for a few seconds. It still seems that the reaction time of tranny in ECO mode is WAY too slow, sometimes in real heavy traffic I just switch ECO mode off for a more enjoyable ride...with no real reduction of gas mileage.

The second reflash & battery reset saved me from getting rid of this vehicle for now, but I still plan on getting rid of my 2014 GC before the warranty is up. I simply lost confidence in it.
__________________
I Hate My Jeep Yet Again...
Reply With Quote
  #402  
Old 11-09-2013, 11:03 AM
Member
 
Join Date: Apr 2013
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 677
hulk is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by GCLimited View Post
Just to reiterate, I got the 2nd transmission reflash back in September (dealership refused to give me the 3rd reflash or even to check the vehicles computer in October), and it seemed to help at first, but after a couple weeks or so it started going back to it's rough shifting ways...lower gear downshifts.

So I did my battery disconnect trick again, but this time I left the negative battery cable disconnected for like two hours (after pumping the brakes to dissipate any residual power left in the system). I then reconnected the battery, drove around town for an hour (in ECO, regular, and Sport mode) and then I switched into every possibility of 4WD (sand, snow, rock, etc.) for a bit.

I'd say now after more than a month, the transmission shift quality is at 90%...with ECO mode being the worst (especially in bumper to bumper traffic). The problems that still persist are a brief sticking in 1st gear when first leaving the driveway in the morning, and when in ECO mode...stomping on the gas to merge out onto the highway gets you a BIG dead spot of nothing for a few seconds. It still seems that the reaction time of tranny in ECO mode is WAY too slow, sometimes in real heavy traffic I just switch ECO mode off for a more enjoyable ride...with no real reduction of gas mileage.

The second reflash & battery reset saved me from getting rid of this vehicle for now, but I still plan on getting rid of my 2014 GC before the warranty is up. I simply lost confidence in it.
+1... First my thanks to you GCLimited... I have both the flashes applied... But they did not help. After reading your post few days back, I tried the battery reset (after the second flash). I would say that, the tranny feels better after the reset. There are still lurches and abrupt 2-1 clunks in the mornings when its still cold... But feels much better once the engine is warmed up... Will report back in a few days
__________________
Reply With Quote
  #403  
Old 04-01-2014, 07:22 AM
Eram's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Location: Canada
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 565
Eram is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Folks,

I had the latest (third) tranny flash applied on Saturday to my 2014 Overland, took the car to a Carwash on Sunday, the Carwash has the tracks that ask you to drive on it and place your vehicle in Neutral. I placed my Jeep in Neutral and the Jeep started moving forward slowly by itself on the tracks, I almost hit the vehicle that was 20 feet ahead of me that was actually being control by the carwash tracks.

Can anyone confirm if their Jeep that had the third Tranny flash update seen similar issues when in Neutral.. I tried it on a flat area on the road yesterday and the Jeep intermittently drives forward for about 20 feet and then stops, 2 out of 6 tries the Jeep moves while in Neutral.

Scarry..
__________________
Reply With Quote
  #404  
Old 04-01-2014, 07:43 AM
Bretto's Avatar
Member
My Jeep: 2013 3.0L WK2
 
Join Date: Feb 2013
Location: NSW
Posts: 272
Thanks: 2
Thanked 4 Times in 4 Posts
Rep Power: 956
Bretto is on a distinguished road
Quote:
Originally Posted by Eram View Post
Folks,

I had the latest (third) tranny flash applied on Saturday to my 2014 Overland, took the car to a Carwash on Sunday, the Carwash has the tracks that ask you to drive on it and place your vehicle in Neutral. I placed my Jeep in Neutral and the Jeep started moving forward slowly by itself on the tracks, I almost hit the vehicle that was 20 feet ahead of me that was actually being control by the carwash tracks.

Can anyone confirm if their Jeep that had the third Tranny flash update seen similar issues when in Neutral.. I tried it on a flat area on the road yesterday and the Jeep intermittently drives forward for about 20 feet and then stops, 2 out of 6 tries the Jeep moves while in Neutral.

Scarry..
Funny you said that .. I had a similar thing happen in my driveway. I pulled up and was just grabbing something quickly inside so
Left the car on, jumped out and next thing I feel the car lurching forward as I was getting out, so quickly jumped back in and applied the brakes and shoved it in park and turned it off. Scariest moment ever. until just reading this, I've assumed I must of left it in drive even though I'm
Sure I didn't ...
__________________
Reply With Quote
  #405  
Old 04-01-2014, 07:47 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,197
Thanks: 214
Thanked 173 Times in 138 Posts
Rep Power: 89730
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

You might want to read this thread:
Carwash Conundrum
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #406  
Old 04-01-2014, 09:12 AM
Sh0rtBus's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: North Texas
Posts: 393
Thanks: 0
Thanked 12 Times in 12 Posts
Rep Power: 2377
Sh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond repute
Garage
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by Bretto View Post
Funny you said that .. I had a similar thing happen in my driveway. I pulled up and was just grabbing something quickly inside so
Left the car on, jumped out and next thing I feel the car lurching forward as I was getting out, so quickly jumped back in and applied the brakes and shoved it in park and turned it off. Scariest moment ever. until just reading this, I've assumed I must of left it in drive even though I'm
Sure I didn't ...
I've actually had that happen with my JK a couple times. I was trail riding with some buddies and stopped going down a slight hill. Put it in park and then went to get out and the JK kept going. Barely had enough time to get in and slam the brakes before it hit my buddy's rig in front of me. I'm guessing it just didn't engage the parking pin because I was on a hill in 4-LO. Will certainly keep this in mind next time I was the WK2, though, which will likely be tomorrow because it desperately needs it.
__________________
2011 Jeep Wrangler Unlimited Rubicon

2014 Grand Cherokee Limited 4x4 3.6L Deep Cherry Red

Reply With Quote
  #407  
Old 04-01-2014, 10:43 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 990
Thanks: 6
Thanked 51 Times in 38 Posts
Rep Power: 3666
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Wow...my thread is back from the dead!

Just to update everyone...

Even though the battery disconnect and multiple transmission flashes helped a lot with my rough shifting transmission, ultimately I got fed-up with it and ended up trading the Limited in for a late build Overland.

The transmission in the Overland from day one has shifted like a champ!

__________________
I Hate My Jeep Yet Again...
Reply With Quote
  #408  
Old 04-01-2014, 06:05 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 1,265
Thanks: 40
Thanked 95 Times in 76 Posts
Rep Power: 2441
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by GCLimited View Post
Wow...my thread is back from the dead!

Just to update everyone...

Even though the battery disconnect and multiple transmission flashes helped a lot with my rough shifting transmission, ultimately I got fed-up with it and ended up trading the Limited in for a late build Overland.

The transmission in the Overland from day one has shifted like a champ!

Not to change the subject but how is the HVAC working in your late built one? erratic heat cooking you to a cinder or did they get that worked out?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Transmission not Shifting gottubes Trouble Shooting/Problems/Service 15 04-30-2013 07:46 PM
Transmission shifting iwearpumas Troubleshooting/Problems 6 06-09-2012 04:58 AM
transmission shifting Delofter77 Trouble Shooting/Problems/Service 4 04-27-2012 02:43 PM
Transmission Shifting Problem txrancher74 Trouble Shooting/Problems/Service 12 06-05-2011 06:15 PM
Transmission shifting right? wjs81866 Trouble Shooting/Problems/Service 4 10-22-2010 09:14 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.