Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #421  
Old 04-27-2014, 09:40 PM
New Member
My Jeep: 2013 3.6L WK2
 
Join Date: Nov 2013
Location: Australia
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
binesh is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Thanks mate, resetting using the battery did make my rid smoother, especially it got rid of the thug when stopping.
__________________

__________________
Reply With Quote
  #422  
Old 06-01-2014, 09:34 PM
Member
My Jeep: 2014 3.6L
 
Join Date: Apr 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 201
SouthGAJeep is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

I also tried the battery disconnect for an hour or so and changed the air filter (Fram Extra Guard - CA10755) today. No loss of presets in the radio, seats, etc... and battery was relatively easy to access under the front passenger seat. Tried to let the car "cool down" as much as possible before taking out again to see if there was a noticeable change, which there was. Rolling out of the drive way Trans temp (according to the display)


Sent from my iPhone using JeepGarage
__________________

__________________
Reply With Quote
  #423  
Old 06-01-2014, 09:40 PM
Member
My Jeep: 2014 3.6L
 
Join Date: Apr 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 201
SouthGAJeep is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Well- i fat fingered the reply by mistake - continue from previous post... Trans temp around 130 F and in Eco Mode the shifts were much cleaner. Drove in both "stop and go" on the interstate for about an hour.And much like a previous post, just feels like she can breathe a lot easier. Much like a previous post I read, just feels like she can finally breathe a little easier. Will see if it continues - thanks again for the suggestions and will see if it holds up.


Sent from my iPhone using JeepGarage
__________________
Reply With Quote
  #424  
Old 06-01-2014, 09:50 PM
clowenthal's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Long Island, NY
Posts: 188
Thanks: 23
Thanked 13 Times in 11 Posts
Rep Power: 860
clowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

I have 2 2014 JGC Limiteds. The one I received in May 2013 has always had tranny issues. The one I received in September 2013 has been perfect.

I tried the battery pull method before any software updates and it definitely improved the tranny substantially. I then got the tranny software update after the second updated bulletin. I saw no difference after that software update. Since the update my tranny progressively got worse and I would say the last two months has just been awful. When I drive the good JGC it really highlights the difference. In fact it got to the point that I couldn't even drive the JGC properly unless I turned off the ECO mode.

I brought my May 2013 JGC this past week to get my annual inspection, oil change, etc. I told the service manager how awful the tranny was and there is definitely an issue since I have another JGC that's great.

Got the JGC back on Thursday and have driven it over 100 miles since. Wow! It now drives just as good as the September 2013 one!!! They applied the most recent bulletin 21-007-13 and while this in and of itself makes no sense - this JGC has never driven so well! They also applied various powertrain module reflashes as well. Perhaps that also has something to do with it.

My wife picked up the car - they only had it one night and I was very skeptical when I picked it up that it really was fixed. But I have to tell you I'm pleasantly surprised. It's really awesome. All this in ECO mode!!!

So now - the big question - will it last??? Only time will tell.

So if you are still having problems I strongly suggest going back to the dealer and complain about the tranny. Don't give them any bulletins to refer to - just indicate the drive is unacceptable and let them handle. That's what I did.

Hope this helps.
__________________
Reply With Quote
  #425  
Old 06-02-2014, 11:25 PM
Member
My Jeep: 2014 3.6L
 
Join Date: Apr 2014
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 201
SouthGAJeep is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by clowenthal View Post
I have 2 2014 JGC Limiteds. The one I received in May 2013 has always had tranny issues. The one I received in September 2013 has been perfect.

I tried the battery pull method before any software updates and it definitely improved the tranny substantially. I then got the tranny software update after the second updated bulletin. I saw no difference after that software update. Since the update my tranny progressively got worse and I would say the last two months has just been awful. When I drive the good JGC it really highlights the difference. In fact it got to the point that I couldn't even drive the JGC properly unless I turned off the ECO mode.

I brought my May 2013 JGC this past week to get my annual inspection, oil change, etc. I told the service manager how awful the tranny was and there is definitely an issue since I have another JGC that's great.

Got the JGC back on Thursday and have driven it over 100 miles since. Wow! It now drives just as good as the September 2013 one!!! They applied the most recent bulletin 21-007-13 and while this in and of itself makes no sense - this JGC has never driven so well! They also applied various powertrain module reflashes as well. Perhaps that also has something to do with it.

My wife picked up the car - they only had it one night and I was very skeptical when I picked it up that it really was fixed. But I have to tell you I'm pleasantly surprised. It's really awesome. All this in ECO mode!!!

So now - the big question - will it last??? Only time will tell.

So if you are still having problems I strongly suggest going back to the dealer and complain about the tranny. Don't give them any bulletins to refer to - just indicate the drive is unacceptable and let them handle. That's what I did.

Hope this helps.

The change the air filter and disconnect the battery suggestions did help but only for a short while. Only a day after did the harsh shifting rear it's ugly head once again. I was in a parking garage and noticed that the jeep shifted quite prematurely from it's typical habit of hanging on to 2nd for the entire trip into 3rd gear. I thought it was a little odd but nonetheless assumed it must be "learning" how to drive in a parking garage. Just before i was about to make a left onto the ramp to head down to the next level I lifted off the throttle and that is when the fun began... The Jeep, quite violently, slammed from 3rd gear directly into 1st. The sudden deceleration felt more like standing on the brakes rather than a gear change and was so forceful that my brief case laying flat on back seat ended up on the floor directly behind me. For the remainder of the trip down the parking garage, the car refused to shift and practically froze in 1st gear despite my attempts to use the manual shift mode.

So, took your advice and have set an appointment with a dealership in Atlanta that I originally purchased the car from. Will see what they can find and hope the service department was half as good as the sales staff.


Sent from my iPhone using JeepGarage
__________________
Reply With Quote
  #426  
Old 06-03-2014, 05:49 AM
clowenthal's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Long Island, NY
Posts: 188
Thanks: 23
Thanked 13 Times in 11 Posts
Rep Power: 860
clowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Good luck! It's been several more days of driving and my tranny is still going well. Finally, the best drive in over a year! Just be insistent that the tranny isn't normal. Besides the flash updates they have another bulletin that the service department can follow to help correct. So as long as they take you seriously they should be able to correct the situation. Keep us updated!


Sent from my iPhone using JeepGarage
__________________
Reply With Quote
  #427  
Old 06-15-2014, 03:32 PM
Member
 
Join Date: Sep 2013
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 417
Yellowone is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Tried disconnecting the F60 fuse and the negative battery cable..It worked ok for like 10 mins then went back to its old ways. My tranny is too smart :/
__________________
Reply With Quote
  #428  
Old 06-19-2014, 05:08 PM
WeJGCnow's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2014
Posts: 16
Thanks: 3
Thanked 3 Times in 3 Posts
Rep Power: 155
WeJGCnow is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

I cannot, for the life of me, get the negative terminal disconnected. I'm pulling pretty hard, any harder and i feel like i'd do some damage! i tried to loosen the bolt on the clamp, but that didnt work as its on there tight. I couldn't find a socket that fit it and it was too awkward to get a good angle with pliers. Any advice?
__________________
2014 Overland: 3.6L V6, Brilliant Black / Morocco Black, Advanced Technology Group, Mopar cargo mat, Husky X-act Contour front/rear slush mats, WeatherTech front/rear window deflectors
Reply With Quote
  #429  
Old 06-19-2014, 05:09 PM
clowenthal's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Long Island, NY
Posts: 188
Thanks: 23
Thanked 13 Times in 11 Posts
Rep Power: 860
clowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond reputeclowenthal has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

10mm socket


Sent from my iPhone using JeepGarage
__________________
Reply With Quote
The Following User Says Thank You to clowenthal For This Useful Post:
  #430  
Old 06-19-2014, 05:19 PM
WeJGCnow's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2014
Posts: 16
Thanks: 3
Thanked 3 Times in 3 Posts
Rep Power: 155
WeJGCnow is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by clowenthal View Post
10mm socket


Sent from my iPhone using JeepGarage
Thank you sir. I'll try that. Just seems like i shouldn't have to do that, as it sounds like others have been able to just pull it off?
__________________
2014 Overland: 3.6L V6, Brilliant Black / Morocco Black, Advanced Technology Group, Mopar cargo mat, Husky X-act Contour front/rear slush mats, WeatherTech front/rear window deflectors
Reply With Quote
  #431  
Old 06-19-2014, 05:38 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 1,197
Thanks: 38
Thanked 91 Times in 72 Posts
Rep Power: 2309
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by WeJGCnow View Post
Thank you sir. I'll try that. Just seems like i shouldn't have to do that, as it sounds like others have been able to just pull it off?
you should not be able to just pull it off if you can then someone forgot to tighten it. it should be loosened and tightened with 10mm as described above.
__________________
Reply With Quote
The Following User Says Thank You to silvermax04 For This Useful Post:
  #432  
Old 06-19-2014, 05:50 PM
WeJGCnow's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jun 2014
Posts: 16
Thanks: 3
Thanked 3 Times in 3 Posts
Rep Power: 155
WeJGCnow is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by silvermax04 View Post
you should not be able to just pull it off if you can then someone forgot to tighten it. it should be loosened and tightened with 10mm as described above.
I see. I don't seem to have a 10mm socket in the garage, so I guess i'll have to look elsewhere.
__________________

__________________
2014 Overland: 3.6L V6, Brilliant Black / Morocco Black, Advanced Technology Group, Mopar cargo mat, Husky X-act Contour front/rear slush mats, WeatherTech front/rear window deflectors
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Transmission not Shifting gottubes Trouble Shooting/Problems/Service 15 04-30-2013 07:46 PM
Transmission shifting iwearpumas Troubleshooting/Problems 6 06-09-2012 04:58 AM
transmission shifting Delofter77 Trouble Shooting/Problems/Service 4 04-27-2012 02:43 PM
Transmission Shifting Problem txrancher74 Trouble Shooting/Problems/Service 12 06-05-2011 06:15 PM
Transmission shifting right? wjs81866 Trouble Shooting/Problems/Service 4 10-22-2010 09:14 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community