Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #61  
Old 06-12-2013, 08:10 AM
studio1930's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Posts: 268
Thanks: 19
Thanked 21 Times in 13 Posts
Rep Power: 1211
studio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond reputestudio1930 has a reputation beyond repute
Garage
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by Icetech View Post
I'm glad im not the only one that hates this trans.. i have only driven manuals for 25 years and thought maybe it was just that im not used to a auto..

What i find worse is that in econo mode its in 8th gear by 40mph.. which means i now i have to stand on the gas so it can downshift to 4th or 5th to get upto 50..

And while im on the subject of econo mode.. why the hell didnt they make it standard mode upto like 30-40mph.. when i take off froma light in econo/standard or sport i watch the MPG drop to 2-3 mpg anyway..

And yeah yeah.. turn econo off.. got it
If yours is like mine, do the battery reset and you shouldn't have to turn off ECO mode anymore. I was constantly turning off ECO mode or using Sport mode to keep from being in 4th gear by 17 mph. After the battery reset, my gears are normal and I leave ECO mode on now.
__________________

__________________
--------------------------------------------------------
2014 Grand Cherokee Overland 4x4, Max Steel, Morocco Black int, ORA II, ATG

Reply With Quote
  #62  
Old 06-12-2013, 08:22 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Posts: 327
Thanks: 0
Thanked 10 Times in 10 Posts
Rep Power: 929
geox19 has a reputation beyond reputegeox19 has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Reset is still working for me. I love this transmission hooked up to the Hemi. The one I test drove did all the same things so I knew what to expect. I abused the hell out of the one I test drove. If I'm paying 50k for an suv I'm sure going to test drive the crap out of it. This thing hauls butt for a 5400 pound suv and it's nice and quiet and mostly smooth when I'm in eco mode best of both worlds IMO. I wish I didn't need to go off-road from time to time I would have got the SRT8. You guys that hate the Trans did you not go on a long enough test drive ?? If you always driven stick then there should be no problem reaching for the little silver lever on the left side of the steering wheel to find that gear you're looking for not sure what gear it will put you in coming from 8th I'll have to give it a try I think it will work with out having to be in sport mode. I'm pretty sure this ZF trans is The same one they use in the bmw 7 series?
__________________

__________________
Reply With Quote
  #63  
Old 06-12-2013, 08:51 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 990
Thanks: 6
Thanked 51 Times in 38 Posts
Rep Power: 3663
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by peejym View Post

Think he did it to dissipate residual power though the brake lights. I ass-u-me
Yes, that's exactly why!



And to everyone else,

Yes my tranny still shifts smooth, but I just want to make everyone aware that downshifts into 1st and 2nd are firmer than the rest of the gears...100% smoother than before, but firmer than the other 6 gears. Those two gears I would assume will get smoother over time.

My main issue with the my 8sp tranny was before the reset it would not downshift quickly when I would take my foot off the gas, causing a clunk once hitting 2nd and 1st before stopping completly.

As for turning on the A/C while in ECO mode and seeing if I get any rough shifting...I'll give that a try when I get the chance and let everyone know.
__________________
I Hate My Jeep Yet Again...
Reply With Quote
  #64  
Old 06-12-2013, 10:23 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Posts: 326
Thanks: 2
Thanked 4 Times in 4 Posts
Rep Power: 965
peejym has disabled reputation
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by GCLimited View Post
As for turning on the A/C while in ECO mode and seeing if I get any rough shifting...I'll give that a try when I get the chance and let everyone know.
Yes please do for this is what I am experiencing the most now, I re-did the fuse method and it seems very smooth now. Maybe I am causing the clunk downshift by the way I am slowing down.
__________________
Reply With Quote
  #65  
Old 06-12-2013, 10:52 AM
Sh0rtBus's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: North Texas
Posts: 393
Thanks: 0
Thanked 12 Times in 12 Posts
Rep Power: 2373
Sh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond reputeSh0rtBus has a reputation beyond repute
Garage
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Okay, so I don't know how I missed this one, but I'm going to try this when I get home this afternoon.
__________________
2011 Jeep Wrangler Unlimited Rubicon

2014 Grand Cherokee Limited 4x4 3.6L Deep Cherry Red

Reply With Quote
  #66  
Old 06-12-2013, 11:47 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Fresno, CA
Posts: 226
Thanks: 22
Thanked 7 Times in 5 Posts
Rep Power: 904
adthebadstud is on a distinguished road
Garage
Help! I thought I followed the directions correctly... Put everything back (I think) and now the car is totally dead! I have a appointment in a half hour. Do I need it towed or is there any idea how to fix?
__________________
2014 Overland 4x4 V6, Black ext, Black int, Advanced Tech Package. EC169841

My First Jeep. Current Status: Chrysler Buy Back (It's for sale in Wisconsin! http://www.vanhorndodge.com/vehicle-...-wi-id-6432659
Reply With Quote
  #67  
Old 06-12-2013, 12:15 PM
Member
My Jeep: 2014 3.6L
 
Join Date: May 2013
Location: Smithtown, NY
Posts: 28
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 615
kwtengine2 is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

I'm a bit confused. Does the fuse method work or am I betor off pulling the negative? Also does the truck have to be running for the fuse method?
__________________
Reply With Quote
  #68  
Old 06-12-2013, 12:21 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Illinois
Posts: 36
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 645
MTC595 is on a distinguished road
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Hi.

I reset my TCM by pulling the fuse, and after 2 1/2 days of driving to work (60 miles round trip - no hwy), it's still smooth and responsive.

The car should be completely OFF when you pull the fuse. I just removed it and let the car sit for 20 minutes. Put the fuse back in and start it up.

Go for a test drive and drive normally. Don't baby it like you might have done during the break in period.

Mike
__________________
Reply With Quote
  #69  
Old 06-12-2013, 12:35 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 861 Times in 470 Posts
Rep Power: 1927149
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by kwtengine2 View Post
I'm a bit confused. Does the fuse method work or am I betor off pulling the negative? Also does the truck have to be running for the fuse method?
Never pull fuses from a vehicle that is running that is a really bad idea. Unless of course your mechanic and you absolutely know what you're doing
__________________
Reply With Quote
  #70  
Old 06-12-2013, 12:36 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,391
Thanks: 341
Thanked 368 Times in 319 Posts
Rep Power: 1801969
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by adthebadstud View Post
Help! I thought I followed the directions correctly... Put everything back (I think) and now the car is totally dead! I have a appointment in a half hour. Do I need it towed or is there any idea how to fix?
If all you did was pull the battery clamp, double check that it is firmly back in place.

If you pulled the fuse, be sure you didn't damage it.

Nothing in either of these methods, if done correctly' would leave you with a 'dead' Jeep.


---
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
  #71  
Old 06-12-2013, 02:20 PM
Northland's Avatar
I go where my Jeep goes.
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2012
Posts: 447
Thanks: 15
Thanked 29 Times in 24 Posts
Rep Power: 1644
Northland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond repute
Re: I Think I Fixed My Rough Shifting 8sp Transmission

I did the remove-the-negative-terminal procedure last night - left it off about 50 minutes. Haven't driven it much today, but indeed it seems to shift much better and I'm leaving it in Eco mode which I couldn't stand to do before! Props to GCLimited for this thread, and I'll leave a "Thanks" on the first post to up your count!

FYI - I didn't pump the brakes after I removed the neg terminal. I've worked on cars for years and from experience have learned that if you leave the battery disconnected for 45-50 minutes there will be no power left in any electrical system in the vehicle - including the air bags. There are capacitors in the SRS in most vehicles, but after that long disconnected from power even they will completely discharge.
__________________
Ordered 2/04/13, Built and Status KZ (Plant Release) on 2/19/13, delivered 2/28/13: 2014 Limited 4x4 in Bright White with Lt. Frost Beige interior; Hemi V8; ORA II; RA4 UConnect.
So far: 20% tint all around; black BT oil catch can; Jeep slush and cargo mats; Blackvue DR500GW-HD dashcam; DropStops; XtremeDigital 4300K low beam HIDs; 5000K LED fog lights; Airaid CAI with SynthaMax dry filter. And now rollin' with UConnect 14.25.05!!
Reply With Quote
  #72  
Old 06-12-2013, 04:21 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Fresno, CA
Posts: 226
Thanks: 22
Thanked 7 Times in 5 Posts
Rep Power: 904
adthebadstud is on a distinguished road
Garage
Re: I Think I Fixed My Rough Shifting 8sp Transmission

Quote:
Originally Posted by bill_de View Post
If all you did was pull the battery clamp, double check that it is firmly back in place.

If you pulled the fuse, be sure you didn't damage it.

Nothing in either of these methods, if done correctly' would leave you with a 'dead' Jeep.


---
I was an idiot. Just didn't put it back in place right. All it took was a second set of eyes. Got it all figured out and works great!
__________________

__________________
2014 Overland 4x4 V6, Black ext, Black int, Advanced Tech Package. EC169841

My First Jeep. Current Status: Chrysler Buy Back (It's for sale in Wisconsin! http://www.vanhorndodge.com/vehicle-...-wi-id-6432659
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 Transmission not Shifting gottubes Trouble Shooting/Problems/Service 15 04-30-2013 07:46 PM
Transmission shifting iwearpumas Troubleshooting/Problems 6 06-09-2012 04:58 AM
transmission shifting Delofter77 Trouble Shooting/Problems/Service 4 04-27-2012 02:43 PM
Transmission Shifting Problem txrancher74 Trouble Shooting/Problems/Service 12 06-05-2011 06:15 PM
Transmission shifting right? wjs81866 Trouble Shooting/Problems/Service 4 10-22-2010 09:14 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:10 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.