Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-25-2013, 08:25 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2013
Location: Michigan
Posts: 833
Thanks: 5
Thanked 18 Times in 13 Posts
Rep Power: 127154
loveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond repute
Idiot problem

So I am having issues with a HID kit install. Long story short I was messing with the wires on the passenger side when the wires from the relay which essentially are hooked up to the drivers side headlight harness managed to ground out on whatever aluminum that is in from of the power distribution center (pcm or whatever it is...) Since I am a idiot and had the headlights on at the time it sparked a few times, then the drivers side headlight went out. I am guessing it is a fuse somewhere but I can't seem to find it, the passenger side works, just the drivers side is out. The owners manual lists a location for HID headlight fuses for both sides (which both are good) but does not list them for the standard lights. Anyone have a clue as to which one it is? Or should I go fuse by fuse through it to try and find it (I realllllly don't want to do this but it beats pulling everything back out and playing dumb at the dealer as to why the light doesn't work.
__________________

__________________
Reply With Quote
  #2  
Old 04-25-2013, 09:40 AM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,418
Thanks: 55
Thanked 132 Times in 114 Posts
Rep Power: 542612
robpp has disabled reputation
Re: Idiot problem

wkjeeps.com lists all relays and fuses.

if its not one of them then it MAY be you fried the FCM which controls the headlights.


dont take this the wrong way but on a modern day vehicle with a canbus and electrrical modules doing things......you should never touch anything electrical without dsicnnecting your neg terminal. I owned a wk for 4.5 years and I wore out the neg terminal hardware i disconnected it so many times.


i hope its ONLY your fcm cause it could be the PCM which will be more than a G to fix.

GL.
__________________

__________________
Reply With Quote
  #3  
Old 04-25-2013, 09:57 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,095
Thanks: 859
Thanked 935 Times in 669 Posts
Rep Power: 7717708
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Idiot problem

try pulling the negative off and resetting the system first. Pull the negative terminal...step on the brake pedal a couple times and wait 10 minutes or so.
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #4  
Old 04-26-2013, 07:18 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2013
Location: Michigan
Posts: 833
Thanks: 5
Thanked 18 Times in 13 Posts
Rep Power: 127154
loveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond reputeloveracing1988 has a reputation beyond repute
I think it must have turned the wire into a fusible link or something else on the relay harness went bad. I plugged a regular bulb in and it turned on just fine, I still don't know what fuse it is, the headlights still work with both of the hid headlight fuses pulled so I'm sure it is one that isn't labeled.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
idiot lights cmk1 Troubleshooting/Problems 8 12-27-2011 10:43 PM
I'm An Idiot kyle.jg Grand Cherokee - WK 12 08-11-2011 08:45 PM
Want to see what your bumper will look like if you offroad like an idiot? BHHJEEP Grand Cherokee - WK2 - 11 06-02-2011 07:53 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:30 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community