Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 10-29-2011, 10:24 AM
Premium Member
 
Join Date: Sep 2010
Location: brOOklyn
Posts: 1,256
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2827
JoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond repute
Re: Infamous "key not detected" problem.

I had TSB I mentioned 2 posts above done. Yesterday I had "key has left the vehicle" message after I stepped out and stepped back in the car.
__________________

__________________
Reply With Quote
  #26  
Old 10-29-2011, 11:15 AM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jul 2011
Location: Phoenix, az
Posts: 181
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1433
Kevlars has a reputation beyond reputeKevlars has a reputation beyond repute
Re: Infamous "key not detected" problem.

ya ... it is weird got the message key has left the car... I stopped the car, turned off ... remote locked and unlocked the car and then turned back on as I had just pulled it out of the driveway ... and all ok.

Just seems that I had no issues then all of a sudden they just started happening and with more frequency. I will you all know what the dealer says ... probably will order me a new FOB.
__________________

__________________
Jeep Grand Cherokee 2011
Overland Summit W/ORII
Hemi 5.7L
285 60 R18 Yokohama Geolander A/T -S
Mopar Rock Rails

[SIGPIC][/SIGPIC]
Reply With Quote
  #27  
Old 01-12-2012, 06:29 PM
1200RT-P's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: May 2011
Location: Santa Monica, CA
Posts: 680
Thanks: 9
Thanked 5 Times in 5 Posts
Rep Power: 2283
1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute
Re: Infamous "key not detected" problem.

Happened to me today for the first time in 14k miles.

Walked up to car, grabbed handle, unlocked as normal, pressed start button, "key not detected". Took it out of my pocked, pressed again, "key not detected". Repeated twice, "key not detected". Pressed it again, car tried to turn over for about 30 seconds, failed to start. Pressed start button again, engine turned over, RPMs to idle speed for a few seconds, car died. Tried one last time, turned over like normal, drove away.

Ran some errands, turned car off and on 6 times at various locations, no more issues.

Strange and disconcerting.
__________________

2011 JGC WK2 - Laredo X - 5.7 - 4x4 - 430N(RHB)
2010 Audi S4 - BMW 1150RT (Mine) - BMW 1200RT-P (Theirs)
Reply With Quote
  #28  
Old 01-16-2012, 02:24 AM
No1Spcl's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Nov 2011
Location: Australia
Posts: 25
Thanks: 0
Thanked 2 Times in 1 Post
Rep Power: 1147
No1Spcl is on a distinguished road
Re: Infamous "key not detected" problem.

Hey Sydneyj gotta say thanks, this exact same thing happened to me, I put a electric break controller in my car and afterwards it didn't work, I'd ran a extra break wire back to the tow bar, as I was reading your post I recalled seeing the blue connector not connected and now I realised where it went, took 5 minutes to fix. Car is booked to go to dealer in 2 days to fix this issue.
__________________
Reply With Quote
  #29  
Old 01-17-2012, 08:57 PM
Premium Member
 
Join Date: Sep 2010
Location: brOOklyn
Posts: 1,256
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2827
JoeSchmoe007 has a reputation beyond reputeJoeSchmoe007 has a reputation beyond repute
Re: Infamous "key not detected" problem.

Quote:
Originally Posted by 1200RT-P View Post
Happened to me today for the first time in 14k miles.

Walked up to car, grabbed handle, unlocked as normal, pressed start button, "key not detected". Took it out of my pocked, pressed again, "key not detected". Repeated twice, "key not detected". Pressed it again, car tried to turn over for about 30 seconds, failed to start. Pressed start button again, engine turned over, RPMs to idle speed for a few seconds, car died. Tried one last time, turned over like normal, drove away.

Ran some errands, turned car off and on 6 times at various locations, no more issues.

Strange and disconcerting.
Take remote apart and put it back together (equivalent of removing battery). After I did this I never had the problem again (yet, it's been several weeks).
__________________
Reply With Quote
  #30  
Old 01-24-2012, 12:46 AM
1200RT-P's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: May 2011
Location: Santa Monica, CA
Posts: 680
Thanks: 9
Thanked 5 Times in 5 Posts
Rep Power: 2283
1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute1200RT-P has a reputation beyond repute
Re: Infamous "key not detected" problem.

Quote:
Originally Posted by JoeSchmoe007 View Post
Take remote apart and put it back together (equivalent of removing battery). After I did this I never had the problem again (yet, it's been several weeks).
Thanks for the tip. It hasn't happened again since that incident, so we'll see. Strange, the key was in the same place it always is - no question it was in range of the sensor.
__________________

2011 JGC WK2 - Laredo X - 5.7 - 4x4 - 430N(RHB)
2010 Audi S4 - BMW 1150RT (Mine) - BMW 1200RT-P (Theirs)
Reply With Quote
  #31  
Old 02-10-2012, 01:05 AM
bigpanda's Avatar
Member
 
Join Date: Feb 2011
Posts: 321
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2097
bigpanda has a reputation beyond reputebigpanda has a reputation beyond reputebigpanda has a reputation beyond reputebigpanda has a reputation beyond reputebigpanda has a reputation beyond reputebigpanda has a reputation beyond reputebigpanda has a reputation beyond reputebigpanda has a reputation beyond reputebigpanda has a reputation beyond reputebigpanda has a reputation beyond reputebigpanda has a reputation beyond repute
Re: Infamous "key not detected" problem.

It happened first time yesterday. Key was in and car was running and suddenly "key has left" warning sign popped up. Someone said there's TSB for this and does anyone know which TSB is for this problem? Thanks.
__________________
Life is Good!!!:thumbsup:

2011 WK2 Overland 3.6 Euro Spec.
Reply With Quote
  #32  
Old 02-10-2012, 11:47 AM
tmw1582's Avatar
Member
My Jeep: 2011 3.6L
 
Join Date: Mar 2011
Location: Orland Park, IL
Posts: 59
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1406
tmw1582 is on a distinguished road
Re: Infamous "key not detected" problem.

Quote:
Originally Posted by bigpanda View Post
It happened first time yesterday. Key was in and car was running and suddenly "key has left" warning sign popped up. Someone said there's TSB for this and does anyone know which TSB is for this problem? Thanks.
One tip I learned from my dealer is that sometimes the prongs that touch the actually battery get pushed down (when you are pushing any of the buttons on the fob) so open your fob, take the battery out and push the little prongs up so they make better contact with the battery.

When I start to get the message every now and again I just replace the battery and the issue goes away.
__________________
Reply With Quote
  #33  
Old 02-10-2012, 03:16 PM
New Member
 
Join Date: Dec 2011
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
DubstepJeep is on a distinguished road
Re: Infamous "key not detected" problem.

The issue I've seen with the key fobs is in the battery connection. On the older modles if you take apart the key take a look at the circuit board. There are four prongs that make contact with the battery itself. Bend the tabs upwards a bit and it should fix the issue. What is happening if the when the key was made the contact prongs are under one of the rubber buttons on the key fob. When the button is pressed over a period of time it flattens the prongs and the key looses power from the battery.
__________________
Reply With Quote
  #34  
Old 02-10-2012, 08:33 PM
windycityjeep's Avatar
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2011
Location: Chicago
Posts: 85
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1152
windycityjeep is on a distinguished road
Re: Infamous "key not detected" problem.

just happend last week, dealer replaced both fobs and its fine now
__________________
Reply With Quote
  #35  
Old 03-03-2012, 11:11 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Oct 2011
Location: Burlington, Ont
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1162
TBradS is on a distinguished road
Re: Infamous "key not detected" problem.

I too am having a similar problem in my 2011. I get the "Key Not Detected" message. And sometimes the doors will not unlock when touching the handle. Remote start is also intermittent. Eventually after maybe a half dozen presses of the button, and moving the fob around, it will start, but it seems to be a bit of a crap-shoot. This occurs with both fobs, one of which rarely gets used. A month ago, the dealer did the flash update and it seemed a bit better...now it's bad again. Back to the dealer, I guess.
__________________
Reply With Quote
  #36  
Old 03-03-2012, 07:11 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Dec 2011
Location: Central, NJ
Posts: 76
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1275
bry@n has a reputation beyond reputebry@n has a reputation beyond reputebry@n has a reputation beyond reputebry@n has a reputation beyond reputebry@n has a reputation beyond reputebry@n has a reputation beyond repute
Re: Infamous "key not detected" problem.

My wifes jeep is at the dealer for this issue again. They are replacing the PEM and both fobs.
__________________

__________________
2011 WK2 Wifes
2012 WK2 Mine
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Key FOB Recognition Issue (Key not detected) JGC_DelSiggy Trouble Shooting/Problems/Service 21 05-20-2013 08:38 PM
Viper 5701 remote start "verification" problem Wrathwielder Audio, Video, Navigation & Electronic Modifications 2 09-28-2011 10:19 PM
Key not detected - still occuring Kirman Technical Service Bulletins and Recalls 2 06-23-2011 01:47 PM
Garmin/430N nav problem: Address/City/Intersection "washed out" and not accessible! ctwickman Audio/Visual/Navigation 4 11-28-2010 11:58 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:00 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.