Keyless ignition problems, again, and again. - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-11-2014, 07:39 AM
Member
 
Join Date: Oct 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1000
lee308 is on a distinguished road
Keyless ignition problems, again, and again.

2012 GC 2WD, 14K miles.

Push button ignition stopped working saying "bad key". Has now been back and serviced by dealer 4 times, under warranty and they can't seem to fix it. (works a day or so and stops working, have to use keyfob as key) Its working for the moment.

(sometimes the passive entry button on door handle would not work)

They replaced the Ign Switch and Passive Entry VOR, (again)

Now they have damaged the fiber panel under the dash taking it on and off so much and reinstalled it with velcro.

Is the Keyless Ignition a problem child? This looks bad when out of warranty.

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-11-2014, 07:47 AM
bill_de's Avatar
Premium Member
My Jeep: 2017 5.7L WK2
 
Join Date: Sep 2012
Posts: 8,661
Thanks: 742
Thanked 1,092 Times in 850 Posts
Rep Power: 1806091
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: Keyless ignition problems, again, and again.

I've only noticed 2 recent posts on the issue ... both yours.

Try a Google search starting with "Jeep Garage:"


---
__________________
If you need a shoulder to cry on ...
... pull over to the side of the road!

Reply With Quote
  #3  
Old 10-11-2014, 07:53 AM
1stJeepGC's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2011
Location: NYC Area
Posts: 1,633
Thanks: 245
Thanked 204 Times in 181 Posts
Rep Power: 27458
1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute
Re: Keyless ignition problems, again, and again.

Quote:
Originally Posted by lee308 View Post
2012 GC 2WD, 14K miles.

Push button ignition stopped working saying "bad key". Has now been back and serviced by dealer 4 times, under warranty and they can't seem to fix it. (works a day or so and stops working, have to use keyfob as key) Its working for the moment.

(sometimes the passive entry button on door handle would not work)

They replaced the Ign Switch and Passive Entry VOR, (again)

Now they have damaged the fiber panel under the dash taking it on and off so much and reinstalled it with velcro.

Is the Keyless Ignition a problem child? This looks bad when out of warranty.
Greetings and welcome,

I had FOB module replace after the first year. Sometimes, I get a bad key coming up and my service center just reprograms it for me and it clears up.

DID THEY CHANGE THE REMOTE'S?

I assume this is the same center you bring it too every time. If this occurs again and you still under warranty or not, do not be afraid to bring it to a another service center. Not all Grade A tech's have the same diagnosis skills. I have seen this many time thru many years. This problem is a combination of electrical and computers. Some tech's just think swap and replace and it works.

Best for now.
__________________
Laredo X, Trail Rated, QTii, Sele-Terrian, Quadra Lift, Off-Road Adventure Package ii, GY 265/60/R18 Duratrac, (Retired Nokian Rotiva AT after 57.6K will miss them), Tow, AFE CAI, DiabloSport inTune 1000-DCX, Custom Sound System ( HAT speakers, JLAudio , Pioneer , JBL MS-8 & RF 3.sixty.3 -- see the writeup link below for more details)

http://www.jeepgarage.org/f155/2011-...ver-79121.html
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 10-11-2014, 07:59 AM
Member
 
Join Date: Oct 2014
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1000
lee308 is on a distinguished road
Re: Keyless ignition problems, again, and again.

Yes, they changed Key Fobs.
Reply With Quote
  #5  
Old 10-11-2014, 08:29 AM
1stJeepGC's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jul 2011
Location: NYC Area
Posts: 1,633
Thanks: 245
Thanked 204 Times in 181 Posts
Rep Power: 27458
1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute1stJeepGC has a reputation beyond repute
Re: Keyless ignition problems, again, and again.

Quote:
Originally Posted by lee308 View Post
Yes, they changed Key Fobs.

Greetings,

I assume it is still working right now?

If it starts up again, I would take all the paperwork that you have and bring it to another dealer. If you have the same problems again, then you cause force them to bring this to the attention of Chrysler and open up a case # for a specialist to come down.

Best for now.
__________________
Laredo X, Trail Rated, QTii, Sele-Terrian, Quadra Lift, Off-Road Adventure Package ii, GY 265/60/R18 Duratrac, (Retired Nokian Rotiva AT after 57.6K will miss them), Tow, AFE CAI, DiabloSport inTune 1000-DCX, Custom Sound System ( HAT speakers, JLAudio , Pioneer , JBL MS-8 & RF 3.sixty.3 -- see the writeup link below for more details)

http://www.jeepgarage.org/f155/2011-...ver-79121.html
Reply With Quote
  #6  
Old 10-16-2014, 12:33 PM
Raptor's Avatar
Member
 
Join Date: Sep 2011
Posts: 821
Thanks: 7
Thanked 70 Times in 62 Posts
Rep Power: 328769
Raptor has a reputation beyond reputeRaptor has a reputation beyond reputeRaptor has a reputation beyond reputeRaptor has a reputation beyond reputeRaptor has a reputation beyond reputeRaptor has a reputation beyond reputeRaptor has a reputation beyond reputeRaptor has a reputation beyond reputeRaptor has a reputation beyond reputeRaptor has a reputation beyond reputeRaptor has a reputation beyond repute
Re: Keyless ignition problems, again, and again.

Did they change the WIN Module? Might be your problem.

The WIN module is a Wireless Ignition Node module. It's located behind the digital dash in all WK2's. It's the module that allows the wireless keyless ignition system to work. But it is also used for other things...... From a 2012 Factory Service Manual;

08 - Electrical / 8E - Electronic Control Modules / RECEIVER, Wireless Ignition Node / Description

DESCRIPTION

This vehicle is equipped with a Wireless Ignition Node (WIN). The WIN, along with the FOB with Integrated Key (FOBIK) are the primary components of the keyless ignition system. The only visible component of the WIN is the ignition switch located on the face of the instrument panel just to the inboard side of the steering column. The remainder of the WIN including its mounting provisions and electrical connections are concealed within the instrument panel.
The WIN housing is constructed of molded black plastic and includes four integral mounting bosses, which are secured to the instrument panel structure with screws. Two connector receptacles are integral to the back of the switch housing. One connects the WIN to the vehicle electrical system through a dedicated takeout and connector of the instrument panel wire harness. The other is a dedicated connector for the coaxial cable input from the optional remote start system external antenna module.

In addition to replacing a conventional keyed ignition switch, the WIN is an integrated electronic receiver that serves as the base station in the vehicle. It communicates with other electronic modules in the vehicle over the Controller Area Network (CAN) data bus.
The WIN interfaces with the Remote Keyless Entry (RKE) FOBIK and the Tire Pressure Monitor (TPM) sensors (if equipped) using Radio Frequency (RF) communication, with the Immobilizer System (theft) transponder within the FOBIK using Low Frequency (LF) RF communication. It also communicates with the TPM trigger transponders (if equipped) and electronic shaft lock module (if equipped) using a Local Interface Network (LIN) data bus connection.
The WIN provides a switched 12-volt source through an isolated switch for the electronic shaft lock module required for certain export market vehicles and contains a key removal inhibit solenoid, an electronic Brake Transmission Shift Interlock (BTSI) solenoid, a key-in warning contact and it serves as the real time vehicle clock by transmitting the clock information to other electronic modules over the CAN data bus.
The WIN cannot be adjusted or repaired, but is flash update capable. If ineffective or damaged the entire WIN must be replaced.
Reply With Quote
  #7  
Old 12-17-2014, 04:10 AM
67HR's Avatar
Member
My Jeep: 2014 3.0L WK2
 
Join Date: Dec 2014
Location: Albany Western Australia
Posts: 347
Thanks: 180
Thanked 53 Times in 50 Posts
Rep Power: 1280
67HR is on a distinguished road
Re: Keyless ignition problems, again, and again.

I noticed this message (see pic) flash up on the display this morning, went into display and checked all was ticked. Funny thing is the keyless locking wasn't working yesterday.
The only thing I can think is I had a tralier hitch fitted and hard wired in the day before.

has anyone else experienced this or seen this message?
Attached Images
File Type: jpg IMAG0686.jpg (172.9 KB, 16 views)
Reply With Quote
  #8  
Old 12-21-2014, 04:12 PM
walt_mink's Avatar
Member
 
Join Date: Feb 2012
Location: Seattle, WA
Posts: 124
Thanks: 7
Thanked 9 Times in 7 Posts
Rep Power: 2088
walt_mink is on a distinguished road
Re: Keyless ignition problems, again, and again.

Quote:
Originally Posted by 67HR View Post
I noticed this message (see pic) flash up on the display this morning, went into display and checked all was ticked. Funny thing is the keyless locking wasn't working yesterday.
The only thing I can think is I had a tralier hitch fitted and hard wired in the day before.

has anyone else experienced this or seen this message?
I just got the same message along with 'service active headlight' system (or something along those lines) after getting my car back from the body shop on Friday. I guess I'll have the body shop deal with it since there doesn't seem to be a DIY fix.

It's amazing how used to the feature you get. I feel like I'm back to wind up windows and non-boosted brakes.
__________________
Ordered on 8/12/13: 2014 JGC Overland Summit with CRD in Maximum Steel Granite.
Picked up on 11/23/13. This thing is awesome!
Lemon Law return on 4/29/15. Well ... awesome, but unreliable. LOL. :(
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyless ignition problem again, and again.... lee308 Troubleshooting/Problems Discussion 1 10-18-2014 02:57 AM
Killing Engine in Neutral Keyless Ignition Sponge Bob Grand Cherokee - WK2 - 5 01-29-2014 07:03 PM
Flat battery again..and again..and again..etc. spikelet Troubleshooting/Problems 4 07-15-2013 09:34 AM
Keyless ignition wont work after stereo installation yshoef Audio/Visual/Navigation 3 08-09-2012 06:23 AM
Keyless ignition wont work after stereo installation yshoef Trouble Shooting/Problems/Service 7 08-07-2012 03:48 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:44 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.