Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-21-2014, 08:25 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Nov 2013
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 298
11Hemi is on a distinguished road
Losing Coolant

My 2011 WK2 with the Hemi has been steadily loosing coolant. I had the water pump replaced at 41k. It currently has 49k.

The overflow was empty approximately 1k ago when I had my mishap with the washer fluid in that reservoir that many of you may have read about. I drained the washer fluid out then and filled it up to full with 50/50 mopar coolant and water. It is at the add mark again in just over two weeks.

There are no obvious leaks anywhere, cannot smell coolant in the engine bay or around the radiator. The exhaust contains a ton of white smoke when first started warm. It does not smell badly of coolant but does not smell like normal exhaust either. The oil for both the engine and transmission is clean and not contaminated with coolant.

Does anybody else think this may be head gasket related?
__________________

__________________
Reply With Quote
  #2  
Old 01-22-2014, 07:57 AM
BuckeyeSRT's Avatar
Senior Member
My Jeep: 2012 5.7L WK2
 
Join Date: Mar 2011
Location: Home of the Buckeyes
Posts: 1,573
Thanks: 28
Thanked 26 Times in 26 Posts
Rep Power: 102257
BuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond reputeBuckeyeSRT has a reputation beyond repute
Re: Losing Coolant

The only thing I would suggest is keeping an eye on the water pump weep hole. It sounds like a few of us are on our 2nd and 3rd water pump. If it was a head gasket issue wouldn't you see some oil in the coolant or visa versa?
__________________

__________________
2012 BB Overland Summit
Like my company on Facebook ...please
https://www.facebook.com/TheSimmondsGroup
Twitter @simmondsgroup
Reply With Quote
  #3  
Old 01-22-2014, 01:50 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2013
Location: NJ
Posts: 375
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 750
Evolv0 is just really nice
Re: Losing Coolant

since you had it replaced not too long again and you did just disconnect and drain the container, it could just have had air in the system that is working its way out of the system. just add again and keep an eye on it.
__________________
Engine- AFE Intake, Moe's 87mm TB, BT CatchCan.
Exhaust- Magnaflow 11385 Xpipe in the center and 2x Magnaflow 14814's in the rear.
Wheels- 20x9 SRT8 Reps, Hankook Ventus ST RH06.
SRT8 Brembo BBK + GoodRidge SS Brake Lines.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Losing throttle cherokee517 Troubleshooting/Problems 6 10-05-2013 10:01 AM
losing coolant jdubgrand Troubleshooting/Problems 2 07-04-2012 12:30 AM
Hemi Losing Coolant! Chaoul1 Grand Cherokee - WK 26 06-09-2011 07:40 PM
high pitch noise, losing coolant 2004 Laredo Perfectbackstage Troubleshooting/Problems 11 07-13-2009 09:05 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community