Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-02-2013, 01:44 AM
erikgenerik's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2013
Location: San Antonio, TX
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 421
erikgenerik is on a distinguished road
Lost cruise control after TSB flash...

So I went today to have my '14 grand cherokee limited flashed with the TSB to fix the auto start AC issue. I used CC on the way to the dealership and on the way home I noticed that the CC would no longer turn on. I'd hit the button and the little speedometer wouldnt pop up in the cluster and CC would not function...crazy huh? On the up side, the AC now works with auto start! Gonna call the dealership in the morning and see what they can tell me. Anyone else have this issue?
__________________

__________________
Reply With Quote
  #2  
Old 10-12-2013, 01:04 PM
Member
 
Join Date: Jul 2013
Posts: 494
Thanks: 2
Thanked 21 Times in 16 Posts
Rep Power: 17751
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: Lost cruise control after TSB flash...

I think I have run into the same issue... were you able to get the cruise control issue resolved?
__________________

__________________
Reply With Quote
  #3  
Old 10-13-2013, 07:17 PM
erikgenerik's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2013
Location: San Antonio, TX
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 421
erikgenerik is on a distinguished road
Re: Lost cruise control after TSB flash...

I haven't had a chance to get back to the dealership to get it fixed yet. They said I'd have to drop it off and leave it for the day (possibly) and I just don't have the time do that yet. I'm not planning a trip anytime soon so I don't need it right away but it would be nice to have it fixed. When I called the stealership they said they'd never heard of that problem. Did you ask your dealer about it? If so what'd they say?
__________________
Reply With Quote
  #4  
Old 10-13-2013, 08:51 PM
Member
 
Join Date: Jul 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 479
Jecko33 is on a distinguished road
In the same boat. Don't know exactly when I lost it, either after AC fix or new update. I reflashed 13.38.52 and it is still not working.
__________________
Reply With Quote
  #5  
Old 10-14-2013, 07:47 AM
Member
 
Join Date: Jul 2013
Posts: 494
Thanks: 2
Thanked 21 Times in 16 Posts
Rep Power: 17751
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: Lost cruise control after TSB flash...

I just had the flash done on Saturday and noticed it afterwards. They screwed up on the update of the uConnect and only bumped me to 13.19 instead of the latest version. I am going to upgrade myself and see if that fixes it, if not I'll mention it when I get my next oil change.

I did some searching and the only other person I saw with this issue had the cruise control switch replaced. Not sure how they are related but either the HVAC update or uConnect upgrade, but....
__________________
Reply With Quote
  #6  
Old 10-14-2013, 10:49 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,163
Thanks: 214
Thanked 161 Times in 129 Posts
Rep Power: 89633
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: Lost cruise control after TSB flash...

Could just be a coincidence. I did the Uconnect update a week ago, and on a 300 mile road trip this weekend, the cruise worked just fine. Hope you guys can get this resolved. I know I use my cruise quite a lot, and would miss it a bunch.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #7  
Old 10-15-2013, 06:32 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 530
robertrichhart is on a distinguished road
Re: Lost cruise control after TSB flash...

Just back from the local dealer after restoration of our cruise control! Dealer had flashed the uconnect upgrade last Friday and after picking up vehicle we noticed that cruise control did not work at all. Called the dealer on Monday and took the GC in for them to resolve. They called me an hour later and said Chrysler told them to disconnect the battery and connect the leads for a short period, then reconnect. Cruise control is back!
__________________
Reply With Quote
  #8  
Old 10-16-2013, 08:26 AM
Member
 
Join Date: Jul 2013
Posts: 494
Thanks: 2
Thanked 21 Times in 16 Posts
Rep Power: 17751
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: Lost cruise control after TSB flash...

I might be having a dumb moment here... ok, no might about it, what did they mean by connect the leads after disconnecting the battery?
__________________
Reply With Quote
The Following User Says Thank You to TurboRush For This Useful Post:
  #9  
Old 10-16-2013, 07:01 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 530
robertrichhart is on a distinguished road
Re: Lost cruise control after TSB flash...

My understanding is that they removed the battery leads and touched them together which allowed any residual current to drain out of the radio or other electronics in the vehicle. That allowed a complete reboot for all electronics when the battery was reconnected and the vehicle was started again for the first time...
__________________
Reply With Quote
  #10  
Old 10-16-2013, 07:19 PM
Member
 
Join Date: Jul 2013
Posts: 494
Thanks: 2
Thanked 21 Times in 16 Posts
Rep Power: 17751
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: Lost cruise control after TSB flash...

Ahhhh yes that makes sense, thanks for clarifying. Week give that a shot as soon as I have a chance.
__________________
Reply With Quote
  #11  
Old 10-20-2013, 06:30 PM
Member
 
Join Date: Jul 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 479
Jecko33 is on a distinguished road
Worked for me too!
__________________
Reply With Quote
  #12  
Old 10-20-2013, 06:56 PM
5.7 My Hemi's Avatar
Member
My Jeep: 2006 5.7L WK2
 
Join Date: Oct 2013
Location: St. George Utah and Chicago
Posts: 308
Thanks: 102
Thanked 14 Times in 13 Posts
Rep Power: 698
5.7 My Hemi is on a distinguished road
Garage
Re: Lost cruise control after TSB flash...

Thanks robertrichhart, I think this is very good information for a lot of people to keep tucked in the back of their mind when they more than likely will have to do more updates. Thanks again.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I tell if TSB Flash Program has been applied? jpsmith Trouble Shooting/Problems/Service 10 02-03-2014 11:52 AM
cruise control dippinsoldier92 Troubleshooting/Problems 0 05-28-2013 01:12 PM
Cruise control Armstrong437 Trouble Shooting/Problems/Service 1 09-27-2012 02:11 AM
Cruise Control kazak Grand Cherokee - WK2 - 9 03-16-2012 11:55 AM
730N RHR lost volume control GFY8 Audio/Visual/Navigation 9 03-07-2012 09:28 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.