Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-29-2012, 09:56 AM
JeepMonster's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: Fairfax, VA
Posts: 316
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 163570
JeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond repute
Malfunction indicator light on- only 300 miles

Turned on the Jeep this morning and the MIL was illuminated. Not sure what to do since the dealer is closed. Checked the oil filter cap and others that I could see.
__________________

__________________
Reply With Quote
  #2  
Old 04-29-2012, 10:18 AM
77Cherokee's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jun 2011
Location: NY State
Posts: 652
Thanks: 0
Thanked 21 Times in 19 Posts
Rep Power: 2236
77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute77Cherokee has a reputation beyond repute
Re: Malfunction indicator light on- only 300 miles

If it doesn't happen again then it was probably just a glitch. If it does, I would take it in and let them scan it.
__________________

__________________
2012 Overland, Deep Cherry w/black/saddle interior, V6, ACC pkg.

My 77 Cherokee- Long gone but not forgotten
___
____________________________________
Reply With Quote
  #3  
Old 04-29-2012, 10:26 AM
JeepMonster's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: Fairfax, VA
Posts: 316
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 163570
JeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond repute
Re: Malfunction indicator light on- only 300 miles

I tried turning it off and on a few times but it's still on. I'm going to go to Advance Auto parts to have them read the code since the dealer is closed.

Quote:
Originally Posted by 77Cherokee View Post
If it doesn't happen again then it was probably just a glitch. If it does, I would take it in and let them scan it.
__________________
Reply With Quote
  #4  
Old 04-29-2012, 11:06 AM
JeepMonster's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: Fairfax, VA
Posts: 316
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 163570
JeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond repute
Re: Malfunction indicator light on- only 300 miles

Evaporative emission system leak detected (very small leak)


I cleared the code- going to see if it comes back on and call the dealer when they open tomorrow

Any ideas what would cause this with only 300 miles on the car? My only guess is a bad gas cap.
__________________
Reply With Quote
  #5  
Old 04-29-2012, 12:44 PM
Member
 
Join Date: Nov 2010
Posts: 88
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1574
mr_bots is on a distinguished road
Re: Malfunction indicator light on- only 300 miles

Might be somewhere else in the system, the evap system runs from most of the length of the vehicle so plenty of room for leaks. Maybe its loose or cracked up where it ties into the intake? I believe these have a check gas cap icon in the EVIC if it thinks the leak is the gas cap.
__________________
Reply With Quote
  #6  
Old 04-29-2012, 06:14 PM
BobsWK2's Avatar
Premium Member
 
Join Date: Aug 2010
Posts: 1,572
Thanks: 3
Thanked 30 Times in 26 Posts
Rep Power: 49708
BobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond repute
Re: Malfunction indicator light on- only 300 miles

Quote:
Originally Posted by jeepmonster View Post
Evaporative emission system leak detected (very small leak)


I cleared the code- going to see if it comes back on and call the dealer when they open tomorrow

Any ideas what would cause this with only 300 miles on the car? My only guess is a bad gas cap.

R&R and tighten the gas cap till it clicks. It still may take up to 50 miles for the MIL to remain off.
__________________
2014 Summit 4X4, V8
Reply With Quote
  #7  
Old 04-29-2012, 06:41 PM
JeepMonster's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: Fairfax, VA
Posts: 316
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 163570
JeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond repute
Re: Malfunction indicator light on- only 300 miles

Yeah I did tighten it until it clicked a couple times before the light came on. After the light came on this morning I reset cleared the code and retightened the gas cap.
__________________
Reply With Quote
  #8  
Old 04-30-2012, 05:43 AM
JeepMonster's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: Fairfax, VA
Posts: 316
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 163570
JeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond repute
Re: Malfunction indicator light on- only 300 miles

When you guys turn on your vehicle how long does the MIL illuminate before it goes away?
__________________
2012 WK2 4x4 Laredo X (QT1) in Maximum Steel w/ Panoramic Sunroof and 430N Nav
Reply With Quote
  #9  
Old 05-01-2012, 06:44 AM
JeepMonster's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: Fairfax, VA
Posts: 316
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 163570
JeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond repute
Re: Malfunction indicator light on- only 300 miles

My light comes up for like a second, just want to make sure I didn't clear the code for the MIL check out of the computer.
__________________
2012 WK2 4x4 Laredo X (QT1) in Maximum Steel w/ Panoramic Sunroof and 430N Nav
Reply With Quote
  #10  
Old 05-05-2012, 01:45 PM
JeepMonster's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: Fairfax, VA
Posts: 316
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 163570
JeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond repute
Re: Malfunction indicator light on- only 300 miles

The light came back on today and is staying solid. The dealer said to bring it by Monday as he thinks it's something with the computer and they are closed tomorrow. I don't get why it came on again, that's twice in 500 miles.
__________________
2012 WK2 4x4 Laredo X (QT1) in Maximum Steel w/ Panoramic Sunroof and 430N Nav
Reply With Quote
  #11  
Old 05-07-2012, 06:36 AM
JeepMonster's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Apr 2012
Location: Fairfax, VA
Posts: 316
Thanks: 4
Thanked 0 Times in 0 Posts
Rep Power: 163570
JeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond reputeJeepMonster has a reputation beyond repute
Re: Malfunction indicator light on- only 300 miles

Heading to the dealer this afternoon to see what's wrong. I noticed that when the light is on though the remote start or Eco mode don't work.
__________________
2012 WK2 4x4 Laredo X (QT1) in Maximum Steel w/ Panoramic Sunroof and 430N Nav
Reply With Quote
  #12  
Old 05-07-2012, 08:08 AM
ajs800's Avatar
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jun 2011
Location: Michigan
Posts: 744
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 32134
ajs800 has a reputation beyond reputeajs800 has a reputation beyond reputeajs800 has a reputation beyond reputeajs800 has a reputation beyond reputeajs800 has a reputation beyond reputeajs800 has a reputation beyond reputeajs800 has a reputation beyond reputeajs800 has a reputation beyond reputeajs800 has a reputation beyond reputeajs800 has a reputation beyond reputeajs800 has a reputation beyond repute
Re: Malfunction indicator light on- only 300 miles

mine popped on and off during a 4wk span but has now been off for the past 5wks. Never did take it in as it was running fine. I plan to have it scanned once it goes for its first visit to the dealer.
__________________

__________________
2011 Overland, Dk Charcoal Pearl, Black/Saddle w/Summit Wood Trim Swap, V6, QL, 20" wheels, 730N
Reply With Quote
The Following User Says Thank You to ajs800 For This Useful Post:
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MIL (Malfunction Indicator Lamp) Andrew Interior/Exterior/Visual 23 06-13-2013 11:22 AM
Electronic Stability Control (ESC) Activation/Malfunction Indicator Light paulabrown4480 Grand Cherokee - WK2 - 1 11-22-2011 08:25 PM
malfunction indicator light 05jgc Grand Cherokee - WK 3 08-20-2011 09:59 PM
Less than 300 Miles thespaman Grand Cherokee - WK2 - 2 02-10-2011 12:15 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.