Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-16-2013, 02:34 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Aug 2013
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 432
wuaname is on a distinguished road
Thumbs down misc electrical issues / related / uconnect?

About a month into the ownership of my 2014 Limited…… and more “little” issues / bugs / uncalled for problems on a new car, etc. than I was expecting. Especially, since it shares its underpinnings and maybe more with the Mercedes M class. I’ve had MB sedans before and just came from a Lexus, so wasn’t expecting so many “bugs” on a new car.

I’ve done a lot of searches on here in the archives and have pretty much seen almost , if not all, the issues addressed, but haven’t found resolutions on some. I’d also like to see if they are all related, part of the issues with Uconnect, resolution available, etc. so bear with me, as I know this has been discussed before.

Subject: 2014 Jeep GC Limited, V8, approx. 2,100 miles at the moment.
  • AC / remote start: This one I have the copy of the tsb, which has been discussed here about ac stays on when you open passenger door, but shuts off when you open driver door. The other issue I have is with the Uconnect app, I don’t think it’s turning on the a/c at all. Is that a separate problem or would the fix be in the tsb mentioned? I have to double check, I think I tried it with a/c on auto, not sure if it would have to do with that or not.
  • Ipod: I tried my ipod the other day with the usb connector and it didn’t work, but I realized the cable was “charge only”, my bad..lol… it plays fine with the aux cable. Two questions: 1. I’ve read of some issues with album art not appearing on the screen or title (I care more of the title not appearing)? Is this a continuing problem? And if so, any word on the fix? I don’t want to buy a usb cable if it’s not going to show the art. 2. Would something like copytrans allow me to copy my music from itunes onto a usb or sd card without blocking the music purchased from itunes? My music streams fine on Bluetooth from my iphone, but no art, plus I don’t want my cell to be my primary music library.
  • Favorite artist / song on radio: This was working like a charm for the last month…. Until yesterday. Now it beeps, but the green emblem doesn’t appear on top for me to select which favorite is playing. I click on the set up area and I have the right options selected “visual and audible” notice, but whichever “favorite” is playing at the moment isn’t showing up there either. This morning it worked fine, but it was down on and off all weekend.
  • The “two touch” required problem = The sunroof sometimes doesn’t open / close with just one touch. Same with the door lock button on the handle. Any fix for this or just not a fully working option?
  • Check engine light: Not an ongoing problem, but yesterday we had to drive through some puddles, maybe 6”, due to heavy rain, for several blocks, cautiously… Five minutes later “check engine” light comes on. It finally went away after a few hours and no issues with truck, but come on, it’s a “JEEP” and it can’t handle a small puddle of water? I am guessing that’s what the cause was.
  • Seat presets: I have my keys with my seat / mirror etc. presets and g/f has her setting with her key. Yesterday, she went to drive it with my keys, pressed seat preset 2 (her settings) since she didn’t have her keys, and it didn’t recognize the preset, it was lost. Then the dash where the mph appear on the top just showed something like three blank lines… I shut off the truck, and back on, and finally the MPH showed back up. Any ideas?
  • Gas mileage: How come I am not getting the 34 mpg in the city they advertise for the Hemi? OK, I AM kidding, lol….no complaints here, lol
Hmm, I think, those are the “only” issues I have on this new vehicle. Any ideas?

Are some of these problems all related to the uconnect update or tsb or are they all individual problems with a new vehicle? Which have fixes at the moment?





__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical issues? bertball50 Trouble Shooting/Problems/Service 4 07-12-2013 01:10 PM
05 WK electrical issues HFolb23 Troubleshooting/Problems 2 04-03-2013 09:36 AM
Electrical Issues 98ZJ-Man Grand Cherokee - ZJ 0 05-08-2012 10:35 PM
Electrical issues tri0829 Troubleshooting/Problems 1 01-23-2012 12:11 PM
electrical issues... smack82 Troubleshooting/Problems Discussion 6 01-21-2010 01:20 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community