Mysterious "Service Transmission" Message on Dash - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-25-2014, 11:47 PM
makris0000's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: Florida
Posts: 163
Thanks: 10
Thanked 6 Times in 6 Posts
Rep Power: 1372
makris0000 is on a distinguished road
Garage
Mysterious "Service Transmission" Message on Dash

Hello,

I went to drive my Jeep today and i got a random message on my dash saying something like "Service transmission ......" and it also beeped when I put the car into reverse and it went away too quickly to read the whole thing. The car was driving normal and it didn't seem like anything was wrong with it but the message came on a few times today. My Jeep was sitting in my driveway for about 5 days because I was on a cruise and when I drove it earlier today it was fine and no message or beep came on but when it was sitting for a few hours after I drove it, it made the beep and message. ( sorry if I sound like I am rambling on)

My questions are, has anyone experienced this before with their Jeep? If anyone has had the message, did they get it checked by the dealer and is it a serious problem?

I am planning on taking it to the dealership maybe tomorrow or sometime before New Years because I want to get it checked ASAP before the Spring semester starts up again. I figured I would check the forums first before going to the dealership.

Thanks!

__________________
2014 Jeep Grand Cherokee Laredo
Maximum Steel/Black
Laredo E Package
Window Tint
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 12-26-2014, 07:31 AM
Member
My Jeep: 2006 5.7L WK
 
Join Date: Nov 2014
Location: Midwest
Posts: 63
Thanks: 6
Thanked 5 Times in 4 Posts
Rep Power: 861
pbruecken is on a distinguished road
Re: Mysterious "Service Transmission" Message on Dash

My 2006 GC limited did the same thing. It seems the navigation system has messages in it like the Vehicle Information Display ( the panel that usually displays temp & direction). On my 2006, there is a display that you can respond to using the buttons that says "ok" and the reminder will go away. It seems to be a factory reminder to get service done and doesn't really indicate there is a problem. You might want to get your transmission serviced as it seems it is time😉


Sent from my iPad using JeepGarage
Reply With Quote
  #3  
Old 12-28-2014, 01:41 AM
makris0000's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: Florida
Posts: 163
Thanks: 10
Thanked 6 Times in 6 Posts
Rep Power: 1372
makris0000 is on a distinguished road
Garage
Re: Mysterious "Service Transmission" Message on Dash

I didn't even have a chance to press ok on mine to make the message it just went away after a few seconds and it didn't store the message under messages. Mine is also a 2014 and I saw that the mid 2000's had that happening to them but there was nothing on it about the 2014's.
__________________
2014 Jeep Grand Cherokee Laredo
Maximum Steel/Black
Laredo E Package
Window Tint
Reply With Quote
  #4  
Old 12-28-2014, 06:34 AM
Member
 
Join Date: Jun 2013
Posts: 63
Thanks: 102
Thanked 7 Times in 7 Posts
Rep Power: 1394
jeepless is on a distinguished road
Hello
I have also had this problem. It first appeared on a trip up north and also cancelled cruise control. "Bing" flash message on the dash then back to normal. I stopped for something, restarted and problem went away.
On the way home it resurfaced, I also noticed that the transmission tunnel indicator led was flashing. (or dimming)
Problem lasted til we got home, 7hours.
Next day I removed my OBD bluetooth dongle and restarted, no problem.
I have since used OBD dongle with no issues, so who knows, problem hasn't resurfaced.
Reply With Quote
  #5  
Old 12-30-2014, 12:47 AM
makris0000's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Oct 2013
Location: Florida
Posts: 163
Thanks: 10
Thanked 6 Times in 6 Posts
Rep Power: 1372
makris0000 is on a distinguished road
Garage
Re: Mysterious "Service Transmission" Message on Dash

Quote:
Originally Posted by jeepless View Post
Hello
I have also had this problem. It first appeared on a trip up north and also cancelled cruise control. "Bing" flash message on the dash then back to normal. I stopped for something, restarted and problem went away.
On the way home it resurfaced, I also noticed that the transmission tunnel indicator led was flashing. (or dimming)
Problem lasted til we got home, 7hours.
Next day I removed my OBD bluetooth dongle and restarted, no problem.
I have since used OBD dongle with no issues, so who knows, problem hasn't resurfaced.
Yeah mine happened 3 times within 10 minutes and when I took it to the dealer this morning they couldn't find any codes or anything wrong with it. I guess I'll try to get my camera ready and take a picture of the message before I goes away (which I tried to do but it went away so quickly I couldn't take the picture) if it comes back on again.
__________________
2014 Jeep Grand Cherokee Laredo
Maximum Steel/Black
Laredo E Package
Window Tint
Reply With Quote
  #6  
Old 01-01-2015, 02:36 PM
YO-EL's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2012
Location: Phila PA suburbs
Posts: 137
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1942
YO-EL will become famous soon enough
Re: Mysterious "Service Transmission" Message on Dash

ALso having the same issue..
Took it in last week, they did an update..
Went from P to D, message pops up again!
__________________

2011- 2010 Englishtown (NJ) 11.50 Index CHAMPION! 2012-2011-2010 Corvette Challenge Pro 11.50 Index CHAMPION!
2012 Modern Muscle CHAMPION!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mysterious jeep problem - need help - Bmoore23 Troubleshooting/Problems Discussion 11 02-27-2015 06:20 PM
Service Transmission message 3x this morning.. YO-EL Trouble Shooting/Problems/Service 14 01-13-2015 10:41 AM
" service electric break system " and " service 4WD system " Rexie1983 Troubleshooting/Problems 0 03-18-2013 07:48 AM
Mysterious Antifreeze Leak mjonesjr Troubleshooting/Problems 7 02-15-2013 09:49 PM
Mysterious noise Cordishead Troubleshooting/Problems Discussion 3 12-23-2010 09:01 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:33 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.