Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-21-2013, 09:31 PM
New Member
 
Join Date: Jun 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
marekh is on a distinguished road
New GC Overland already broken after 100 miles

i just got new 2014 GC Ovelrland for my wife. she drove few miles and message for "service all wheel drive" appeared. ESP, TC, adaptive Cruise control and collision warning shut down. brought the car to stealership, they do not know what to do, car is too new we do not have records from chrysler blah, blah. i already do not like this car. i am long time SRT owner, but this is simply ridiculus! maybe we should just return vehicle and be done with chrysler products.
please help, did you have similar problems, is new GC just junk? BTW, uconnect and all their aps is a joke too!

greatly appraciate any help and advice.

thanks so much!

marek
__________________

__________________
Reply With Quote
  #2  
Old 06-21-2013, 10:39 PM
ENFORCER's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: May 2011
Location: Sydney, Australia
Posts: 2,052
Thanks: 23
Thanked 99 Times in 81 Posts
Rep Power: 322147
ENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond reputeENFORCER has a reputation beyond repute
Re: New GC Overland already broken after 100 miles

Might be the dreaded earth strap issue.
Hope they fix it quickly for you.
__________________

__________________
Previous Ride = 2011 JGC CRD Overland
Current Ride = 2014 Silver JGC SRT with Pano, HK and Spider monkeys.
Mods = CLSTech Ribbon Mod

Best 1/4 13.4@102Mph
Reply With Quote
  #3  
Old 06-21-2013, 10:39 PM
New Member
 
Join Date: Jun 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
marekh is on a distinguished road
Re: New GC Overland already broken after 100 miles

i have started to read forums and it looks like our car has multiple issues i.e. uconnect not working properly, ac not turning on after remote start, air suspension cycling. this is after spending just 30 mintues to research. i will try to return it tomorrow, however we could be stuck with piece of junk for antother few years. it is not my happiest day!

marek
__________________
Reply With Quote
  #4  
Old 06-21-2013, 10:43 PM
New Member
 
Join Date: Jun 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
marekh is on a distinguished road
Re: New GC Overland already broken after 100 miles

Quote:
Originally Posted by ENFORCER View Post
Might be the dreaded earth strap issue.
Hope they fix it quickly for you.
thanks a lot for your input, will suggest to the "experts" at dealership.

best

marek
__________________
Reply With Quote
  #5  
Old 06-21-2013, 10:50 PM
eljeffe505's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Location: Albuquerque
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 630
eljeffe505 is on a distinguished road
"Its the best of what we are made of" - I'm on 2 weeks in the shop. Good Luck!
__________________
_____________________
2009 Wrangler Rubicon Unlimited
2014 Grand Cherokee Overland
Reply With Quote
  #6  
Old 06-22-2013, 04:15 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,568
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80278
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: New GC Overland already broken after 100 miles

Finally got a look uner the hood of a '14 and the ground connections (two cables under one bolt and a ground strap under another). Other than the braided strtap seeming kind of flimsy all were tight and looked the same as on my '12. Battery connections under seat also seemed tight.

If some are finding one/more loose, which is it please ?
__________________

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 not even 100 miles and issues 655321 Trouble Shooting/Problems/Service 68 05-23-2013 01:12 AM
2014 first 100 miles - impressions so far njtoman Grand Cherokee - WK2 - 49 03-03-2013 10:15 PM
2011 GC Overland Power Liftgate Broken SRQ Jeep Trouble Shooting/Problems/Service 0 07-27-2011 03:50 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.