Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-11-2013, 07:55 PM
New Member
 
Join Date: Sep 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Onionseeds is on a distinguished road
new owner multiple issues

hi all,

I am the new owner of a 2014 GC Limited - it's easily one of the most enjoyable cars to drive. I've had it for about a month, and today's the first time I've had some interesting issues occur. On the way to work this morning, I noticed my speedometer wasn't working properly (it doesn't look like I'm able to attach a pic of the issue just yet). Basically the speedo showed everything but the numbers or mph, making it somewhat difficult to know what speed I was going. I tried scrolling through all the dash settings, to try to get it to work, but the only solution was to stop and start the Jeep back up.

On the way home after work, it was the first snow in Chicago. I got in the Jeep, and pressed on both defrost buttons. The rear defrost seemed to work immediately. The heater fan turned to 7, but wasn't on. I waited about 20 minutes, as I thought the Jeep may have a setting to prevent the fan from turning on if it wasn't at normal running temperature. So I turned the fan off, and went into the a/c controls to try to just turn it on that way, but nothing. I decided to pull over, as it was starting to fog up inside. I turned the Jeep off, then back on and the fan came on immediately.

I'm on the latest software 13.38.52. I was wondering if this has happened to anyone else, or if this is a known issue. Or, is this something that needs to be escalated to Jeep in order to have it fixed in the next software release.

Any input is appreciated.
__________________

__________________
Reply With Quote
  #2  
Old 11-11-2013, 07:58 PM
New Member
 
Join Date: Sep 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Onionseeds is on a distinguished road
Re: new owner multiple issues

just found this, apologies:

Missing Numbers on speedo

It looks like the suggestion is to look at the CAN bus connection - this makes sense, but the digital mph readout was working, just the analog was blank, in case that helps.
__________________

__________________
Reply With Quote
  #3  
Old 11-11-2013, 08:04 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,843
Thanks: 294
Thanked 295 Times in 261 Posts
Rep Power: 1801265
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: new owner multiple issues

If it happens again, see your dealer. That's the first step. They will contact dealer direct if they don't already know how to fix it.
__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Aux cord issues new owner pandrade2011 Trouble Shooting/Problems/Service 2 06-12-2013 08:14 AM
Multiple cylinder misfire, HELP Please! Sawyer26 Troubleshooting/Problems 16 03-22-2013 08:15 AM
Multiple Issues for my SRT KOA72 Trouble Shooting/Problems/Service 4 09-06-2012 08:11 PM
Multiple engine codes hgb8956 Troubleshooting/Problems 30 06-06-2011 04:44 PM
Multiple engine codes hgb8956 Troubleshooting/Problems Discussion 2 05-10-2011 02:38 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community