Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-29-2011, 01:25 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Aug 2010
Location: Virginia
Posts: 417
Thanks: 3
Thanked 3 Times in 3 Posts
Rep Power: 1867
Radside has a reputation beyond reputeRadside has a reputation beyond repute
New uconnect module tsb

I just saw this on Milius' site...might be the answer to all those phone connection issues using the center console USB port.

http://www.wk2jeeps.com/tsb/tsb_wk2_0803611.pdf
__________________

__________________
2011 Black Berry Laredo X
Chrome Running Boards
Chrome Fog Bezel
Shark Fin Antennal
MyGig 430N
20" SRT REPS (9"wide)
Good Year Fortera 265 50R/20
Reply With Quote
  #2  
Old 06-30-2011, 11:32 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2010
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1368
Marky is on a distinguished road
Re: New uconnect module tsb

I just made an appointment with my dealer (Mullen Motors in Southold, NY -- who I still love) for the TSB to be applied tomorrow. I'll report back what it does.

I have a non-nav 430.
__________________

__________________
Reply With Quote
  #3  
Old 06-30-2011, 11:37 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Massachusetts
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1476
hammer1234 is on a distinguished road
Re: New uconnect module tsb

Quote:
Originally Posted by Marky View Post
I just made an appointment with my dealer (Mullen Motors in Southold, NY -- who I still love) for the TSB to be applied tomorrow. I'll report back what it does.

I have a non-nav 430.
Do you have an iPod Touch or iPhone that you are having connection problems with?
__________________
Reply With Quote
  #4  
Old 06-30-2011, 10:43 PM
Member
 
Join Date: Jun 2011
Posts: 117
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1256
aquaanox is on a distinguished road
Re: New uconnect module tsb

Sweet!
__________________
Reply With Quote
  #5  
Old 07-02-2011, 10:59 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2010
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1368
Marky is on a distinguished road
Re: New uconnect module tsb

My iPhone 3GS, my wife's 3G and my son's iPod Touch all work via USB now. There was a slight glitch the first time I used it, but a restart fixed it and now it seems solid.

Bluetooth streaming is still problematic. Screen must be off.
__________________
Reply With Quote
  #6  
Old 07-02-2011, 05:50 PM
Member
 
Join Date: May 2010
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1568
granto3k is on a distinguished road
Re: New uconnect module tsb

Quote:
Originally Posted by Marky View Post
My iPhone 3GS, my wife's 3G and my son's iPod Touch all work via USB now. There was a slight glitch the first time I used it, but a restart fixed it and now it seems solid.

Bluetooth streaming is still problematic. Screen must be off.
Does album art show up?
__________________
Reply With Quote
  #7  
Old 07-03-2011, 09:11 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2010
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1368
Marky is on a distinguished road
Re: New uconnect module tsb

No album art.
__________________
Reply With Quote
  #8  
Old 07-21-2011, 06:30 PM
bigbore's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2011
Location: Chicago
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1273
bigbore is on a distinguished road
Re: New uconnect module tsb

Had the TSB done yesterday. My iphone4 now works great on Bluetooth streaming (which was choppy and unlistenable before) but will not play songs via USB. All the menus display the playlists and songs properly but have not been able to get it to play.
__________________
2011 Overland Hemi & 2006 300C SRT8, both Brilliant Black
Reply With Quote
  #9  
Old 07-22-2011, 10:58 AM
Premium Member
My Jeep: 2012 6.4L SRT8
 
Join Date: Dec 2010
Location: Ormond Beach FL
Posts: 1,544
Thanks: 0
Thanked 21 Times in 20 Posts
Rep Power: 2883
mjw930 has a reputation beyond reputemjw930 has a reputation beyond repute
Re: New uconnect module tsb

Quote:
Originally Posted by bigbore View Post
Had the TSB done yesterday. My iphone4 now works great on Bluetooth streaming (which was choppy and unlistenable before) but will not play songs via USB. All the menus display the playlists and songs properly but have not been able to get it to play.
The same problem here, the audio isn't making it to the radio but the control signals are. I would say they don't have this fully sorted, expect another TSB down the road OR iOS 5 will help.
__________________
2012 Grand Cherokee SRT8 Black/Black
Reply With Quote
  #10  
Old 07-22-2011, 04:40 PM
rangersplash85's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Dec 2010
Location: the Sandhills, NC
Posts: 113
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1435
rangersplash85 is on a distinguished road
Quote:
Originally Posted by bigbore View Post
Had the TSB done yesterday. My iphone4 now works great on Bluetooth streaming (which was choppy and unlistenable before) but will not play songs via USB. All the menus display the playlists and songs properly but have not been able to get it to play.
Make sure your device is set to send audio through the dock connector and not Bluetooth. The iPhone defaults audio through Bluetooth.
__________________
2012 Limited 3.6L 4x4
Black on Black
Luxury Group
Trailer Tow Grp
Reply With Quote
  #11  
Old 07-27-2011, 09:12 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Massachusetts
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1476
hammer1234 is on a distinguished road
Re: New uconnect module tsb

Just had the update done and it fixed the iPod Touch connection error we were having. All is better now...
__________________
Reply With Quote
  #12  
Old 08-01-2011, 09:10 PM
Member
 
Join Date: May 2010
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1568
granto3k is on a distinguished road
Re: New uconnect module tsb

I did the update myself. The BT streaming does not skip anymore but the sound quality seems to have a lot of static. My coworker has a new Ford and the BT streaming in that vehicle sounds on par with Sirius radio quality.

Is anyone else noticing this? I haven't tried another phone in my car. My iPhone is on its last legs so it might be my phone that is the problem.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
UConnect Module in WK2 Jeeps Mmartin Audio/Visual/Navigation 6 05-29-2013 11:16 AM
Shift Module f1_mimmo Grand Cherokee - WK 14 09-24-2012 10:46 PM
Abs module... Help jdcollins86 Grand Cherokee - WK 10 01-06-2011 03:01 AM
Is there a TSB for this? Spoon Trouble Shooting/Problems/Service 2 10-18-2010 01:11 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community