Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-28-2011, 05:46 AM
GrandFa's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2011
Location: RUSSIA/Moskow reg/Electrostal city
Posts: 60
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1349
GrandFa is on a distinguished road
No power after warming up! 5.7 HEMI

Hello, dear colleagues!
I read here a lot, but have not yet found an answer to my questions and decided to post it topic!
The question is: can anyone come across, but was not paying attention!
I have a Grand Cherokee 5.7 Overland from Canada, bought new.
I began to notice strange feature, until the engine has not reached operating temperature, on heating to about 75-80 degrees more, the car rides well, starts quickly, accelerates fast! Once the engine is fully warmed up, there is a strange variation, the car just goes! Slap and dynamic acceleration followed by sluggish and even with what that strange sound set speed, the car will drive starts sluggishly, the impression of something that she is missing! </span>And then, while hot as always! In the morning warm-up power comes again!
Maybe someone encountered this problem, share, someone can not pay attention, you never know do not have to fast start, I'm still here and run in at all until 3000 km traveled specially very quiet and does not have noticed this feature!

P.S. Well, speed limiter at 180 km/h strongly breaks off, can someone know if he is removed from a dealer flashing the brain, or as something else?

grateful to all who responded!
__________________________________________________ _______________
PS problem not mine. published from Russian Jeep Forum...
__________________

__________________
Reply With Quote
  #2  
Old 11-30-2011, 03:16 PM
Member
 
Join Date: May 2011
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1294
wardy is on a distinguished road
Re: No power after warming up! 5.7 HEMI

Yes me too. Thought i was crazy but this is exactly what is happening.

Any ideas? I think the oil is too thin?
__________________

__________________
Reply With Quote
  #3  
Old 11-30-2011, 04:36 PM
SixZeroFour's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jan 2011
Location: Vancouver BC
Posts: 542
Thanks: 11
Thanked 38 Times in 25 Posts
Rep Power: 54390
SixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond reputeSixZeroFour has a reputation beyond repute
Re: No power after warming up! 5.7 HEMI

I'm fairly certain this is due to heat soak and the engine retarding the timing once its hot. Not a whole lot that can be done until tuners crack the ECU and start playing with timing maps.
__________________
Reply With Quote
  #4  
Old 11-30-2011, 04:38 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,371
Thanks: 874
Thanked 1,043 Times in 718 Posts
Rep Power: 7718285
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: No power after warming up! 5.7 HEMI

what grade gasoline are you using?


Its sounds like once the catalytic converters heat up to desired temp...the PCM is limiting performance for some odd reason. Maybe bad cats? Bad PCM? I would take to dealer for diagnosis.

No engine lights? etc? Any mods to the engine?

Suggest them to resett the PCM by disconecting the negative terminal on the battery and then stepping on brake pedal sevral times...theen waiting 20-30 minutes.
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #5  
Old 11-30-2011, 06:27 PM
Darby Crash's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Oct 2011
Location: LOS ANGELES
Posts: 87
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1192
Darby Crash is on a distinguished road
Re: No power after warming up! 5.7 HEMI

I thought I was crazy too, but I'm having the same exact issue. I'm using the recommended gas, no engine lights going on and all I have is the K&N drop in filter. I thought it might have something to do with my flowmasters, but I know it’s not after reading other people are having the same issues.
__________________
~2011-BRLBLK-LMTD-4X-5.7~
Reply With Quote
  #6  
Old 11-30-2011, 09:08 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Sep 2011
Location: TX
Posts: 121
Thanks: 0
Thanked 2 Times in 1 Post
Rep Power: 1248
rpoverland is on a distinguished road
Re: No power after warming up! 5.7 HEMI

Mine does the same thing. I also have a 2010 RR Sport and that one has no issues with performance at all.
__________________
Reply With Quote
  #7  
Old 12-01-2011, 06:43 AM
GrandFa's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2011
Location: RUSSIA/Moskow reg/Electrostal city
Posts: 60
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1349
GrandFa is on a distinguished road
Re: No power after warming up! 5.7 HEMI

Quote:
Originally Posted by Scottina06 View Post
what grade gasoline are you using?
regular 95 rus
Quote:
Originally Posted by Scottina06 View Post
No engine lights? etc? Any mods to the engine?
No. Just a new car...
Quote:
Originally Posted by Scottina06 View Post
Suggest them to resett the PCM by disconecting the negative terminal on the battery and then stepping on brake pedal sevral times...theen waiting 20-30 minutes.
Thnks!I will...
__________________
Reply With Quote
  #8  
Old 12-01-2011, 06:47 AM
GrandFa's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Apr 2011
Location: RUSSIA/Moskow reg/Electrostal city
Posts: 60
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1349
GrandFa is on a distinguished road
Re: No power after warming up! 5.7 HEMI

Quote:
Originally Posted by SixZeroFour View Post
Not a whole lot that can be done until tuners crack the ECU and start playing with timing maps.
this car purchased from "non-official" (Canadian) dealer and so it hasn't a warranty coat in Russia
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there a big power difference Hemi vs. 4.7? stefano Grand Cherokee - WK 22 05-30-2011 11:11 PM
Problems with power locks/power windows Frango100 Troubleshooting/Problems 8 02-10-2011 08:23 AM
The difference in the 1st generation HEMI to the new 2nd generation HEMI White WK Swagga Grand Cherokee - WK 2 07-08-2010 11:16 AM
Difference in GC Hemi and Ram Hemi?? HemiDawg Grand Cherokee - WK 12 05-13-2010 11:52 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community