Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-09-2013, 12:00 AM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 858
Thanks: 0
Thanked 34 Times in 27 Posts
Rep Power: 73222
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Noticed a huge cable particually unplugged on new 2014

As you stand in front facing the engine there is large control module on the left.

It has two large connectors on it.

Noticed today one was partly unlatched.

When I pushed latch down I could clearly see whole connecter pull itself in

It had a dpuble latch and I clicked it in.

Just FYI

Maybe this being loose caused my service electronic throttle error.
__________________

__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #2  
Old 09-09-2013, 07:21 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 995
Thanks: 6
Thanked 51 Times in 38 Posts
Rep Power: 3674
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: Noticed a huge cable particually unplugged on new 2014

Quote:
Originally Posted by mswlogo View Post

As you stand in front facing the engine there is large control module on the left.

It has two large connectors on it.

Noticed today one was partly unlatched.

When I pushed latch down I could clearly see whole connecter pull itself in

It had a dpuble latch and I clicked it in.

Just FYI

Maybe this being loose caused my service electronic throttle error.
I noticed on my 2014 GC the very same connector you speak of had the lock tab broken off...which just so happens to hold the red latch arm down in the locked position. I now have a zip-tie holding that red latch down.
__________________
2 Reflashes, 1 Recall and Counting...
Reply With Quote
Reply

Tags
2014

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 SD/USB area is HUGE...room for CD player too? doulos4JC Grand Cherokee - WK2 - 44 06-21-2013 04:54 AM
Few Things I Noticed on my 2014 V8 Summit BobsWK2 Grand Cherokee - WK2 - 9 04-20-2013 01:29 PM
O2 signal voltage with sensor unplugged..? drivewaylemonade Troubleshooting/Problems 9 02-28-2013 07:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.