odd symbol in my EVIC - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-31-2014, 10:41 AM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2012
Location: Ontario, Canada
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1982
chuckster is on a distinguished road
odd symbol in my EVIC

I have been loving my 2012 Laredo X without any hint of problems, but the other day going for a casual drive not towing anything, I noticed a small letter "i" in the EVIC up near the compass reading. When we finished shopping and started out again, the little i was gone. This has happened a couple of times. I have checked the manual for symbols and found no reference to this. Anyone enlighten me as to what this is?

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-31-2014, 06:58 PM
LTrainGC's Avatar
Senior Member
My Jeep: 2013 5.7L WK2
 
Join Date: May 2009
Location: St. Petersburg, FL
Posts: 2,206
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 5227
LTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond reputeLTrainGC has a reputation beyond repute
Re: odd symbol in my EVIC

It means you have a "message" - scroll down through the options (trip info, vehicle info, etc) until you get to "messages". Usually it is for the oil life indicator - mine will come on when I forget to reset it.
__________________
2013 WK2 Overland HEMI 4x4
Bright White / New Saddle
Reply With Quote
  #3  
Old 08-31-2014, 07:43 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2012
Location: Ontario, Canada
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1982
chuckster is on a distinguished road
Re: odd symbol in my EVIC

Thanks a lot. I've had my Jeep for nearly 3 years and there's still stuff about it I don't understand. A job for the grand-kids I guess.
Reply With Quote
Sponsored Links
Advertisement
 
  #4  
Old 08-31-2014, 08:59 PM
SRTNinja's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: Aug 2012
Location: DC
Posts: 775
Thanks: 37
Thanked 193 Times in 128 Posts
Rep Power: 17113
SRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond repute
Garage
Re: odd symbol in my EVIC

Yes, go into your set up screen using the steering wheel buttons and go to messages.
__________________
Instagram @srtninja
Reply With Quote
  #5  
Old 09-02-2014, 07:00 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2012
Location: Ontario, Canada
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1982
chuckster is on a distinguished road
Re: odd symbol in my EVIC

Follow-up. I did what you guys suggested and the message was "low battery in the key fob". I took the Jeep back to the dealer to get new batteries. They took it into the shop to investigate and came out saying the batteries were fine and that they had cleared the EVIC fault message.
So now I have 2 questions: 1.Why would this happen if the batteries were OK?
2. After the warranty is out, can you just pry these fobs open and put in new batteries yourself or is it more complicated than that?
Reply With Quote
  #6  
Old 09-02-2014, 07:09 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,816
Thanks: 317
Thanked 316 Times in 248 Posts
Rep Power: 91620
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: odd symbol in my EVIC

Quote:
Originally Posted by chuckster View Post
2. After the warranty is out, can you just pry these fobs open and put in new batteries yourself or is it more complicated than that?
Easy peasy.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2017 Compass Latitude 4x4, redline pearl coat/black, delivered 4-25-'17
Reply With Quote
  #7  
Old 09-02-2014, 07:14 PM
SRTNinja's Avatar
Premium Member
My Jeep: 2014 6.4L WK2
 
Join Date: Aug 2012
Location: DC
Posts: 775
Thanks: 37
Thanked 193 Times in 128 Posts
Rep Power: 17113
SRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond reputeSRTNinja has a reputation beyond repute
Garage
Re: odd symbol in my EVIC

Can't answer #1, but #2 is very easy to do. Exactly what you said, pop it open and drop in a new battery. I just changed both of mine and they are CR2032.
__________________
Instagram @srtninja
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What is this evic symbol? Jdsmitty10 Grand Cherokee - WK2 - 6 01-22-2014 06:35 PM
3 Car symbol on upper right hand corner? armoredsaint Audio/Visual/Navigation 7 07-08-2012 10:59 PM
change Nav symbol from arrow to jeep? BackInBlack Audio, Video, Navigation & Electronic Modifications 3 01-16-2012 12:15 PM
Odd idle when shifting... Martyp Grand Cherokee - WK 25 08-17-2009 05:58 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:50 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.