Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 03-08-2012, 12:32 AM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 872
Smoke1991 is on a distinguished road
Re: Oil leak, 3 days old, less than 200 miles!!! PICS!!!

Well it turned out to be the rear main seal, they are also saying one of the plugs that go into the block directly above the crank seal is also leaking, ill get some photos for you guys hopefully up by friday the latest. They just dropped the transmission today.
__________________

__________________
Reply With Quote
  #14  
Old 07-02-2012, 01:13 AM
Member
 
Join Date: Nov 2011
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1006
jhale2004 is on a distinguished road
Re: Oil leak, 3 days old, less than 200 miles!!! PICS!!!

Ever get those photos?
__________________

__________________
Reply With Quote
  #15  
Old 07-02-2012, 09:50 AM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 872
Smoke1991 is on a distinguished road
Re: Oil leak, 3 days old, less than 200 miles!!! PICS!!!

To be honest I forgot completely about this thread I made. But I do have some pics on my desktop computer. Unfortunately its out of commission (waiting for an rma motherboard).

Once I get it up and running I'll look around for them.

On a side note, the jeep has been fixed and I just did the first oil change to it last week. No problems except for the front differential housing being slightly wet .
__________________
Reply With Quote
  #16  
Old 07-02-2012, 01:02 PM
Member
 
Join Date: Nov 2011
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1006
jhale2004 is on a distinguished road
Re: Oil leak, 3 days old, less than 200 miles!!! PICS!!!

Quote:
Originally Posted by Smoke1991 View Post
To be honest I forgot completely about this thread I made. But I do have some pics on my desktop computer. Unfortunately its out of commission (waiting for an rma motherboard).

Once I get it up and running I'll look around for them.

On a side note, the jeep has been fixed and I just did the first oil change to it last week. No problems except for the front differential housing being slightly wet .

I ask because I have a leak in the exact same spot. I cleaned it off and 1 day later it already started forming a drip again.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Possible oil leak?? Anybody? Blueflame1979 Grand Cherokee - WK 17 10-24-2011 01:38 AM
Observations after 8 days and 1,500 miles rovinrail Grand Cherokee - WK2 - 8 08-21-2011 11:11 AM
Only 200 miles and it's already been in for service ctherc Trouble Shooting/Problems/Service 2 06-24-2011 11:52 AM
A family of 5: 4K miles in 16 days breaking in our 2011 Rubi. Dieselbud Wrangler-JK 2 04-12-2011 11:10 AM
BT Catch Can, 200 miles and already caught this much! sanitarium16 Grand Cherokee - WK 8 07-08-2010 11:04 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:55 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community