Oil pressure sensor, CEL - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-07-2015, 08:25 PM
ccp.jose's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2014
Location: Chile
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1133
ccp.jose is on a distinguished road
Oil pressure sensor, CEL

Hi folks!

Well basically im writing because yesterday when i started my JGC Laredo '14 i noticed that the check engine light didn't go away... so today i drove it to the dealer to get it scanned, i dont have the code but dealer said that it was the oil pressure sensor then showed that when the engine its not running the oil pressure gauge shows 90 psi -or lbs i dont remember the unit- totally no sense because when the engine its not running should show zero in the oil pressure page. Dealer also said that if im going to travel in a few days i have nothing to worry about and i just wanted to check that last information with you.

What do you think about it? some recommendation maybe?

Totally have no idea how could this happen.

PS: The new sensor should be arriving in a week or so.

Thanks!!!

__________________
Josť Alejandro
Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 02-07-2015, 10:54 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,865
Thanks: 0
Thanked 58 Times in 53 Posts
Rep Power: 82377
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: Oil pressure sensor, CEL

On my '12 I can read the oil pressure in the EVIC. What is yours reading when running ?

Used to have oil pressure senders fail so often I always kept a spare for my 3800s.
Reply With Quote
  #3  
Old 02-07-2015, 11:06 PM
ccp.jose's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2014
Location: Chile
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1133
ccp.jose is on a distinguished road
Re: Oil pressure sensor, CEL

when running my EVIC shows a range between 250 and 300 and when engine its not running shows about 80, but i cannot remember the unit, i will upload some photos later.

Thanks for the answer
__________________
Josť Alejandro
Reply With Quote
  #4  
Old 02-08-2015, 07:34 AM
MDBones's Avatar
OVERLAND HIGH ALTITUDE
My Jeep: 2016 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 3,653
Thanks: 664
Thanked 633 Times in 520 Posts
Rep Power: 10710
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: Oil pressure sensor, CEL

Quote:
Originally Posted by ccp.jose View Post
when running my EVIC shows a range between 250 and 300 and when engine its not running shows about 80, but i cannot remember the unit, i will upload some photos later.

Thanks for the answer
It sounds like your pressure reading is displaying metric kPa.

Assuming that your sensor is reading somewhat correctly when the engine IS running, 250-300 kPa would be within a normal operating range for oil pressure.
__________________
http://www.jeepgarage.org/members/54562-albums357-picture4858.png
Reply With Quote
  #5  
Old 02-08-2015, 12:37 PM
ccp.jose's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2014
Location: Chile
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1133
ccp.jose is on a distinguished road
Re: Oil pressure sensor, CEL

Quote:
Originally Posted by MDBones View Post
It sounds like your pressure reading is displaying metric kPa.

Assuming that your sensor is reading somewhat correctly when the engine IS running, 250-300 kPa would be within a normal operating range for oil pressure.
I checked today and when running idle evic shows an oil pressure of 236, and when engine its not running shows 36 after a few seconds shows 32 and then 36... interesting thing because yesterday showed 80 when engine was off.

Im thinking that by the time that the new sensor arrives the actual sensor will show the correct pressures.

And yes we use metric system....
__________________
Josť Alejandro
Reply With Quote
  #6  
Old 02-09-2015, 12:39 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Oregon
Posts: 74
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1488
justice37 is on a distinguished road
Re: Oil pressure sensor, CEL

No worry. Some of Chrysler's 2013~2014 vehicles have a defective oil pressure sensor. Chrysler already announce they will replace if the sensor is defective. It is just sensor, the car will run fine if there is no "real" problem in your car. Just don't use racing/off-road climb/towing. I had the same issue last year, but I needed to wait about 1 month until the replacement part arrived. My jeep was running well with this defective sensor.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure sensor pensfan414 Grand Cherokee - WK2 - 1 09-10-2014 01:07 PM
Oil Pressure / Oil Temp ggrassmid Diesel Powered WK Grand Cherokee 0 04-13-2014 03:25 AM
2005 WK 5.7L - P0520 Check Engine Code - Oil Pressure Sensor mroho Engine Performance/Intake/Exhaust 11 07-06-2013 12:32 PM
04 4.7HO oil pressure switch, vs actual oil pressure Sqall12001 Grand Cherokee - WJ 2 05-21-2012 03:00 PM
05' WK 5.7L Engine Oil Pressure Sensor Circuit Malfunction? Chaoul1 Troubleshooting/Problems 4 02-28-2012 12:56 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:56 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.