Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #157  
Old 06-16-2014, 12:10 PM
not_too_shabby's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: Portland, OR
Posts: 423
Thanks: 1
Thanked 10 Times in 10 Posts
Rep Power: 1021
not_too_shabby has a brilliant future
Re: Outside Temperature Sensor Problem

Quote:
Originally Posted by StaticFX View Post
i got the TSB done this am (along with the Brake recall - they installed some foam shield thing) and oddly enough... the HVAC acts differently now - like i had it set at 68 - and heat was on (even though it felt warm inside) - turning it down to 65 turned on the air. still playing, but its seems more responsive. lol.. odd. oh yeah, so far the temp sensor is fine.
Interesting. Hopefully it doesn't create a new problem with the HVAC. Keep us posted. Mine seems to work OK as it is.
__________________

__________________
2014 Grand Cherokee Overland 4x4 V6
Maximum Steel
Download my App - iLeaseMyCar Pro Auto Loan and Lease Calculator for iPhone or iPad
Reply With Quote
  #158  
Old 06-16-2014, 02:25 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 735
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1246
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Outside Temperature Sensor Problem

ok, the temp sensor is still slow to respond (took a good 3 minutes before it started to change..) sigh - i guess as long as it doesnt get stuck all day im happy
__________________

__________________
Reply With Quote
  #159  
Old 06-16-2014, 03:49 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 735
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1246
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Outside Temperature Sensor Problem

lol.. ok.. this time it took almost 15 minutes before it updated.... in otherwords, this TSB didnt do squat for me
__________________
Reply With Quote
  #160  
Old 06-16-2014, 03:59 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 1,201
Thanks: 38
Thanked 91 Times in 72 Posts
Rep Power: 2314
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: Outside Temperature Sensor Problem

Quote:
Originally Posted by StaticFX View Post
i got the TSB done this am (along with the Brake recall - they installed some foam shield thing) and oddly enough... the HVAC acts differently now - like i had it set at 68 - and heat was on (even though it felt warm inside) - turning it down to 65 turned on the air. still playing, but its seems more responsive. lol.. odd. oh yeah, so far the temp sensor is fine.
Did they also apply the HVAC fix TSB to yours or just this enhancment one with the temp sensor fix?
__________________
Reply With Quote
  #161  
Old 06-16-2014, 06:49 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 735
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1246
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Outside Temperature Sensor Problem

they were supposed to a month ago.. but said it didnt apply to mine (...um...ok lol) so no.
__________________
Reply With Quote
  #162  
Old 06-18-2014, 06:20 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 1,201
Thanks: 38
Thanked 91 Times in 72 Posts
Rep Power: 2314
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: Outside Temperature Sensor Problem

ok so had the brake booster recall done today and they did the flash for the temp sensor and the other dozen items. temp readout wrong and car alarm going off for no reason at various times where the issues and why I had the flash. so I get in start the jeep and the HVAC doesn't work figuring it will start I head home. after about 5 miles and 90 degrees outside I know something is wrong restart the car a few times with no luck go back to the dealer and we sit in the jeep and the tech turns ac auto mode off and it starts blowing air and he says see its fine. I press auto mode and say No it isn't fine auto is broke. he agrees they run tests give it back and say all modules operating as they should. so they open a case on it with Chrysler and say they will call me. going home I also notice the day runners are out and don't work. so as soon as I get home I do the old pull the battery cable trick as I have other times before. after letting it sit a while I started it and everything fine and working as it should and the temp sensor working correctly also.
I have said this in other threads these cars are getting more and more like computers when things are not working right reboot with the battery cable pull. so for those that got the flash and it didn't work or worse knocked down the HVAC like mine you may want to try the battery cable pull. The body control module interfaces with a lot of different areas apparently and the flash thoroughly confused my jeep so the battery pull just resunk everything I guess. may be worth a try if you have issues. also check your settings menu a lot of the items get reset to default with this flash like the equalizer, door locks things like that.
__________________
Reply With Quote
  #163  
Old 06-18-2014, 06:23 PM
Sudbury78's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Scottsdale, AZ
Posts: 132
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 692
Sudbury78 is on a distinguished road
Re: Outside Temperature Sensor Problem

Interesting post silvermax. I actually brought mine home today from getting my AC auto start issue fixed ( yay finally works) and my AC read out seems to be working well so I'm pleasantly surprised.
__________________
2014 Summit Granite and Brown V6 4X2 Ordered 5/7.

DELIVERED 6/19
Reply With Quote
  #164  
Old 06-18-2014, 06:29 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 1,201
Thanks: 38
Thanked 91 Times in 72 Posts
Rep Power: 2314
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: Outside Temperature Sensor Problem

Quote:
Originally Posted by Sudbury78 View Post
Interesting post silvermax. I actually brought mine home today from getting my AC auto start issue fixed ( yay finally works) and my AC read out seems to be working well so I'm pleasantly surprised.
yeah this one was the flash 08-053-14 "vehicle enhancements" actually doesn't have anything to do with the HVAC but the Body Control Module which this flash is for interfaces with the HVAC module and they talk so something got the jeep confused between the two. all good now just reboot
__________________
Reply With Quote
  #165  
Old 06-18-2014, 09:41 PM
StaticFX's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jul 2013
Posts: 735
Thanks: 1
Thanked 16 Times in 16 Posts
Rep Power: 1246
StaticFX has a reputation beyond reputeStaticFX has a reputation beyond reputeStaticFX has a reputation beyond repute
Re: Outside Temperature Sensor Problem

after a few days of the sensor taking as long as 20 minutes to update... today it was perfect. worked immediately on start..
__________________
Reply With Quote
  #166  
Old 06-19-2014, 07:07 AM
Member
 
Join Date: Jul 2013
Posts: 494
Thanks: 2
Thanked 21 Times in 16 Posts
Rep Power: 17750
TurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond reputeTurboRush has a reputation beyond repute
Re: Outside Temperature Sensor Problem

Quote:
Originally Posted by silvermax04 View Post
I have said this in other threads these cars are getting more and more like computers when things are not working right reboot with the battery cable pull.
Yep. I am not familiar with the actual implementation and communication processes between the modules but I know in my world if servers and components aren't brought back up in the right order everything can look fine but it won't work to save its life.

Everyone knows after most Windows updates you have to restart the machine - not to say its the same but - there is something to be said for things come back up and online in an orderly and "clean" manner, which is exactly what pulling the battery cable facilitates.
__________________
2014 Overland - Granite, Hemi
Reply With Quote
  #167  
Old 06-19-2014, 07:49 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 928
Thanks: 0
Thanked 42 Times in 33 Posts
Rep Power: 3540
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: Outside Temperature Sensor Problem

Quote:
Originally Posted by silvermax04 View Post

ok so had the brake booster recall done today and they did the flash for the temp sensor and the other dozen items.
I wish the dealerships in my area did things like this. It's like pulling teeth to get Jeep dealerships to perform flash TSBs.



Quote:
So I get in start the jeep and the HVAC doesn't work figuring it will start I head home. after about 5 miles and 90 degrees outside I know something is wrong restart the car a few times with no luck go back to the dealer and we sit in the jeep and the tech turns ac auto mode off and it starts blowing air and he says see its fine. I press auto mode and say No it isn't fine auto is broke.
Don't you just LOVE when dealerships forget to verify their work?

__________________
My V6 Overland transmission shifts like crap!
Reply With Quote
  #168  
Old 06-19-2014, 10:53 AM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 1,201
Thanks: 38
Thanked 91 Times in 72 Posts
Rep Power: 2314
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Re: Outside Temperature Sensor Problem

Quote:
Originally Posted by GCLimited View Post
I wish the dealerships in my area did things like this. It's like pulling teeth to get Jeep dealerships to perform flash TSBs.





Don't you just LOVE when dealerships forget to verify their work?

My last dealer was like that couldnt spell TSB, strange little pieces of paper they didnt know what to do with. Go to a new dealer the one i have now is pretty good so far thats why im cutting them a little slack on this one. dealers only do so much when it comes to software they loadem and it works or it doesnt. i dont think the whole reboot the jeep thing has resonated with any of the dealers yet as a good first try on troubleshooting. Maybe it will in the future when they realize these jeeps are becoming more just like a big computer. Find a new dealer it can be the difference between night and day.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery temperature sensor stingray66 Grand Cherokee - WJ 4 05-13-2012 09:52 PM
unusual tpms sensor problem help! tyler05wk Troubleshooting/Problems 4 01-01-2012 06:44 PM
jeep commander temperature sensor filo8818 2005+ Jeep Commander XK 3 05-08-2011 06:59 PM
Digital temperature control swap for rotary temperature control? Juan Audio, Video, Navigation & Electronic Modifications 3 04-05-2011 02:24 PM
Knock Sensor Problem... amw5 Grand Cherokee - WK 4 08-24-2010 12:30 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:28 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.