Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 04-09-2013, 03:23 AM
dco397's Avatar
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Sep 2010
Location: Walla Walla, WA
Posts: 48
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1475
dco397 is a splendid one to behold
Garage
Re: Outside Temperature Sensor Problem

I think this is a Chrysler thing. I had a 2006 Charger R/T and the temp readout was always off at first. I assumed it was the last reading from the night before or something until it adjusted after driving for a few minutes. My 2010 Challenger is the same way, and my 2013 GC does it too. As far as remote start, my HVAC has always activated on my GC when I use it. If it's cold, HVAC runs, and seat warmers activate.
__________________

__________________
Tom in Walla Walla, WA
Reply With Quote
  #14  
Old 04-09-2013, 06:13 AM
JeeperJohn's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2011
Location: Northeastern Pennsylvania
Posts: 515
Thanks: 83
Thanked 58 Times in 31 Posts
Rep Power: 7911
JeeperJohn has a reputation beyond reputeJeeperJohn has a reputation beyond reputeJeeperJohn has a reputation beyond reputeJeeperJohn has a reputation beyond reputeJeeperJohn has a reputation beyond reputeJeeperJohn has a reputation beyond reputeJeeperJohn has a reputation beyond reputeJeeperJohn has a reputation beyond reputeJeeperJohn has a reputation beyond reputeJeeperJohn has a reputation beyond reputeJeeperJohn has a reputation beyond repute
Re: Outside Temperature Sensor Problem

My 2011 Overland had no issues. My 2014 Summit will display the same wrong temperature for hours and suddenly correct itself. Seems as though its not updating the reading as often as it should.
__________________

__________________
Sold - 2008 Grand Cherokee Limited 5.7
Wife's Mall Crawler

Sold - 2011 Grand Cherokee Overland 5.7
Black Crystal Pearl / Saddle

Delivered: '14 Summit, Deep Cherry Red / Jeep Brown, 5.7, 4x4, CD player
21,000 miles, still flawless
Reply With Quote
  #15  
Old 04-09-2013, 06:54 PM
BobsWK2's Avatar
Premium Member
 
Join Date: Aug 2010
Posts: 1,520
Thanks: 3
Thanked 23 Times in 21 Posts
Rep Power: 49513
BobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond repute
Re: Outside Temperature Sensor Problem

My previous 2012 Overland and current 2014 Summit responds quickly. I wonder why there is such a difference, even on same year and models. I would think Jeep has been using the same temp sensor since the 2011's.
__________________
2014 Summit 4X4, V8
Reply With Quote
  #16  
Old 04-09-2013, 07:31 PM
Northland's Avatar
I go where my Jeep goes.
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2012
Posts: 422
Thanks: 15
Thanked 26 Times in 22 Posts
Rep Power: 1475
Northland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond repute
Re: Outside Temperature Sensor Problem

Quote:
Originally Posted by JeeperJohn View Post
My 2011 Overland had no issues. My 2014 Summit will display the same wrong temperature for hours and suddenly correct itself. Seems as though its not updating the reading as often as it should.
This is what my '14 Limited with RA4/nav is doing - always displays far lower outside temp than actual; sometimes it corrects itself as I'm driving and sometimes it doesn't. I'll probably have a dealership look at this at some point, but I dread should they have to remove the RA4 for any reason just to check the temp reading.
__________________
Ordered 2/04/13, Built and Status KZ (Plant Release) on 2/19/13, delivered 2/28/13: 2014 Limited 4x4 in Bright White with Lt. Frost Beige interior; Hemi V8; ORA II; RA4 UConnect.
So far: 20% tint all around; black BT oil catch can; Jeep slush and cargo mats; Blackvue DR500GW-HD dashcam; DropStops; XtremeDigital 4300K low beam HIDs; 5000K LED fog lights; Airaid CAI with SynthaMax dry filter. And now rollin' with UConnect 14.25.5!!
Reply With Quote
  #17  
Old 04-09-2013, 07:58 PM
not_too_shabby's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: Portland, OR
Posts: 395
Thanks: 1
Thanked 8 Times in 8 Posts
Rep Power: 909
not_too_shabby has a brilliant future
I wonder if there is a calibration step that is not being done at the factory? Hence the variance.
__________________
2014 Grand Cherokee Overland 4x4 V6
Maximum Steel
Download my App - iLeaseMyCar Pro Auto Loan and Lease Calculator for iPhone or iPad
Reply With Quote
  #18  
Old 04-09-2013, 08:21 PM
Theo P.'s Avatar
Member
 
Join Date: Apr 2013
Location: Massachusetts
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 490
Theo P. is on a distinguished road
Garage
Re: Outside Temperature Sensor Problem

It's interesting to hear that I'm not the only one with a 2014 that's doing this. I've continued to observe it. This morning it moved after awhile to 43. Then it stayed there on two errands today - it was 70 out. Later on, my drive was longer and it moved ... up to 53. Then driving back home, it made it up to 64 after awhile. Strange. I'll take it in for service and report back. It's also interesting to read about the other Chryslers that have had odd temp sensor issues. It seems like this is a simple sensor and straightforward bit of data. The note about calibration is an interesting one. Are there folks on the forum who would know if there is a service bulletin on this or who have seen this issue in service departments and know if there's a fix?
__________________
Reply With Quote
  #19  
Old 04-11-2013, 06:17 PM
Premium Member
 
Join Date: Aug 2010
Posts: 103
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1683
azzolij has a reputation beyond reputeazzolij has a reputation beyond reputeazzolij has a reputation beyond reputeazzolij has a reputation beyond reputeazzolij has a reputation beyond reputeazzolij has a reputation beyond reputeazzolij has a reputation beyond repute
Re: Outside Temperature Sensor Problem

http://www.wk2jeeps.com/tsb/tsb_wk2_0804611.pdf

This resolved the issue on my 2011.
__________________
Reply With Quote
  #20  
Old 04-11-2013, 08:39 PM
Theo P.'s Avatar
Member
 
Join Date: Apr 2013
Location: Massachusetts
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 490
Theo P. is on a distinguished road
Garage
Re: Outside Temperature Sensor Problem

Quote:
Originally Posted by azzolij View Post
http://www.wk2jeeps.com/tsb/tsb_wk2_0804611.pdf

This resolved the issue on my 2011.
Thanks azzolij - I'll print that and take it with me to the service appointment.
__________________
Reply With Quote
  #21  
Old 04-22-2013, 09:02 PM
Keelingg's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 568
Keelingg is on a distinguished road
Re: Outside Temperature Sensor Problem

Same problem here, outside air reads 15-20 degrees lower that actual temperature. This causes the heated seats and steering wheel to come on until the sensor starts reading correctly. This morning it was 55 degrees outside and the sensor read 35 and it slowly increased and took about 15 minutes to reach the correct temperature.
__________________
Reply With Quote
  #22  
Old 04-22-2013, 09:41 PM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,056
Thanks: 207
Thanked 146 Times in 119 Posts
Rep Power: 89441
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: Outside Temperature Sensor Problem

Not normal. Mine works fine. Temp changes as soon as I back out of my garage.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #23  
Old 05-20-2013, 08:30 PM
Member
 
Join Date: Apr 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 485
srhawkins is on a distinguished road
I have a 2014 GC Summit with 1950 miles on it. OAT sensor is stuck on 81 degrees today even though the real OAT is 90.
__________________
Reply With Quote
  #24  
Old 05-20-2013, 09:59 PM
not_too_shabby's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: Portland, OR
Posts: 395
Thanks: 1
Thanked 8 Times in 8 Posts
Rep Power: 909
not_too_shabby has a brilliant future
Re: Outside Temperature Sensor Problem

Quote:
Originally Posted by srhawkins View Post
I have a 2014 GC Summit with 1950 miles on it. OAT sensor is stuck on 81 degrees today even though the real OAT is 90.
Mine has done this three times over the last couple weeks. Hopefully a software update will fix it.
__________________

__________________
2014 Grand Cherokee Overland 4x4 V6
Maximum Steel
Download my App - iLeaseMyCar Pro Auto Loan and Lease Calculator for iPhone or iPad
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery temperature sensor stingray66 Grand Cherokee - WJ 4 05-13-2012 09:52 PM
unusual tpms sensor problem help! tyler05wk Troubleshooting/Problems 4 01-01-2012 06:44 PM
jeep commander temperature sensor filo8818 2005+ Jeep Commander XK 3 05-08-2011 06:59 PM
Digital temperature control swap for rotary temperature control? Juan Audio, Video, Navigation & Electronic Modifications 3 04-05-2011 02:24 PM
Knock Sensor Problem... amw5 Grand Cherokee - WK 4 08-24-2010 12:30 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community