Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 11-02-2012, 11:51 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2011
Location: Olathe, KS
Posts: 928
Thanks: 0
Thanked 12 Times in 12 Posts
Rep Power: 3571
kkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond reputekkreit01 has a reputation beyond repute
Re: Overland 5.7 feels very sluggish...

Feel sluggish until another V6 vs. V8 thread...
__________________

__________________
2011 Laredo X in White Gold: QT1, V6, Tow Package, Sunroof, Mopar Step Bars/Slush Mats, 20% Tint, Airaid Intake.
Reply With Quote
  #14  
Old 11-05-2012, 10:59 PM
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Sep 2010
Location: Queens Co. NY
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1536
Bob WK2 is on a distinguished road
Re: Overland 5.7 feels very sluggish...

I have the lack of power issue in my 5.7L as well. When the engine temp is 200
F or below it runs great and downshifts as expected when accelerating. Once a certain temp is reached, (it does go up to 226 F before dropping back down) the throttle response and downshifting is unacceptable.
In fact it is dangerous if you need to get out of the way of a situation immediately and are not able to do so.
Any one have this issue? I know there was a TSB that was performed on my Jeep about a year ago which made a slight improvement but on a late model engine this should not be happening.
__________________

__________________
Reply With Quote
  #15  
Old 11-06-2012, 02:40 PM
Member
 
Join Date: Oct 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 736
James Cole is on a distinguished road
Re: Overland 5.7 feels very sluggish...

You guys think a tune when its available will remedy this?
__________________
Reply With Quote
  #16  
Old 12-11-2012, 06:21 PM
CJMAJ423's Avatar
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Aug 2011
Location: Westchester Co, NY
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1123
CJMAJ423 is on a distinguished road
Re: Overland 5.7 feels very sluggish...

I too am experiencing an extremely lethargic 5.7L. I drove my mothers 2011 WK2 Limited 5.7L and it was literally night and day. The 11' Limited was blazing fast compared to my 13' Overland; and I use 93 octane!! I can't remember if the 11' was this sluggish new or if it opened up after some miles were put on. Either way, quite annoying.
__________________
Reply With Quote
  #17  
Old 12-11-2012, 10:58 PM
Premium Member
My Jeep: 2011 5.7L WK2
 
Join Date: Sep 2010
Location: Queens Co. NY
Posts: 94
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1536
Bob WK2 is on a distinguished road
Re: Overland 5.7 feels very sluggish...

I had my 4.7 Limited in the dealer last week to try to find the cause of the intermittent poor performance problem.

They road tested and didn't feel any problem. They also checked for error codes and found nothing.

My problem only occurs when the engine temp gets up over 215 F. This didn't happen on the dealers road test. (It will go as high as 226 F before dropping back down to around 205 F in stop & go driving).

There is obviously an issue here, my guess is that the computer is mis-adjusting either timing or fuel mixture at higher engine temps. Have to guess at this because Chrysler doesn't have a clue.
__________________
Reply With Quote
  #18  
Old 08-29-2013, 03:30 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2010
Location: Colorado
Posts: 28
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1673
jhedman2 is on a distinguished road
Re: Overland 5.7 feels very sluggish...

So this is interesting. Just about everything here being described is exactly what i'm faced with, and it's ridiculously annoying. Has anyone found any fixes yet? So I wanted to throw out a few observations i have as well.

First, for my 11 WK2 Hemi, the poor performance definitely seems to be far more noticeable with higher outside temperatures. it's been this way since i bought, and it's annoying. Now that's normal, i mean its well known that colder air has a higher O2 density, so engines usually run a little better, but this is sad.

Second, it's almost like clock work. Just about anytime my tach is in the green section, power is pretty weak. Almost instantly when i'm out the green (around 2500RPM i believe) power increases dramatically.

Using AC definitely affects power as well. Which when you consider the engine is 350+ HP, AC shouldn't cause that much of a torque loss.

Hammering the throttle reduces power, vs. slow throttle pressure. This makes no sense, I can hammer the throttle on my Subaru with great power, I can do the same in a BMW X5, Toyota Tundra, etc. Why on the Jeep do i get less power/torque.

Lastly, I've tried even the Interceptor system but still, the power is weak! Turning on Tow/Haul mode, and Switching the select-trac to Sport helps, but not much.

Any help would be appreciated.
__________________
Reply With Quote
  #19  
Old 09-02-2013, 10:09 AM
jgc4ever's Avatar
Senior Member
My Jeep: 2012 5.7L WK2
 
Join Date: Mar 2011
Posts: 3,206
Thanks: 0
Thanked 78 Times in 69 Posts
Rep Power: 1160243
jgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond repute
Garage
Re: Overland 5.7 feels very sluggish...

Quote:
Originally Posted by jhedman2 View Post
So this is interesting. Just about everything here being described is exactly what i'm faced with, and it's ridiculously annoying. Has anyone found any fixes yet? So I wanted to throw out a few observations i have as well.

First, for my 11 WK2 Hemi, the poor performance definitely seems to be far more noticeable with higher outside temperatures. it's been this way since i bought, and it's annoying. Now that's normal, i mean its well known that colder air has a higher O2 density, so engines usually run a little better, but this is sad.

Second, it's almost like clock work. Just about anytime my tach is in the green section, power is pretty weak. Almost instantly when i'm out the green (around 2500RPM i believe) power increases dramatically.

Using AC definitely affects power as well. Which when you consider the engine is 350+ HP, AC shouldn't cause that much of a torque loss.

Hammering the throttle reduces power, vs. slow throttle pressure. This makes no sense, I can hammer the throttle on my Subaru with great power, I can do the same in a BMW X5, Toyota Tundra, etc. Why on the Jeep do i get less power/torque.

Lastly, I've tried even the Interceptor system but still, the power is weak! Turning on Tow/Haul mode, and Switching the select-trac to Sport helps, but not much.

Any help would be appreciated.
This recent TSB: http://www.wk2jeeps.com/tsb/tsb_wk2_2100613.pdf might fix it. I haen't had it done yet but need to. A few that have had it done and commented have been happy with the improvements saying it takes away the sluggishness (downshifts and delays upshifting better as appropriate to the driving situation).
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sluggish and no reverse! BLKCRD Troubleshooting/Problems 8 05-07-2013 06:48 PM
Swapped grille...now sluggish V6 Kindnug Trouble Shooting/Problems/Service 2 08-20-2011 12:17 PM
Front end feels very loose with thuds Troy Cruise Trouble Shooting/Problems/Service 5 07-06-2011 07:48 PM
Feels like Vegas! Mlebout Grand Cherokee - WK2 - 4 06-02-2011 03:36 PM
front end feels... hemi_shox Grand Cherokee - WK 4 06-01-2011 12:28 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:56 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community