Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
View Poll Results: What are your experiences with the Quadra-Lift system?
No problems - works as expected. 279 96.54%
Early Problem (less than 1000 mi) - resolved. 12 4.15%
Later Probelm ( more than 1000 mi) - resolved. 10 3.46%
Continuing problem - no resolution yet. 31 10.73%
Multiple Choice Poll. Voters: 289. You may not vote on this poll

Reply
 
Thread Tools Display Modes
 
  #61  
Old 05-23-2012, 11:20 PM
Lingohocken's Avatar
Premium Member
My Jeep: 2012 3.6L WK2
 
Join Date: Feb 2010
Location: Bucks County, Pennsylvania
Posts: 1,185
Thanks: 15
Thanked 9 Times in 6 Posts
Rep Power: 3234
Lingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond reputeLingohocken has a reputation beyond repute
Re: Poll - Problems with Quadra-Lift?

Quote:
Originally Posted by aimpulsive View Post
Mdb I have a 2012 overland with 4000 miles and it also will not go into the top two settings....the lights just blink. Goes fine in normal, aero, and park modes.

Just started not working last weekend.
Same exact symptoms as on ours. A new compressor and all is now back to normal.
__________________

__________________
2012 Cherry Overland V6, ADG
Reply With Quote
  #62  
Old 05-24-2012, 11:06 AM
Member
 
Join Date: May 2012
Posts: 90
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 890
E55 Bulldog is a name known to all
Re: Poll - Problems with Quadra-Lift?

Quote:
Originally Posted by Lingohocken View Post
It's a great feature, but get Chrysler Maxcare to cover however long you plan to keep the vehicle. Our QL compressor started fading at 11k miles, and the fix would be well over $1k if it weren't covered by warranty.
Thanks. I just picked up a 2011 Overland Summit with 4k on it... but it is in the shop already, didn't even have it for 24 hours hahahaa... But it was not for the QL it is because one of the PMC units that controlled the headlights went bad and they have to replace the whole unit.
__________________

__________________
Reply With Quote
  #63  
Old 06-05-2012, 08:56 AM
MDBJGC's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Nov 2011
Location: Huntsville, AL
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1004
MDBJGC is on a distinguished road
Re: Poll - Problems with Quadra-Lift?

The compressor on the QL was replaced in Feb 2012. It has work flawlessly ever since. The adjustments complete more smoothly and quickly than ever before.
__________________
2011 Overland Summit 4x4
Rugged Brown
5.7L Hemi

[SIGPIC][/SIGPIC]
Reply With Quote
  #64  
Old 06-05-2012, 10:22 AM
Yadkin's Avatar
Senior Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2012
Location: Yadkin Valley, NC
Posts: 1,243
Thanks: 0
Thanked 16 Times in 16 Posts
Rep Power: 202229
Yadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond repute
Re: Poll - Problems with Quadra-Lift?

No problems after 8000 miles. I routinely use sport mode- lots of curvy road here, and about half the time lower it when I pull in my driveway just before I park it.
__________________
Reply With Quote
  #65  
Old 06-06-2012, 01:14 AM
jgc4ever's Avatar
Senior Member
My Jeep: 2012 5.7L WK2
 
Join Date: Mar 2011
Posts: 3,174
Thanks: 0
Thanked 76 Times in 67 Posts
Rep Power: 1160169
jgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond reputejgc4ever has a reputation beyond repute
Garage
Re: Poll - Problems with Quadra-Lift?

Quote:
Originally Posted by Yadkin View Post
No problems after 8000 miles. I routinely use sport mode- lots of curvy road here, and about half the time lower it when I pull in my driveway just before I park it.
Same exactly for mine.
__________________
Reply With Quote
  #66  
Old 07-30-2012, 01:42 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Sep 2011
Location: NJ
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1048
yoyo is on a distinguished road
Re: Poll - Problems with Quadra-Lift?

I'm new to this forum.....I have to say you guys are awesome with the all the helpful information I found here. I've been having problems for three months now. The quadra-trac II activates at different times while driving. On the highway I've had it raise to the full OR2 height while driving 60+ on the highway. Very dangerous in my opinion. I live in New Jersey and have attempted to set an appointment at Teterboro Jeep, for those who are familiar, and they're horrible!! Service Department told me the vehicle needs to stay in the shop at least a week until they find out what is causing the QT to activate on its own. One service rep stated that the lines tend to kink after a while and it's a known issue so i'll guess we'll see......If no luck, I'm really considering trading it in and getting me an SRT.....but that 2014 model looks tempting! lol
__________________
Reply With Quote
  #67  
Old 07-30-2012, 07:36 PM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jan 2012
Posts: 538
Thanks: 46
Thanked 4 Times in 4 Posts
Rep Power: 163933
JRNYC has a reputation beyond reputeJRNYC has a reputation beyond reputeJRNYC has a reputation beyond reputeJRNYC has a reputation beyond reputeJRNYC has a reputation beyond reputeJRNYC has a reputation beyond reputeJRNYC has a reputation beyond reputeJRNYC has a reputation beyond reputeJRNYC has a reputation beyond reputeJRNYC has a reputation beyond reputeJRNYC has a reputation beyond repute
Re: Poll - Problems with Quadra-Lift?

Quote:
Originally Posted by yoyo View Post
I'm new to this forum.....I have to say you guys are awesome with the all the helpful information I found here. I've been having problems for three months now. The quadra-trac II activates at different times while driving. On the highway I've had it raise to the full OR2 height while driving 60+ on the highway. Very dangerous in my opinion. I live in New Jersey and have attempted to set an appointment at Teterboro Jeep, for those who are familiar, and they're horrible!! Service Department told me the vehicle needs to stay in the shop at least a week until they find out what is causing the QT to activate on its own. One service rep stated that the lines tend to kink after a while and it's a known issue so i'll guess we'll see......If no luck, I'm really considering trading it in and getting me an SRT.....but that 2014 model looks tempting! lol
I think you are referring to quadra lift going up and down not quadra track 2. Mine has done this but only like 3 times in 6 months.

Yours sounds fekked! 60 MPH you better watch out for MOOSE if your in OR2 !
__________________
Reply With Quote
  #68  
Old 07-30-2012, 07:43 PM
dobiegillis's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2011
Location: Atlanta
Posts: 275
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1511
dobiegillis is on a distinguished road
Quote:
Originally Posted by JRNYC View Post
I think you are referring to quadra lift going up and down not quadra track 2. Mine has done this but only like 3 times in 6 months.

Yours sounds fekked! 60 MPH you better watch out for MOOSE if your in OR2 !
Same with me. And I agree.

Sent from my SGH-T989 using Tapatalk 2
__________________
2011 Summit 4x4, Hemi, Brilliant Black/Saddle
Reply With Quote
  #69  
Old 07-30-2012, 08:11 PM
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Nov 2011
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 964
ov10mech is on a distinguished road
Thumbs down Re: Poll - Problems with Quadra-Lift?

8k Miles. If I put it all the way up it just sticks. Waiting for dealer to get back to me. Friend had similar issue when he took delivery. We both have 2011 Overlands. I bet if everyone actually tried to use all the functions there would be more complaints. I bet 90% of people put it in auto and never pay attention.

I took a video of my issue....

__________________
Reply With Quote
  #70  
Old 07-30-2012, 09:22 PM
Member
 
Join Date: Oct 2010
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1370
daleviewrd is on a distinguished road
Re: Poll - Problems with Quadra-Lift?

Quote:
Originally Posted by rich mac View Post
With all the talk of Quadra-Lift problems on this and other forums, what kind of experience have you had with your QL system?
No problems at 30,000 miles
__________________
Rich is a follower of Jesus Christ
He drives:
2011 Jeep Grand Cherokee - Overland 4WD - V8
Dark Characol Pearl Ext / Frost Int
DVD/ 730
97 Dodge Diesel 2500
05 C6 Corvette Convertible
2005 Harley Davidson Ultra Classic
1992 Custom Harley Davidson Rats Hole Champ
2003 Infinity G35
Reply With Quote
  #71  
Old 07-31-2012, 04:36 PM
Member
My Jeep: 2012
 
Join Date: Jul 2012
Location: Orange County, CA
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 746
rilo2012 is on a distinguished road
Re: Poll - Problems with Quadra-Lift?

I have the 2012 Overland with QL, bought in April so probably manufactured Feb or March. Haven't really used the QL except I noticed once on the highway it went into the aero mode - I thought by itself (not sure if it's supposed to do this, have to check the manual again). After reading this thread, ran out and tested the QL and okay at all levels - at 2900 miles.
__________________
Reply With Quote
  #72  
Old 08-01-2012, 06:51 AM
dobiegillis's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Feb 2011
Location: Atlanta
Posts: 275
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 1511
dobiegillis is on a distinguished road
Quote:
Originally Posted by rilo2012 View Post
I have the 2012 Overland with QL, bought in April so probably manufactured Feb or March. Haven't really used the QL except I noticed once on the highway it went into the aero mode - I thought by itself (not sure if it's supposed to do this, have to check the manual again). After reading this thread, ran out and tested the QL and okay at all levels - at 2900 miles.
Aero mode is automatic at 62mph or when you manually put it in sport mode


Sent from my iPad using Tapatalk
__________________

__________________
2011 Summit 4x4, Hemi, Brilliant Black/Saddle
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quadra Lift barho Suspension/Driveline/Brakes/Wheels/Tires 89 10-24-2012 06:54 AM
For those of you with quadra-lift... msaenger Grand Cherokee - WK2 - 26 02-25-2011 01:38 AM
Quadra Lift JujuB Trouble Shooting/Problems/Service 5 01-14-2011 03:11 PM
Quadra lift LJS8510 Grand Cherokee - WK2 - 26 05-18-2010 11:19 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community