"Power outlet" problems/no power ? - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-15-2016, 09:02 AM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jan 2013
Location: Central Virginia
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1449
glenn27 is on a distinguished road
"Power outlet" problems/no power ?

Good morni9ng-Folks...Haven't been on here for awhile, and I apologize for that--I know there are some very 'techie' type gear heads here--some way over my limit.
Anyway-I have small problem...

2012 Grand Cherokee...39,000 miles--great shape. LOVE it!~!

Went on a road trip last week--my daughter in the back seat--she plugs her phone in to charge on the outlet on back of console--no juice!

Outlet inside the bottom/second layer down of the console is "hot'--so she runs her cord up and uses that.
OK--I check farther with test light when we get home---out- let inside front cup-holder (in front of shifter) is also 'dead' WTH?? Checked the one all way in back storage area on right side--that works The manual only calls these power outlet #1 or 2 or 3--doesn't show where each one actually is.
I have the Haynes manual

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 07-17-2016, 04:23 PM
Governor's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Apr 2016
Location: Alabama
Posts: 1,216
Thanks: 379
Thanked 193 Times in 179 Posts
Rep Power: 78404
Governor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond reputeGovernor has a reputation beyond repute
Re: "Power outlet" problems/no power ?

Did you check the fuses?
Reply With Quote
  #3  
Old 07-19-2016, 07:42 PM
Member
My Jeep: 2015 WK2
 
Join Date: Sep 2015
Location: Phoenix, AZ
Posts: 202
Thanks: 6
Thanked 50 Times in 39 Posts
Rep Power: 719
Billscarnage has a reputation beyond reputeBillscarnage has a reputation beyond reputeBillscarnage has a reputation beyond reputeBillscarnage has a reputation beyond repute
Re: "Power outlet" problems/no power ?

I've got the same problem and am having the dealer look at it this week. Still under 3/36.

It acts almost like there is a short as when I plug in an air mattress pump, the pump kicks on for a split second and stops. Then nothing. If I restart the GC the exact same thing happens. Pump kicks on for a split second an then nothing after that.
__________________
2015 WK2 Limited | Lux II | ORA 1 | 8.4 Nav | White & Beige

Coming mods
Black out chrome | Mopar Rails
Reply With Quote
  #4  
Old 07-19-2016, 08:26 PM
silvermax04's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Feb 2013
Posts: 3,350
Thanks: 254
Thanked 556 Times in 430 Posts
Rep Power: 30279
silvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond reputesilvermax04 has a reputation beyond repute
Yeah I had the same problem with the mattress pump when camping and it's because the plug is only rated to 150w which is practically usless in todays world. It won't even power the charger on my laptop.
Reply With Quote
  #5  
Old 07-20-2016, 05:48 AM
f1anatic's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Jan 2013
Location: Chicago, IL
Posts: 1,674
Thanks: 68
Thanked 183 Times in 136 Posts
Rep Power: 159922
f1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond reputef1anatic has a reputation beyond repute
Re: "Power outlet" problems/no power ?

I did as well recently when the whole USB, 12V and 110V outlets failed on me. I replaced the appropriate fuses - which despite the seemingly good appearance didn't work anymore. I don't know if it is important to remove them all at once or replace them with new ones and replace them back if you insist on trying the old ones and they are visibly not burnt.
Reply With Quote
  #6  
Old 07-20-2016, 12:14 PM
JeepCares's Avatar
Jeep Customer Service
 
Join Date: Jan 2016
Location: Michigan
Posts: 150
Thanks: 1
Thanked 46 Times in 31 Posts
Rep Power: 200989
JeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond reputeJeepCares has a reputation beyond repute
Re: "Power outlet" problems/no power ?

Quote:
Originally Posted by Billscarnage View Post
I've got the same problem and am having the dealer look at it this week. Still under 3/36.

It acts almost like there is a short as when I plug in an air mattress pump, the pump kicks on for a split second and stops. Then nothing. If I restart the GC the exact same thing happens. Pump kicks on for a split second an then nothing after that.
Let me know if you need further assistance after visiting dealer - Kevin T, Social Connect Team
Reply With Quote
  #7  
Old 10-30-2016, 09:25 AM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jan 2013
Location: Central Virginia
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1449
glenn27 is on a distinguished road
Question Re: "Power outlet" problems/no power ?

Back here after mucho time...
I see some others have posted since I was here.....
Back story is--I remember when we purchased this Jeep.(About 11 months old-then)--the service tech had 'fixed' a wire problem for the rear out-let--
I remember seeing it onthe service order...

Now my question--yes, I checked the fuses--Under the hood--on the right fender well..Have the 5.7 Hemi engine--so I think some fuse panels are in different places. Anyway--two places-looking in the manual.

Fuses M5 M6 and M7 all control these outlets inside the vehicle. Says M7 is 'switchable'--what does that mean?

glenn
Reply With Quote
  #8  
Old 10-31-2016, 08:14 AM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jan 2013
Location: Central Virginia
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1449
glenn27 is on a distinguished road
Re: "Power outlet" problems/no power ?

Quote:
Originally Posted by glenn27 View Post
Back here after mucho time...
I see some others have posted since I was here.....
Back story is--I remember when we purchased this Jeep.(About 11 months old-then)--the service tech had 'fixed' a wire problem for the rear out-let--
I remember seeing it onthe service order...

Now my question--yes, I checked the fuses--Under the hood--on the right fender well..Have the 5.7 Hemi engine--so I think some fuse panels are in different places. Anyway--two places-looking in the manual.

Fuses M5 M6 and M7 all control these outlets inside the vehicle. Says M7 is 'switchable'--what does that mean?

glenn
////////////////////////////

I checked the fuses again the other day-#5 and 6 are 'dead'-=-no current to either one...so what 'feeds them?
I guess is what I need to know--wire diagram doesn't really show..

glenn
Reply With Quote
  #9  
Old 11-02-2016, 05:34 PM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jan 2013
Location: Central Virginia
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1449
glenn27 is on a distinguished road
Re: "Power outlet" problems/no power ?

Nobody else run across this?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dash lighter and power outlet Bigdiesel74 Grand Cherokee - WK 1 05-04-2011 01:18 PM
Rear Power Outlet JTK1130 Grand Cherokee - WK 6 12-31-2010 12:08 PM
lighter cover/power outlet cover cain45 Grand Cherokee - WK 23 07-13-2010 07:49 AM
Power outlet removal cncannone Grand Cherokee - WK 1 05-31-2010 02:19 PM
power outlet in rearseat problem 2008hemi Troubleshooting/Problems Discussion 4 01-24-2010 04:11 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:36 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.