Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-14-2012, 09:20 AM
Member
 
Join Date: Jan 2011
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1421
7upstang is on a distinguished road
Problem with my radio

I have a 2011 GC Laredo X, the issue that I just started having is that my iPhone 4 no longer will uconnect to the radio. When I got the jeep I synced them together and it worked fine. Now it shows they are connected, but no sound. The phone feature works fine. Any suggestions? I thought about un-syncing the phone and re-syncing, but don't know how to do that.

Thanks,
Jim
__________________

__________________
Reply With Quote
  #2  
Old 12-14-2012, 05:59 PM
Member
My Jeep: 2011 WK2
 
Join Date: Oct 2010
Location: Motor City
Posts: 121
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1553
Robey5 is on a distinguished road
Re: Problem with my radio

I am unsure of the radio that you have; but I suspect it is a 430N.

I have had problems with my Blackberry connecting as well at times. I "deleted" the device on both my 730N and "deleted" UCONNECT from my BB recently, and re-sync'ed them. I did this about a week ago, and my BB connects correctly again.

If you know how to manage the bluetooth connections on your phone (I do not know how to on an Iphone, as I do not use one) I would recommend that you delete the uconnect device on your Iphone (first, and while the JGC is OFF). I would then put the JGC in ACC mode, and go through the prompts to "delete" your Iphone from the Uconnect.

Then; I would go through the set up as you did the very first time when you picked up the JGC.

The above is the route I used to get a better connection to the uconnect with my BB; it works as intended now.

Hope that helps!
__________________

__________________
Current Vehicles:
93 Corvette, with lightly modded LT4/ZF6. Polo green, Beige interior - garage queen.
11 Overland V8/4x4 Mineral Grey/Lt. beige/730N
Dad's car; a project I recently took over: 79 Porsche 911SC, engine build ongoing...
Reply With Quote
  #3  
Old 12-15-2012, 01:38 PM
RoMe2's Avatar
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jan 2012
Location: Brick, NJ
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 999
RoMe2 is on a distinguished road
Re: Problem with my radio

Bring it back to the dealer. It's most likely a TSB for an upgrade to be performed. I had that problem with my Iphone a while back and they just did an update and it works completely fine. Good luck!
__________________
Appearance
Lights HID Low Beams 5000K
20% 3M Tint-Front and Rear Windows
WeatherTech FloorLiner DigitalFit-Black
WeatherTech Side Window Deflectors-Black
Packages
Laredo X
Laredo E Group
Trailer Tow Group
Off-Road Adventure 1
Reply With Quote
  #4  
Old 12-16-2012, 09:32 AM
Member
 
Join Date: Jan 2011
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1421
7upstang is on a distinguished road
Re: Problem with my radio

I just un-paired the iphone and re-paired it. Working now, Thanks!
__________________
Reply With Quote
  #5  
Old 12-18-2012, 09:13 AM
Member
 
Join Date: Apr 2011
Posts: 158
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 1658
xsdbs has a reputation beyond reputexsdbs has a reputation beyond reputexsdbs has a reputation beyond reputexsdbs has a reputation beyond reputexsdbs has a reputation beyond reputexsdbs has a reputation beyond reputexsdbs has a reputation beyond reputexsdbs has a reputation beyond reputexsdbs has a reputation beyond repute
Re: Problem with my radio

With a lot of the newer phones when something odd starts happening, a simple reboot of the phone helps a lot.
1) BlackBerry & Android phones, remove the battery for a couple minutes, then reinsert it. then retry the phone.
2) Apple phones, hold down the power & home buttons at the same time till the white apple appears, then release them and the phone will reboot.




Quote:
Originally Posted by 7upstang View Post
I just un-paired the iphone and re-paired it. Working now, Thanks!
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RER radio/nav problem Hemi_Girl Audio, Video, Navigation & Electronic Modifications 13 10-26-2012 03:09 PM
Problem with Radio/Speakers Javiiko Audio/Visual/Navigation 0 06-06-2012 08:23 AM
new radio problem nickdemarchis Audio, Video, Navigation & Electronic Modifications 8 09-12-2011 10:16 AM
Radio Presets Problem jmp42 Trouble Shooting/Problems/Service 3 05-31-2011 03:46 PM
2008 Nav Radio Problem JimmyNock Grand Cherokee - WK 11 05-07-2011 04:30 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community