Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-07-2014, 12:24 PM
fox_hound's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Location: south carolina
Posts: 77
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 22003
fox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond repute
problems with alternator and sounds like broken light bulbs from the engine

Yesterday was the first time it started. I cranked my 2012 Grand Cherokee laredo, and head this god awful screeching sound. I popped the hood to see if I could see something out of place or smoking. other than the sound everything was in place. called the dealership and talked to a guy named Bill. he said he would look at it real quick to make sure it was still OK to drive. 10 min later I arrived and he said it was more than likely the alternator and it was OK to drive. we set up an appointment for today @930am.
The battery light came on the entire way home after work 4-5 hours later.
cranked it a few more times after it had set in the yard. cranked fine. still had the noise.

This morning I cranked it just fine, went to the gas station for my red bull before heading to the dealership. After cutting it off for less than 2 min It tried to crank but did not have enought juice to do it. I tried to crank it 5-8 more times and the engine started to smoke and make the worst noise I had ever heard from an engine. I can only describe it as broken lamps in a box coming from inside the engine.

Called the dealership and they advised to have it towed. Thank god for roadside assistance. The jeep was bought in june of 2012 and has less than 19500 miles on it. so its still covered by the warranty.

trying to reach out to my Jeep friends. Have any of y'all experienced anything like this?

The lady with Chrysler road side assistance said they had had problems with the 2014's stalling. THEN the tow truck guy said they had pulled 20+ new 2014 jeeps with less than 20 miles on them in less than 2 weeks.

please help.
__________________

__________________
Reply With Quote
  #2  
Old 03-07-2014, 01:51 PM
Premium Member
 
Join Date: Feb 2014
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 218
sc32valve is on a distinguished road
Re: problems with alternator and sounds like broken light bulbs from the engine

Quote:
Originally Posted by fox_hound View Post
Yesterday was the first time it started. I cranked my 2012 Grand Cherokee laredo, and head this god awful screeching sound. I popped the hood to see if I could see something out of place or smoking. other than the sound everything was in place. called the dealership and talked to a guy named Bill. he said he would look at it real quick to make sure it was still OK to drive. 10 min later I arrived and he said it was more than likely the alternator and it was OK to drive. we set up an appointment for today @930am.
The battery light came on the entire way home after work 4-5 hours later.
cranked it a few more times after it had set in the yard. cranked fine. still had the noise.

This morning I cranked it just fine, went to the gas station for my red bull before heading to the dealership. After cutting it off for less than 2 min It tried to crank but did not have enought juice to do it. I tried to crank it 5-8 more times and the engine started to smoke and make the worst noise I had ever heard from an engine. I can only describe it as broken lamps in a box coming from inside the engine.

Called the dealership and they advised to have it towed. Thank god for roadside assistance. The jeep was bought in june of 2012 and has less than 19500 miles on it. so its still covered by the warranty.

trying to reach out to my Jeep friends. Have any of y'all experienced anything like this?

The lady with Chrysler road side assistance said they had had problems with the 2014's stalling. THEN the tow truck guy said they had pulled 20+ new 2014 jeeps with less than 20 miles on them in less than 2 weeks.

please help.
Sounds like an internal short in the alternator. Alternator was on its way out and stopped charging the battery, the battery light came on to indicate the battery was below normal voltage. You tried to crank it after the battery was too low and it either couldn't run the starter or the ignition system. Short in alternator most likely caused the smoke.
__________________

__________________
Reply With Quote
  #3  
Old 03-07-2014, 02:18 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,155
Thanks: 24
Thanked 61 Times in 54 Posts
Rep Power: 43571
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: problems with alternator and sounds like broken light bulbs from the engine

Quote:
Originally Posted by sc32valve View Post
Sounds like an internal short in the alternator. Alternator was on its way out and stopped charging the battery, the battery light came on to indicate the battery was below normal voltage. You tried to crank it after the battery was too low and it either couldn't run the starter or the ignition system. Short in alternator most likely caused the smoke.
... and hopefully fuses blew before the battery fried anything serious. Hopefully.
Is a rare thing, but makes a lot of noise and magic smoke when it happens.
__________________
Reply With Quote
  #4  
Old 03-07-2014, 04:43 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 799
Thanks: 0
Thanked 27 Times in 22 Posts
Rep Power: 73035
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: problems with alternator and sounds like broken light bulbs from the engine

Dealer should not advised you to continue to drive it. Only a matter of time before it was dead and you could do damage.

Hopefully smoke was from Alternator. I doubt it was, because the engine wasn't running when he smoked. I suspect starter or battery cables overheated.

Sounds like the Alternator just fell apart. Seized bearing or something.

When the battery is low and the starter doesn't turn, or you try too many times, you get high current in power cables. They can start to melt.

After it didn't start the first time, you were done.
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #5  
Old 03-07-2014, 05:00 PM
fox_hound's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Location: south carolina
Posts: 77
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 22003
fox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond repute
Re: problems with alternator and sounds like broken light bulbs from the engine

Thanks for the feedback guys!. i really appreciate it.

I have been resiting the urge to hurt someone at the dealership after this experience, the only thing that has stopped me is I don't feel like setting in jail tonight or half the weekend.

The dealership is refusing to get the replacement part from a dealer 45 min away. They are going to get it from a couple stats away. It will not be in till Tuesday of next week instead of having it fixed by noon tomorrow (Saturday) . They have refused to call the company that handles my extended coverage warranty to see if I can get a rental car. and now I can not even get in touch with the parts manager. He will not return my calls.

They "believe" its just the alternator and nothing in the engine was damaged. But after all the crap I have been through today you can understand why I am skeptical.

I have even contemplated paying out of my own pocket for it to be towed to the dealer i bought it from and have them fix it......45 min away.
__________________
Reply With Quote
  #6  
Old 03-07-2014, 05:06 PM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 799
Thanks: 0
Thanked 27 Times in 22 Posts
Rep Power: 73035
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: problems with alternator and sounds like broken light bulbs from the engine

Quote:
Originally Posted by fox_hound View Post
Thanks for the feedback guys!. i really appreciate it.

I have been resiting the urge to hurt someone at the dealership after this experience, the only thing that has stopped me is I don't feel like setting in jail tonight or half the weekend.

The dealership is refusing to get the replacement part from a dealer 45 min away. They are going to get it from a couple stats away. It will not be in till Tuesday of next week instead of having it fixed by noon tomorrow (Saturday) . They have refused to call the company that handles my extended coverage warranty to see if I can get a rental car. and now I can not even get in touch with the parts manager. He will not return my calls.

They "believe" its just the alternator and nothing in the engine was damaged. But after all the crap I have been through today you can understand why I am skeptical.

I have even contemplated paying out of my own pocket for it to be towed to the dealer i bought it from and have them fix it......45 min away.
Call ahead if you do that.

I'm sure engine is fine.

I'd be a little concerned about starter/battery cable. But that is partly your fault, if it is. And not a huge deal if it is. They CAN SMOKE if you really tried 5-8 times.

If it doesn't start after the 2nd time. Don't try again. It really stresses it.

Stay calm. It's not worth it. I know it's tough.
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #7  
Old 03-07-2014, 05:23 PM
fox_hound's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jul 2012
Location: south carolina
Posts: 77
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 22003
fox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond reputefox_hound has a reputation beyond repute
Re: problems with alternator and sounds like broken light bulbs from the engine

***update***
After causing a huge stink at the dealership with the manager and Chrysler. they just called and said my baby will be ready before they close at 6pm.

i dont mind being called an a hole or dick at the dealership. i just need my baby so i can go pick up my real babies.


"I'd be a little concerned about starter/battery cable. But that is partly your fault, if it is. And not a huge deal if it is. They CAN SMOKE if you really tried 5-8 times."

Sadly I was very mad and yes I did keep trying only because it got 90% cranked and then stopped. I am willing to accept blame for something I messed up. I will def look at this part more in-depth when I get her home.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fog Light Bulbs Laredo2006 Interior/Exterior/Visual 3 06-14-2013 09:05 AM
Led tail light bulbs in an 05 z3ro0 Interior/Exterior/Visual 4 03-23-2013 12:22 AM
Sounds like a broken garbage disposal Andrew Klossner Trouble Shooting/Problems/Service 3 11-02-2011 04:55 PM
new engine sounds like is not advancing pagokid Troubleshooting/Problems Discussion 4 10-31-2010 05:41 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community