Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 04-12-2011, 05:36 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2010
Posts: 1,197
Thanks: 1
Thanked 22 Times in 22 Posts
Rep Power: 3108
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Re: Quadra Lift Problem??

Quote:
Originally Posted by bobkbusch View Post
Just got the same message, "Air suspension requires imediate service/repair." I then tried to change the ride height and the EVIC said the "system is cooling down...please wait." Would not change ride height.

Going to the dealer tomorrow....

Did you get this during normal driving?
__________________

__________________
Reply With Quote
  #14  
Old 04-12-2011, 05:51 PM
Premium Member
My Jeep: 2014 5.7L
 
Join Date: Feb 2011
Location: Colorado Springs
Posts: 158
Thanks: 3
Thanked 8 Times in 6 Posts
Rep Power: 1456
bobkbusch is on a distinguished road
Re: Qudra Lift Problem??

Yes...just happened to notice an EVIC message that popped up momentarily. It kept repeating so I tried to change ride height and got the "system is cooling down" message. About five minutes prior to noticing the first EVIC message, I had changed the traction control from Sport to Auto. I didn't pay attention to see if the ride height actually changed from Sport/Aerodynamic to Normal (sorry if that isn't the correct term, but whatever ride height is normal for Auto) but I believe it did. At the time, I was driving in the city and wanted to see if Auto provided a better ride through a construction zone.
__________________

__________________
Reply With Quote
  #15  
Old 04-14-2011, 06:00 PM
Premium Member
My Jeep: 2014 5.7L
 
Join Date: Feb 2011
Location: Colorado Springs
Posts: 158
Thanks: 3
Thanked 8 Times in 6 Posts
Rep Power: 1456
bobkbusch is on a distinguished road
Re: Qudra Lift Problem??

Update: Dealer said they pulled four codes and reset, followed by a test drive. Two codes returned and the system again malfunctioned. They ordered a control module, but I'm out of town until next week, so won't know much until then...
__________________
Reply With Quote
  #16  
Old 04-15-2011, 03:57 AM
Member
 
Join Date: Mar 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1270
Grandcherokee6 is on a distinguished road
Re: Qudra Lift Problem??

I had the same exact issue the other day as well. Tuesday was the first time I really drove it hard since I got it. The vehicle was in Auto Mode and I got that "Serivce system immediately" message. When I was able to stop, I tried lowering the vehichle to Park height and got the "system cooling" message. After that it worked OK. I did go in an make sure all the fuses were securly in place. I also pulled and reinserted the two fuses related to the Qualdra Lift- J 01 and M 15. After doing this and starting the vehichle, the suspension went from park to normal mode. The last two days I drove it harder than I ever had since owning it and I have not had that message since.
__________________
Reply With Quote
  #17  
Old 04-15-2011, 10:50 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2010
Posts: 1,197
Thanks: 1
Thanked 22 Times in 22 Posts
Rep Power: 3108
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Re: Qudra Lift Problem??

Quote:
Originally Posted by Grandcherokee6 View Post
I had the same exact issue the other day as well. Tuesday was the first time I really drove it hard since I got it. The vehicle was in Auto Mode and I got that "Serivce system immediately" message. When I was able to stop, I tried lowering the vehichle to Park height and got the "system cooling" message. After that it worked OK. I did go in an make sure all the fuses were securly in place. I also pulled and reinserted the two fuses related to the Qualdra Lift- J 01 and M 15. After doing this and starting the vehichle, the suspension went from park to normal mode. The last two days I drove it harder than I ever had since owning it and I have not had that message since.

Have you tried raising it to OR1 or OR2?
__________________
Reply With Quote
  #18  
Old 04-17-2011, 11:34 PM
Member
 
Join Date: Mar 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1270
Grandcherokee6 is on a distinguished road
Re: Qudra Lift Problem??

Quote:
Originally Posted by jp467 View Post
Have you tried raising it to OR1 or OR2?
No, I never did- yet
__________________
Reply With Quote
  #19  
Old 04-18-2011, 10:17 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2010
Posts: 1,197
Thanks: 1
Thanked 22 Times in 22 Posts
Rep Power: 3108
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Re: Qudra Lift Problem??

Well I have it over at the dealer now. They had to put a request into STAR for help on troubleshooting the issue. They said it was in "Plant mode" and they got it out of that, but it still won't go into OR1 and OR2 and there are three or four fault codes system overheated and a couple other ones. So hopefully I will have some answers today.
__________________
Reply With Quote
  #20  
Old 04-19-2011, 12:26 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2010
Posts: 1,197
Thanks: 1
Thanked 22 Times in 22 Posts
Rep Power: 3108
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Re: Qudra Lift Problem??

Quote:
Originally Posted by mjw930 View Post
It's probably the controller module that's part of the pump/valve assembly, I've read about a few of those being replaced. Or it's low nitrogen which would indicate a leak. Either way, cycling the power or resetting a module isn't likely to fix it, it's going to require an actual mechanic to actually do some troubleshooting. This is not something you are going to get a simple fix for off an internet forum, that's what dealers and warranties are for.....

I think you might be right about the pump/valve assembly. I have it in the shop now and they are working with Chrysler on it they have tried a couple modules in it and this was not the problem and they say the pressures are right where they should be. So hopefully I will know soon. It operates fine in normal mode It's just when I raise it I get that message.
__________________
Reply With Quote
  #21  
Old 04-19-2011, 12:03 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2010
Posts: 1,197
Thanks: 1
Thanked 22 Times in 22 Posts
Rep Power: 3108
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Re: Qudra Lift Problem??

Well I just heard from the dealer. After going through all the troubleshooting they determined it is a fault with the compressor. It's been ordered and will be a couple days to get it. Does anyone know how involved it is changing this?
__________________
Reply With Quote
  #22  
Old 04-19-2011, 08:20 PM
Premium Member
My Jeep: 2014 5.7L
 
Join Date: Feb 2011
Location: Colorado Springs
Posts: 158
Thanks: 3
Thanked 8 Times in 6 Posts
Rep Power: 1456
bobkbusch is on a distinguished road
Re: Qudra Lift Problem??

Just picked up my Overland from the dealer after a "control module" replacement. The service advisor told me he checked out the Quadra-Lift personally after the mechanics finished.

I checked it out in the parking lot before leaving and it worked fine.

Unfortunately, I got the same message again while driving home from the dealer..."Air Suspension Requires Immediate Service/Repair."

It happened in the exact same scenario as last time, when selecting "Auto" from "Sport" mode at about 30mph.

Back to the dealer tomorrow...I suppose I will show him this thread and emphasize looking at the compressor.
__________________
Reply With Quote
  #23  
Old 04-19-2011, 08:59 PM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2010
Posts: 1,197
Thanks: 1
Thanked 22 Times in 22 Posts
Rep Power: 3108
jp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond reputejp467 has a reputation beyond repute
Re: Qudra Lift Problem??

I picked mine up today as well. My dealer called STAR and they walked them through the troubleshooting the first thing they were told to try was the control module and it wasn't that. After all the testing they found the problem to be in the compressor. I have read of a few other compressor failures it seems like it might be kind of common. I was looking at it today and it looks fairly easy to change after removing the air cleaner.
__________________
Reply With Quote
  #24  
Old 04-19-2011, 09:10 PM
chibianh's Avatar
Premium Member


My Jeep: 2011 5.7L WK2
 
Join Date: Jul 2010
Location: Colorado
Posts: 593
Thanks: 2
Thanked 6 Times in 5 Posts
Rep Power: 96472
chibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond reputechibianh has a reputation beyond repute
Send a message via AIM to chibianh
Re: Qudra Lift Problem??

i had my compressor replaced about a month ago as well.. have been trouble free since!
__________________

__________________
2011 WK2 Overland 5.7 w/ Off-road Adventure II and other stuff
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Quadra Lift barho Suspension/Driveline/Brakes/Wheels/Tires 89 10-24-2012 06:54 AM
Shudder, Do you have Quadra-Lift ? vikingdave Trouble Shooting/Problems/Service 25 03-21-2011 07:01 PM
For those of you with quadra-lift... msaenger Grand Cherokee - WK2 - 26 02-25-2011 01:38 AM
Quadra Lift JujuB Trouble Shooting/Problems/Service 5 01-14-2011 03:11 PM
Quadra lift LJS8510 Grand Cherokee - WK2 - 26 05-18-2010 11:19 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community