Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-14-2012, 01:52 PM
Member
 
Join Date: Oct 2010
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1483
prelude532 is on a distinguished road
Radio Preset Button Issues

Curious if anyone else is having issues with the Radio preset button on the back of the steering wheel. In the Laredo X, since pretty much day 1, its not consistent. I've had it in twice and both times the dealer says that can't replicate the problem. I'm about to take it to another deal in hopes that I can also get my LEDs in the door handles/door pockets turned on since the same dealer says that my Jeep doesn't come with them. My wife has a WK2 Limited and my father has a WK2 Overland and both of their preset buttons feel more "clicky" for lack of a better term and even when I don't hit them EXACTLY on, they still seem to do the job. If i'm even off the slightest when I try to press mine, it just channels up or down. FWIW, both of those other vehicles also had the LEDs lit up correctly coming off the lot.

Curious if anyone else was/is experiencing this.
__________________

__________________
Reply With Quote
  #2  
Old 02-14-2012, 04:12 PM
Jeeters's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jun 2010
Location: PA
Posts: 483
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2544
Jeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond repute
Re: Radio Preset Button Issues

No issues with mine. I use them *a lot* when listening to Sirius - I'm constantly 'channel surfing' with them. Laredo X with 430N.
__________________

__________________
Reply With Quote
  #3  
Old 02-14-2012, 07:37 PM
RageOfFury's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Feb 2011
Location: Ottawa, Canada
Posts: 1,372
Thanks: 97
Thanked 28 Times in 26 Posts
Rep Power: 11274
RageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond repute
Re: Radio Preset Button Issues

I experience the exact same issue!!! It's such a pain in the you know what.

I'm going to have the dealer replace the switch whenever I get around to it.
__________________
2011 WK2 Laredo E V6 4x4
Reply With Quote
  #4  
Old 02-14-2012, 08:39 PM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Oct 2011
Location: Avon, CT USA
Posts: 204
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1532
PECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond reputePECo has a reputation beyond repute
Re: Radio Preset Button Issues

No problems with mine.
__________________
2012 Jeep Grand Cherokee Overland 4x4 5.7L ORAII Mineral Gray Dark/Light Frost Beige
Reply With Quote
  #5  
Old 02-14-2012, 09:12 PM
12167jeep's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jun 2011
Location: Central NY
Posts: 224
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 1447
12167jeep is on a distinguished road
Re: Radio Preset Button Issues

I have the same issues with mine, there is a TSB out for the buttons. As for the leds, i got the same story from two dealers and even their "field service tech" for the area.
__________________
Reply With Quote
  #6  
Old 02-14-2012, 09:15 PM
RageOfFury's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Feb 2011
Location: Ottawa, Canada
Posts: 1,372
Thanks: 97
Thanked 28 Times in 26 Posts
Rep Power: 11274
RageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond repute
Re: Radio Preset Button Issues

Quote:
Originally Posted by 12167jeep View Post
I have the same issues with mine, there is a TSB out for the buttons. As for the leds, i got the same story from two dealers and even their "field service tech" for the area.
There is?
__________________
2011 WK2 Laredo E V6 4x4
Reply With Quote
  #7  
Old 02-14-2012, 09:24 PM
12167jeep's Avatar
Member
My Jeep: 2011 5.7L WK2
 
Join Date: Jun 2011
Location: Central NY
Posts: 224
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 1447
12167jeep is on a distinguished road
Re: Radio Preset Button Issues

Quote:
Originally Posted by RageOfFury View Post
There is?
Ok so i was mistaken, i knew i read it on the TSB page though. It at the bottom in purple for builds before 7/10. Says to replace the switch

http://www.wk2jeeps.com/wk2_tsb.htm
__________________
Reply With Quote
  #8  
Old 02-15-2012, 07:09 AM
Jeeters's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Jun 2010
Location: PA
Posts: 483
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2544
Jeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond reputeJeeters has a reputation beyond repute
Re: Radio Preset Button Issues

Quote:
Originally Posted by 12167jeep View Post
Ok so i was mistaken, i knew i read it on the TSB page though. It at the bottom in purple for builds before 7/10. Says to replace the switch

http://www.wk2jeeps.com/wk2_tsb.htm
I just read that and it made me chuckle... So if your buttons are sticking, and your build date is before 7/2010, they say replace the switches. So I guess if your buttons are sticking but your build date is after 7/2010 you're SOL?
__________________
Reply With Quote
  #9  
Old 02-15-2012, 09:53 PM
Member
 
Join Date: Oct 2010
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1483
prelude532 is on a distinguished road
Re: Radio Preset Button Issues

Just wanted to update. After going to a new dealership, they diagnosed it as a bad switch and replaced the buttons in the steering wheel. Works like a champ now.
__________________
Reply With Quote
  #10  
Old 02-16-2012, 06:45 PM
RageOfFury's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Feb 2011
Location: Ottawa, Canada
Posts: 1,372
Thanks: 97
Thanked 28 Times in 26 Posts
Rep Power: 11274
RageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond repute
Re: Radio Preset Button Issues

Quote:
Originally Posted by prelude532 View Post
Just wanted to update. After going to a new dealership, they diagnosed it as a bad switch and replaced the buttons in the steering wheel. Works like a champ now.
Sweet! I gotta find time to do that!
__________________

__________________
2011 WK2 Laredo E V6 4x4
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 WK REQ Radio Issues - No Sound at times scottmarion Troubleshooting/Problems 6 04-08-2010 03:26 PM
adding satellite radio and ipod/aux to RAQ radio fasteddy001 Audio, Video, Navigation & Electronic Modifications 3 02-20-2010 02:43 AM
Help, WK Button location please! TimmyB Grand Cherokee - WK 10 12-27-2009 04:51 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:06 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.