Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-01-2012, 11:45 AM
AKHLK's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Aug 2012
Location: Anchorage, Alaska
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 848
AKHLK is on a distinguished road
Rear Camera Cold Weather Problem

Now that it's gotten pretty cold I've noticed that when I start my GC and put it in reverse the backup camera isn't working, I just get a blank screen. After it warms up for about 5 minutes or so it starts working again. It's 18 degrees here in Anchorage this morning and is going to get much colder as winter progresses . The dealer already replaced the camera part and that didn't solve the problem. Has this happened to anyone else?
__________________

__________________
Reply With Quote
  #2  
Old 11-01-2012, 11:58 AM
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Aug 2011
Location: Castle Rock, CO
Posts: 605
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 381811
Aiyer has a reputation beyond reputeAiyer has a reputation beyond reputeAiyer has a reputation beyond reputeAiyer has a reputation beyond reputeAiyer has a reputation beyond reputeAiyer has a reputation beyond reputeAiyer has a reputation beyond reputeAiyer has a reputation beyond reputeAiyer has a reputation beyond reputeAiyer has a reputation beyond reputeAiyer has a reputation beyond repute
Garage
Re: Rear Camera Cold Weather Problem

I have noticed that recently on my Jeep. But it was warm yesterday, about 73 F here. I put it in reverse and it takes few seconds (maybe 5?) to show up. But, this morning (it was cooler than yesterday afternoon), the rear view display was instantaneous. Maybe the system needs a reboot.
__________________

__________________
2012 Jeep Grand Cherokee Limited
2008 Porsche Cayenne S
2002 Aprilia SL1000R
2000 Porsche Boxster (Sold)
1998 Jeep Grand Cherokee SE (Sold and still missed)
Reply With Quote
  #3  
Old 11-01-2012, 12:46 PM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Sep 2010
Location: Chicago
Posts: 102
Thanks: 0
Thanked 6 Times in 4 Posts
Rep Power: 1558
RKlimas is on a distinguished road
Send a message via ICQ to RKlimas
Re: Rear Camera Cold Weather Problem

My camera stopped working right after I purchased it earlier this year. It turned out to be a problem with the ground wire in the plastic connector between the wires from the radio and the wires from the camera. Have them check that out. It is located in the rear hatch.
__________________
2012 Grand Cherokee Overland 4x4
Maximum Steel, V-8
Reply With Quote
  #4  
Old 11-25-2012, 09:35 PM
Member
My Jeep: 2011 WK2
 
Join Date: Apr 2011
Location: Chicago west suburbs
Posts: 67
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1326
moontz is on a distinguished road
Re: Rear Camera Cold Weather Problem

Same issue here. Never thought about the cold being a possible cause but my experience is similar to yours. Prob have them check it in the coming weeks.
__________________
Reply With Quote
  #5  
Old 11-25-2012, 10:14 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,537
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80157
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: Rear Camera Cold Weather Problem

My main concern is the impacts from closing the hatch, display is what is usually affected by cold. Think it got down to 40f once so far but rarely goes below freezing here.
Reply With Quote
  #6  
Old 11-26-2012, 12:04 AM
AKHLK's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Aug 2012
Location: Anchorage, Alaska
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 848
AKHLK is on a distinguished road
I only have problems when it's below freezing, otherwise the camera works perfectly. When the interior of the vehicle is cold, I either get a black and white blurry sort of static or more often, just a black screen with "check entire surroundings" at the top. Once the vehicle interior is warm, the camera works fine. The dealer is going to replace the head unit next, since replacing the camera itself didn't work. They claim that no one else has complained of this problem.
__________________
Reply With Quote
  #7  
Old 01-11-2013, 04:16 PM
AKHLK's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Aug 2012
Location: Anchorage, Alaska
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 848
AKHLK is on a distinguished road
Update: the dealer replaced the head unit and the camera is working perfectly now. As a plus, the new head unit came with updated firmware and newest nav software, so I don't have to worry about that now either.

Also, I accidentally left a music cd that I had burned in the cd player and it was in the old head unit when they removed it. The old head unit was packed up and sent back to Chrysler for engineers to evaluate. I realized later that I'd left it in there and figured they'd just toss it, didn't bother me, I figured I'll just make another one. I got a call a few days ago from the dealer, Chrysler found the cd and sent it back to them for me to swing by and pick up! It's nothing valuable or important to me but it impresses me that they went through the trouble to send it back.
__________________
Reply With Quote
  #8  
Old 01-11-2013, 07:52 PM
Premium Member
 
Join Date: Oct 2010
Posts: 94
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 1528
computerwiz621 is on a distinguished road
Re: Rear Camera Cold Weather Problem

I'm having the exact same problem. I think I have narrowed it down to the cold. Today was warmer and had no issues, but it seems when it gets cold out, it does not always work.

Trying to explain this to the dealer is going to be fun.
__________________
2011 Jeep Grand Cherokee Overland
V6 4x4
Off Road II
Adaptive Cruise Package
Ordered: 11/13
Estimated Delivery 1/15
Delivered 1/19
Reply With Quote
  #9  
Old 01-11-2013, 10:19 PM
AKHLK's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Aug 2012
Location: Anchorage, Alaska
Posts: 93
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 848
AKHLK is on a distinguished road
When I told the dealer about it they didn't give me any trouble. They did say that they hadn't heard of that problem before but had no issues digging in and getting it fixed. I don't know if they were even able to duplicate the error, or just took my word for it, but I did have videos and photos to show them if they wanted.

Also, I just found out that it wasn't Chrysler that returned the cd. The radio was returned to the factory "United Radio" in N.Y. and they returned it.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Backup camera problem Greg7 Trouble Shooting/Problems/Service 9 04-11-2014 10:23 AM
2012 GC Backup Camera Problem cherga Audio/Visual/Navigation 13 12-30-2012 09:55 AM
Idiling in extreemly cold weather TJcust Export & Diesel Powered Jeep Models 8 02-17-2012 04:08 PM
Bad Cold Weather Noises JeepMe Troubleshooting/Problems 7 12-22-2010 04:45 PM
Belts in cold weather GiggityGiggity Troubleshooting/Problems 7 12-09-2010 02:19 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:33 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community