Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-10-2013, 11:12 AM
bertball50's Avatar
Member
 
Join Date: Jan 2013
Location: central iowa
Posts: 269
Thanks: 62
Thanked 5 Times in 4 Posts
Rep Power: 842
bertball50 is on a distinguished road
Serious electrical issues

Ok, I've had my summit for 2 months now and unfortunately I've had electrical issues the whole time. With 200 miles my passive entry sensor went bad and was replaced. The remote start doesn't work right, which supposedly there's a fix on the way. With 1400 miles I had to be towed to dealership bc jeep wouldn't start and low voltage and battery lights came on. Replaced alternator. With 1900 miles all hell broke loose, and every light came on, the speedometer and odometer quit working, and as I was driving the air system made it seem like I was on a roller coaster, constantly going up and down. When I got home after I shut it off and restarted 15 minutes later only the check engine light was on. That went away after a couple more restarts. That was 2 days ago. Yesterday, I tried to start it, got the clicking noise and didnt start first 2 tries, but went in the 3rd try. Got down to the end of the street and it died. Got it restarted but the low voltage and battery light were on fir a bit but went away. The check engine light stayed on as well as acc/fcw unavailable service required. Also the tranny was stuck in 4 th gear, couldn't move up or down. Limped it to the dealer and its in the shop. We'll see, but I'm really having doubts about thus jeep. We were seriously looking at getting a new Durango for my wife, but she's really worried about chryslers electrical.
__________________

__________________
delivered 6-12-13 full review to come at 500 miles
2014 summit deep cherry red with jeep brown hemi.

Previous Jeeps:
1997 Limited
2004 Special Edition
2005 Rocky Mountain Edition (Wife's)
2006 Limited
Reply With Quote
  #2  
Old 08-10-2013, 11:20 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 853 Times in 468 Posts
Rep Power: 1927026
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Re: Serious electrical issues

Sorry to hear about this BertBall, The issues may be related to each other....

Can I ask a few questions.

Has your radio been replaced?
What version of software is your radio running (known battery run down issue)
Has your dealer looked into the CAN BUS Connector to the right side of the radio/console?

Just curious and you are welcome to PM me if you like.

Thanks!
__________________

__________________
Reply With Quote
  #3  
Old 08-10-2013, 11:36 AM
bertball50's Avatar
Member
 
Join Date: Jan 2013
Location: central iowa
Posts: 269
Thanks: 62
Thanked 5 Times in 4 Posts
Rep Power: 842
bertball50 is on a distinguished road
Willix, the radio has not been replaced, I think the version is 13.19, and I don't know if they've looked at the can bus. Waiting to hear back to see what they've found. Only good thing is they did give me a loaner car.
__________________
delivered 6-12-13 full review to come at 500 miles
2014 summit deep cherry red with jeep brown hemi.

Previous Jeeps:
1997 Limited
2004 Special Edition
2005 Rocky Mountain Edition (Wife's)
2006 Limited
Reply With Quote
  #4  
Old 08-10-2013, 11:44 AM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 853 Times in 468 Posts
Rep Power: 1927026
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by bertball50 View Post
Willix, the radio has not been replaced, I think the version is 13.19, and I don't know if they've looked at the can bus. Waiting to hear back to see what they've found. Only good thing is they did give me a loaner car.
Please keep me posted, PM likely best but I really hope your dealer can get it sorted. There were a couple of mistakes identified in the new electrical architecture but they are mainly isolated to a specific connector or ground. I really hope they find it and get you down the road and happy.

The remote start issue is still a problem yes, but I am really hoping to see that update very soon.
__________________
Reply With Quote
  #5  
Old 08-10-2013, 12:08 PM
bertball50's Avatar
Member
 
Join Date: Jan 2013
Location: central iowa
Posts: 269
Thanks: 62
Thanked 5 Times in 4 Posts
Rep Power: 842
bertball50 is on a distinguished road
I'll let u know, congrats on your diesel order
__________________
delivered 6-12-13 full review to come at 500 miles
2014 summit deep cherry red with jeep brown hemi.

Previous Jeeps:
1997 Limited
2004 Special Edition
2005 Rocky Mountain Edition (Wife's)
2006 Limited
Reply With Quote
  #6  
Old 08-10-2013, 12:13 PM
Willx's Avatar
Moderator - MOTS jr.


My Jeep: 2014 3.0L WK2
 
Join Date: May 2013
Posts: 4,884
Thanks: 529
Thanked 853 Times in 468 Posts
Rep Power: 1927026
Willx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond reputeWillx has a reputation beyond repute
Garage
Quote:
Originally Posted by bertball50 View Post
I'll let u know, congrats on your diesel order
Thanks!
__________________
Reply With Quote
  #7  
Old 08-10-2013, 01:46 PM
Member
 
Join Date: Mar 2013
Posts: 194
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 717
RFF111 is on a distinguished road
Re: Serious electrical issues

Quote:
Originally Posted by bertball50 View Post
Ok, I've had my summit for 2 months now and unfortunately I've had electrical issues the whole time. With 200 miles my passive entry sensor went bad and was replaced. The remote start doesn't work right, which supposedly there's a fix on the way. With 1400 miles I had to be towed to dealership bc jeep wouldn't start and low voltage and battery lights came on. Replaced alternator. With 1900 miles all hell broke loose, and every light came on, the speedometer and odometer quit working, and as I was driving the air system made it seem like I was on a roller coaster, constantly going up and down. When I got home after I shut it off and restarted 15 minutes later only the check engine light was on. That went away after a couple more restarts. That was 2 days ago. Yesterday, I tried to start it, got the clicking noise and didnt start first 2 tries, but went in the 3rd try. Got down to the end of the street and it died. Got it restarted but the low voltage and battery light were on fir a bit but went away. The check engine light stayed on as well as acc/fcw unavailable service required. Also the tranny was stuck in 4 th gear, couldn't move up or down. Limped it to the dealer and its in the shop. We'll see, but I'm really having doubts about thus jeep. We were seriously looking at getting a new Durango for my wife, but she's really worried about chryslers electrical.
Good luck with your issues. There is really good support on these threads.
__________________
Reply With Quote
  #8  
Old 08-14-2013, 05:18 PM
bertball50's Avatar
Member
 
Join Date: Jan 2013
Location: central iowa
Posts: 269
Thanks: 62
Thanked 5 Times in 4 Posts
Rep Power: 842
bertball50 is on a distinguished road
Got the jeep back today and after a few days of looking and testing they found a ground that was loose and the bolt was stripped. Tech thought it'd probably have happened at the factory. The ground was below the TIPM on the rail. Whatever that is. Hopefully this fixes it. I'll update this either way in a few weeks
__________________
delivered 6-12-13 full review to come at 500 miles
2014 summit deep cherry red with jeep brown hemi.

Previous Jeeps:
1997 Limited
2004 Special Edition
2005 Rocky Mountain Edition (Wife's)
2006 Limited
Reply With Quote
  #9  
Old 08-14-2013, 08:38 PM
cnynctry's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: PV Arizona
Posts: 79
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 1960
cnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond reputecnynctry has a reputation beyond repute
Re: Serious electrical issues

Seems like most of the electrical issues have been resolved with finding bad, lose, poor grounds. You would think that would have gotten back to production for some additional quality control. I hope they have fixed your issues but the bad grounding has caused some other modules to need replacing.
__________________

__________________
2014 Grand Cherokee 5.7 Overland
2014 Wrangler Rubicon
2010 Challenger R/T Classic
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical issues? bertball50 Trouble Shooting/Problems/Service 4 07-12-2013 01:10 PM
05 WK electrical issues HFolb23 Troubleshooting/Problems 2 04-03-2013 09:36 AM
Electrical issues!!! hollowpoint515 Trouble Shooting/Problems/Service 5 10-25-2012 11:13 AM
Electrical issues? Gribbs Export Grand Cherokee 2011+ 5 08-17-2012 09:19 PM
electrical issues 97jeepcherokee Troubleshooting/Problems Discussion 1 02-23-2012 12:51 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community