Service Transmission message 3x this morning.. - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-19-2014, 02:17 PM
YO-EL's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2012
Location: Phila PA suburbs
Posts: 137
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1896
YO-EL will become famous soon enough
Service Transmission message 3x this morning..

Lit up in red on the EVIC this morning, but car is driving & shifting fine..
Not doing it this afternoon....

Any thoughts?
2014 JGC Overland 2200 miles..

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 10-19-2014, 03:11 PM
Member
 
Join Date: Sep 2014
Posts: 24
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 824
hampton64 is on a distinguished road
Re: Service Transmission message 3x this morning..

Service the trans?
Reply With Quote
  #3  
Old 10-19-2014, 03:13 PM
YO-EL's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2012
Location: Phila PA suburbs
Posts: 137
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1896
YO-EL will become famous soon enough
Re: Service Transmission message 3x this morning..

Quote:
Originally Posted by hampton64 View Post
Service the trans?
What kind of service does a tranny need w/ 2000 mi?
__________________

2011- 2010 Englishtown (NJ) 11.50 Index CHAMPION! 2012-2011-2010 Corvette Challenge Pro 11.50 Index CHAMPION!
2012 Modern Muscle CHAMPION!
Reply With Quote
  #4  
Old 10-19-2014, 03:15 PM
Member
 
Join Date: Sep 2014
Posts: 24
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 824
hampton64 is on a distinguished road
Re: Service Transmission message 3x this morning..

Just sayin id look at fluid level and color at the least to rule out an actual prob. Before chasin an electrical issue.
Reply With Quote
  #5  
Old 10-19-2014, 07:53 PM
YO-EL's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2012
Location: Phila PA suburbs
Posts: 137
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1896
YO-EL will become famous soon enough
Re: Service Transmission message 3x this morning..

Got ya...
Reply With Quote
  #6  
Old 10-19-2014, 08:26 PM
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Aug 2011
Location: NYC
Posts: 860
Thanks: 82
Thanked 31 Times in 23 Posts
Rep Power: 3184
Roki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond reputeRoki303 has a reputation beyond repute
Re: Service Transmission message 3x this morning..

Quote:
Originally Posted by hampton64 View Post
Just sayin id look at fluid level and color at the least to rule out an actual prob. Before chasin an electrical issue.
8 speed does not have dipstick and is not refillable (lifetime fill). Given that there is no service that you have to do you probably need a dealer to take a look. With only 2k on odo you might have a bad one. I hope not, maybe it just needs a software upgrade or so.
__________________
2014 Jeep GC, V6, Black/Indigo with Adv Tech Package and ORAII
Reply With Quote
  #7  
Old 10-20-2014, 08:24 PM
YO-EL's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2012
Location: Phila PA suburbs
Posts: 137
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1896
YO-EL will become famous soon enough
Re: Service Transmission message 3x this morning..

Quote:
Originally Posted by Roki303 View Post
8 speed does not have dipstick and is not refillable (lifetime fill). Given that there is no service that you have to do you probably need a dealer to take a look. With only 2k on odo you might have a bad one. I hope not, maybe it just needs a software upgrade or so.
Thanks Roki... I just went out to look & found no dipstick..
It was pretty cold out yesterday morning (36 degrees), so I'm wondering if it has to do something with cold weather, since I have not seen the Service Transmission message since it warmed up yesterday or today..

I have to go back to the dealer once the axles come in so I'll ask to check to see if any codes were set etc, or if the error message I got actually means anything.

I will say, the car drive & shifts just fine!

Has anyone else gotten this "Service Transmission" (in RED) message?
__________________

2011- 2010 Englishtown (NJ) 11.50 Index CHAMPION! 2012-2011-2010 Corvette Challenge Pro 11.50 Index CHAMPION!
2012 Modern Muscle CHAMPION!
Reply With Quote
  #8  
Old 01-01-2015, 02:39 PM
YO-EL's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2012
Location: Phila PA suburbs
Posts: 137
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1896
YO-EL will become famous soon enough
Re: Service Transmission message 3x this morning..

25 degrees out, started car, put in Drive.. got message again..
__________________

2011- 2010 Englishtown (NJ) 11.50 Index CHAMPION! 2012-2011-2010 Corvette Challenge Pro 11.50 Index CHAMPION!
2012 Modern Muscle CHAMPION!
Reply With Quote
  #9  
Old 01-01-2015, 03:52 PM
Member
My Jeep: 2014 3.0L WK2
 
Join Date: May 2014
Location: Northern MN.
Posts: 90
Thanks: 0
Thanked 6 Times in 6 Posts
Rep Power: 1094
pineluretom has a reputation beyond reputepineluretom has a reputation beyond reputepineluretom has a reputation beyond reputepineluretom has a reputation beyond repute
Re: Service Transmission message 3x this morning..

+25, try -25 like we have here in MN. I have the diesel with no problems in transmission.
Reply With Quote
  #10  
Old 01-04-2015, 08:35 AM
YO-EL's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2012
Location: Phila PA suburbs
Posts: 137
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1896
YO-EL will become famous soon enough
Re: Service Transmission message 3x this morning..

I'm wondering if something is sticking in the trans while cold, when initially shifting into D..setting off the error message?

Like I said, the "Service Transmission" error message only comes on when car is shifted into either D or R...
__________________

2011- 2010 Englishtown (NJ) 11.50 Index CHAMPION! 2012-2011-2010 Corvette Challenge Pro 11.50 Index CHAMPION!
2012 Modern Muscle CHAMPION!
Reply With Quote
  #11  
Old 01-04-2015, 09:31 AM
MDBones's Avatar
OVERLAND HIGH ALTITUDE
My Jeep: 2016 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 3,560
Thanks: 621
Thanked 607 Times in 499 Posts
Rep Power: 10535
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: Service Transmission message 3x this morning..

YO-EL, you first reported this issue in here on 10-19-14. Have you had your dealer check it out yet?
__________________

THE GHOST
Reply With Quote
  #12  
Old 01-04-2015, 06:44 PM
YO-EL's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2012
Location: Phila PA suburbs
Posts: 137
Thanks: 1
Thanked 4 Times in 4 Posts
Rep Power: 1896
YO-EL will become famous soon enough
Re: Service Transmission message 3x this morning..

Quote:
Originally Posted by MDBones View Post
YO-EL, you first reported this issue in here on 10-19-14. Have you had your dealer check it out yet?
Yes.
Had it in last week for the axles & they did the latest flash for the trans..
Then the other day, saw the error message when I shifted into D..
Still get it now & then... all upon moving shifter into D.... thats why I'm posting on this.. I can't be the only one....
__________________

2011- 2010 Englishtown (NJ) 11.50 Index CHAMPION! 2012-2011-2010 Corvette Challenge Pro 11.50 Index CHAMPION!
2012 Modern Muscle CHAMPION!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting "Vehicle phone requires service message" ebang Trouble Shooting/Problems/Service 179 10-04-2016 03:54 PM
"Service 4wd system" message Kayak83 Troubleshooting/Problems 5 01-03-2013 05:50 PM
Wheel speed sensor / Service 4WD Message Problem. philr75 Troubleshooting/Problems 2 09-19-2012 12:05 PM
Dreaded "Service 4WD System" Message DaBigBone Troubleshooting/Problems 10 01-09-2012 09:31 AM
Service 4WD System Message cain45 Grand Cherokee - WK 18 09-13-2010 06:49 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:41 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.