Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-04-2013, 05:51 PM
TheSiltSurfer's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jul 2012
Location: Durango Colorado
Posts: 265
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 1132
TheSiltSurfer is on a distinguished road
slew up problems post recall flash

First off the backup camera became glitchy looking appearing as if i were on a weak WiFi connection. Next, I was listening to music last week via Bluetooth when all of the sudden all the driver side speakers went out. Next up the DVD drive stopped reading DVD and CDs. Took it to the dealer and they claim the amp failed and is the root cause. They have ordered me a new amp and new DVD drive. Will report back next week.
__________________

__________________
"Infinite Patience Produces Immediate Results"
Reply With Quote
  #2  
Old 12-04-2013, 08:30 PM
Premium Member
 
Join Date: Sep 2013
Posts: 566
Thanks: 2
Thanked 66 Times in 50 Posts
Rep Power: 6319
Peter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond reputePeter_K has a reputation beyond repute
Re: slew up problems post recall flash

Quote:
Originally Posted by TheSiltSurfer View Post
First off the backup camera became glitchy looking appearing as if i were on a weak WiFi connection. Next, I was listening to music last week via Bluetooth when all of the sudden all the driver side speakers went out. Next up the DVD drive stopped reading DVD and CDs. Took it to the dealer and they claim the amp failed and is the root cause. They have ordered me a new amp and new DVD drive. Will report back next week.
A fair number of people have the "glitchy" or "jerky" backup camera. Did they update your radio to the latest version? That's where it seems to show up most often from polling the issue...
__________________

__________________
Reply With Quote
  #3  
Old 12-05-2013, 09:13 AM
not_too_shabby's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: Portland, OR
Posts: 427
Thanks: 1
Thanked 11 Times in 11 Posts
Rep Power: 1053
not_too_shabby has a brilliant future
My jerky rear camera started after the latest radio update.
__________________
2014 Grand Cherokee Overland 4x4 V6
Maximum Steel
Download my App - iLeaseMyCar Pro Auto Loan and Lease Calculator for iPhone or iPad
Reply With Quote
  #4  
Old 12-05-2013, 10:01 AM
Member
 
Join Date: Jan 2013
Posts: 57
Thanks: 6
Thanked 0 Times in 0 Posts
Rep Power: 741
FAST_US is on a distinguished road
Re: slew up problems post recall flash

Quote:
Originally Posted by not_too_shabby View Post
My jerky rear camera started after the latest radio update.
Same issue here! After the radio update, the video camera seems to be running on a Pentium III cpu! LOL
__________________
Reply With Quote
  #5  
Old 12-05-2013, 10:12 AM
TheSiltSurfer's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jul 2012
Location: Durango Colorado
Posts: 265
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 1132
TheSiltSurfer is on a distinguished road
Yes I had the recall and the radio update. Do they seriously not test their sh!t before they release these updates.
__________________
"Infinite Patience Produces Immediate Results"
Reply With Quote
  #6  
Old 12-05-2013, 11:49 AM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 853
Thanks: 0
Thanked 33 Times in 26 Posts
Rep Power: 73179
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: slew up problems post recall flash

Radio update and Camera work fine on mine.

I always do a factory reset on any device I update firmware on. Not sure if that helped avoid issues. But Radio has been pretty near perfect.

I seem to have squeaked by not needing the xmas tree recall. Even though build date is 1 week before the date in the TSB.
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #7  
Old 12-05-2013, 11:52 AM
TheSiltSurfer's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jul 2012
Location: Durango Colorado
Posts: 265
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 1132
TheSiltSurfer is on a distinguished road
Quote:
Originally Posted by mswlogo View Post
Radio update and Camera work fine on mine.

I always do a factory reset on any device I update firmware on. Not sure if that helped avoid issues. But Radio has been pretty near perfect.

I seem to have squeaked by not needing the xmas tree recall. Even though build date is 1 week before the date in the TSB.
So how exactly do you factory reset your radio post update?
__________________
"Infinite Patience Produces Immediate Results"
Reply With Quote
  #8  
Old 12-05-2013, 11:56 AM
Northland's Avatar
I go where my Jeep goes.
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2012
Posts: 447
Thanks: 15
Thanked 29 Times in 24 Posts
Rep Power: 1612
Northland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond reputeNorthland has a reputation beyond repute
Push ignition button to ACC; press & hold simultaneously the hot & cold temp buttons on driver's side to bring up diagnostic menu; scroll down to reset option.
__________________
Ordered 2/04/13, Built and Status KZ (Plant Release) on 2/19/13, delivered 2/28/13: 2014 Limited 4x4 in Bright White with Lt. Frost Beige interior; Hemi V8; ORA II; RA4 UConnect.
So far: 20% tint all around; black BT oil catch can; Jeep slush and cargo mats; Blackvue DR500GW-HD dashcam; DropStops; XtremeDigital 4300K low beam HIDs; 5000K LED fog lights; Airaid CAI with SynthaMax dry filter. And now rollin' with UConnect 14.25.05!!
Reply With Quote
  #9  
Old 12-05-2013, 11:59 AM
Member
 
Join Date: Aug 2013
Location: Boston
Posts: 853
Thanks: 0
Thanked 33 Times in 26 Posts
Rep Power: 73179
mswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond reputemswlogo has a reputation beyond repute
Re: slew up problems post recall flash

Quote:
Originally Posted by TheSiltSurfer View Post
So how exactly do you factory reset your radio post update?
Hold Down Cold and Hot Temp buttons on Drivers Side and a Diagnostic Menu will appear. Scroll down to Factory Reset.

You will lose everything. But I didn't have that much in there.

If I had a ton of stuff I might have skipped it.

There are different version radios too. It could be newer radios work better with the update than older ones.
__________________
08-10-2014 Limited 3.6L Red W/Black Int, Tow Group IV, 8.4AN Radio, ProClip, OBDLink/Torque, Zeigler Lifetime MaxCare
OEM: Mud Flaps, Matts, Cargo Liner, Cross Rails
UConnect: 13.48.3 TSB: 21-007-13C (Yippy) Tires: OEM/Nokian
Reply With Quote
  #10  
Old 12-05-2013, 12:04 PM
TheSiltSurfer's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jul 2012
Location: Durango Colorado
Posts: 265
Thanks: 0
Thanked 9 Times in 9 Posts
Rep Power: 1132
TheSiltSurfer is on a distinguished road
Quote:
Originally Posted by mswlogo View Post

Hold Down Cold and Hot Temp buttons on Drivers Side and a Diagnostic Menu will appear. Scroll down to Factory Reset.

You will lose everything. But I didn't have that much in there.

If I had a ton of stuff I might have skipped it.

There are different version radios too. It could be newer radios work better with the update than older ones.
I'm going to give this a try today, I wonder if the dealer tried this. Driving around with half my stereo is pretty annoying. Thank you for the tip!
__________________
"Infinite Patience Produces Immediate Results"
Reply With Quote
  #11  
Old 12-05-2013, 08:36 PM
Member
 
Join Date: Oct 2013
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 454
2014 summit is on a distinguished road
Re: slew up problems post recall flash

Quote:
Originally Posted by mswlogo View Post
Radio update and Camera work fine on mine.

I always do a factory reset on any device I update firmware on. Not sure if that helped avoid issues. But Radio has been pretty near perfect.

I seem to have squeaked by not needing the xmas tree recall. Even though build date is 1 week before the date in the TSB.
Do you perform this when you get it back from the dealership after they have installed the new update? We are having problems with our radio not retaining the presets on am/fm stations. They work fine on the sirus stations. I also notice that almost everytime we start our GC Summit it can take up to 15 seconds for everything to load (ie) first the radio stations appear after 5 seconds then another 5 seconds the temp settings, then the outside temp setting, then the last thing to show up is the compass direction. Its strange because sometimes on a first start in the morning everything just shows up fine, then sometimes it does that weird reload thing. It will also continue the reload every engine restart after that, then every once in a while everything will show up on a engine restart. Something isn't right and this is our second NAV/Radio system in the Summit.
__________________
Reply With Quote
  #12  
Old 12-06-2013, 07:13 AM
jeepman917's Avatar
Member
 
Join Date: Jun 2013
Posts: 182
Thanks: 13
Thanked 7 Times in 5 Posts
Rep Power: 720
jeepman917 is on a distinguished road
I have a newly replaced radio w new software and the camera is still glitchy...
__________________

__________________
2014 Jeep Summit in black pearl w grand canyon interior... Hemi 5.7...
[SIGPIC][/SIGPIC]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 WK2 Recall (BCM Flash?) libby2cm Trouble Shooting/Problems/Service 2 09-05-2013 06:20 PM
RA4 13.19.0 Post Upgrade Problems klittle Audio/Visual/Navigation 3 08-07-2013 09:03 PM
First post - iphone 5 / audio problems davidg22 Audio/Visual/Navigation 1 01-08-2013 04:09 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:18 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.