Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 08-08-2013, 11:13 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Massachusetts
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1466
hammer1234 is on a distinguished road
Have not been tracking this thread for a while...we have not seen the problem for several months now. Have an extended service contract just in case...

Sent from my SCH-I545 using Tapatalk 2
__________________

__________________
Reply With Quote
  #14  
Old 08-08-2013, 02:06 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,490
Thanks: 0
Thanked 20 Times in 17 Posts
Rep Power: 80041
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: Stall after start

Could also be a failing fuel pump or switch. Sounds like either fire or fuel is being lost. Before throwing a $1300 TIPM at it would be best to figure out which.
__________________

__________________
Web home. Notary Sojac Y'all
One of these is a diesel:
Reply With Quote
  #15  
Old 08-09-2013, 07:07 PM
Member
 
Join Date: Mar 2013
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 520
bill hall is on a distinguished road
Quote:
Originally Posted by bigv View Post
Pissible fix for you... After some research it looks like the tpim needs to be replaced. I believe it runs about $1300
My 2011 hemi has this problem been at the dealer for 2 weeks waiting for a module from factory stop by to day was told that this would not be in until August 22, if then . Purchased life time warranty when I purchased this vehicle glad I did . If this price is correct I have gotten my warranty money back. Must be several vehicles with this issue tipm module. Long wait but with warranty Chrysler is furnishing me with a rental.my wk2 has 95k miles.
__________________
Reply With Quote
  #16  
Old 08-15-2013, 09:16 AM
Member
 
Join Date: Apr 2011
Posts: 37
Thanks: 0
Thanked 3 Times in 1 Post
Rep Power: 1225
Flocker is on a distinguished road
Re: Stall after start

Quote:
Originally Posted by Flocker View Post
Sitting at the dealership now with the same issue. Grrrr. Will post their findings.
Dealer reprogramed the PEM Module. Cost me $100.00.

Next day - same issue.

Took it to the dealership where I purchased it and they said that I need a new TIPCM. [Totally integrated power control module] Est. cost = $800.

My Jeep has been there 6 days as they now claim the part is "on back order" and they can not give me an ETA on the part. The saga continues...
__________________
Reply With Quote
  #17  
Old 08-15-2013, 09:33 AM
Member
 
Join Date: Apr 2011
Posts: 37
Thanks: 0
Thanked 3 Times in 1 Post
Rep Power: 1225
Flocker is on a distinguished road
Re: Stall after start

Quote:
Originally Posted by padgett View Post
Could also be a failing fuel pump or switch. Sounds like either fire or fuel is being lost. Before throwing a $1300 TIPM at it would be best to figure out which.
I was told by the dealer that one of the functions of the TIPCM is to keep the fuel pump primed.
__________________
Reply With Quote
  #18  
Old 08-15-2013, 03:01 PM
Member
 
Join Date: Apr 2011
Posts: 37
Thanks: 0
Thanked 3 Times in 1 Post
Rep Power: 1225
Flocker is on a distinguished road
Re: Stall after start

Quote:
Originally Posted by Flocker View Post
Dealer reprogramed the PEM Module. Cost me $100.00.

Next day - same issue.

Took it to the dealership where I purchased it and they said that I need a new TIPCM. [Totally integrated power control module] Est. cost = $800.

My Jeep has been there 6 days as they now claim the part is "on back order" and they can not give me an ETA on the part. The saga continues...
The Dealership finally called me back. The part is on "National Back Order" Status. I am #207 on the list!!! Un-flocking-believable!
__________________
Reply With Quote
  #19  
Old 08-15-2013, 05:35 PM
Member
 
Join Date: Aug 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 354
bullrider718 is on a distinguished road
Re: Stall after start

Might as well check-in in this thread too. I'm having the same issue and am somewhere around 150 on the list judging by what another person that had theirs ordered on the same day was told (dealership didn't give me my number).

Anyway I've contacted Chrysler about it, it is like pulling teeth with them but so far this is pretty much all they've told me: "as of today (8/15), we currently do not have a firm estimated time of arrival for your part to reach the dealership."

Very unhelpful. Very frustrating.
__________________
Reply With Quote
  #20  
Old 08-15-2013, 06:03 PM
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Mar 2012
Location: WNY
Posts: 87
Thanks: 0
Thanked 5 Times in 1 Post
Rep Power: 1058
jd2012jgc has a reputation beyond reputejd2012jgc has a reputation beyond reputejd2012jgc has a reputation beyond reputejd2012jgc has a reputation beyond reputejd2012jgc has a reputation beyond reputejd2012jgc has a reputation beyond repute
Re: Stall after start

Well add me to this list as well. (It seems that I participate in every known issue with my 12 5.7 Overland)

Same thing has happend to me twice. Hot weather, stalls after start, wont start back up until on/off is cycled.

Took it to dealer, no codes were pulled.

Of note, when trying to start back up, engine sounds really rough, as if timing is off. No dashboard warning lights except one red light--security system light?
__________________
Reply With Quote
  #21  
Old 08-15-2013, 06:14 PM
Member
 
Join Date: Aug 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 354
bullrider718 is on a distinguished road
Re: Stall after start

Quote:
Originally Posted by jd2012jgc View Post
Well add me to this list as well. (It seems that I participate in every known issue with my 12 5.7 Overland)

Same thing has happend to me twice. Hot weather, stalls after start, wont start back up until on/off is cycled.

Took it to dealer, no codes were pulled.

Of note, when trying to start back up, engine sounds really rough, as if timing is off. No dashboard warning lights except one red light--security system light?
I had no codes either. Mine's an 11 5.7 Overland. I first thought it was TSB 08-053-11 (only applies to 2011s though) so the dealer reflashed the TIPM but the problem returned 2 days later. That's when they said the TIPM needs to be replaced, apparently it is sending a bad signal to the fuel injector. They seemed to be pretty familiar with the issue.

Some times mine will start, then have an incredibly rough idle, then just die. Other times it will just crank. I don't know if it's just me being paranoid at this point but I think it might be rough idling when in drive, e.g. at a stop light. I read another guy who complained about this and his actually started stalling then too.

Dealership doesn't offer loaners, I don't have a second car, I don't really know what Jeep expects people to do stuck in this situation.
__________________
Reply With Quote
  #22  
Old 08-16-2013, 09:29 AM
Member
 
Join Date: Mar 2013
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 520
bill hall is on a distinguished road
Re: Stall after start

The extended warranty is so important purchase that I made . First extended that I made glad I did on this issue. My wk2 hemi has been In the shop 3wks. Now wating on tipm.dealer says going to be another week. Must be lots with this issue. I travel a lot for work so warranty provide a rental.
__________________
Reply With Quote
  #23  
Old 08-16-2013, 06:09 PM
Member
 
Join Date: Apr 2011
Posts: 37
Thanks: 0
Thanked 3 Times in 1 Post
Rep Power: 1225
Flocker is on a distinguished road
Re: Stall after start

Quote:
Originally Posted by bullrider718 View Post
Dealership doesn't offer loaners, I don't have a second car, I don't really know what Jeep expects people to do stuck in this situation.
Same issue with me. No loaners at my dealer. They told me to call Chrysler at 1-800-992-1997 and tell them about the issue. I did and they approved a made a reservation for a rental car. They delivered the rental car in the same day. Based on other posts, we could be in our rental cars for a month at least.
__________________
Reply With Quote
  #24  
Old 08-19-2013, 11:46 AM
Member
 
Join Date: Aug 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 354
bullrider718 is on a distinguished road
Re: Stall after start

Well there's two threads going on about this issue so I'm not really sure which one to update.. I spoke to my case manager from jeep today who said that there is a large number of the units scheduled to be shipped by the supplier on 8/23 which she said means they should be at the dealers by 8/30 or so. Fingers crossed...
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine stall Whilst Driving JoePistone Trouble Shooting/Problems/Service 24 08-19-2013 10:37 PM
Stall During Startup? litespeedz Trouble Shooting/Problems/Service 0 04-11-2011 12:28 PM
Stall while accelerating (5.7L) justin1569 Trouble Shooting/Problems/Service 13 04-01-2011 01:43 PM
Startup reverse stall? NHWK05 Grand Cherokee - WK 6 05-27-2010 09:44 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community