Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-10-2012, 09:48 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Massachusetts
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1382
hammer1234 is on a distinguished road
Stall after start

My 2011 GC (V6 Laredo) is in the shop today...been having an intermittent problem where the vehicle stalls after starting and then will not start unless the key position is cycled to off and then back on. No MFL but when the car would not start and the security system light flashed. We have had problems with one of the key fobs, but I replaced the battery on it twice and we reported the problem to the dealer and they could not find any faults.

Will report on what the dealer comes up with but I was just curious if anyone else has had this issue.
__________________

__________________
Reply With Quote
  #2  
Old 07-10-2012, 04:51 PM
Member
 
Join Date: Jul 2012
Location: connecticut
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 663
smokin151 is on a distinguished road
Re: Stall after start

sounds like a wcm(wireless control module) failure
__________________

__________________
Reply With Quote
  #3  
Old 07-12-2012, 09:17 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Massachusetts
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1382
hammer1234 is on a distinguished road
Re: Stall after start

The dealer replaced both keys but nothing in the vehicle. Said that this sometimes happens. I'm a little baffled by this...one key I could see but two bad keys at the same time?
__________________
Reply With Quote
  #4  
Old 07-30-2012, 06:59 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Massachusetts
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1382
hammer1234 is on a distinguished road
Re: Stall after start

Had another stall after start, although this one was after a long drive (6 hours with two stops) and it stalled when I started the vehicle soon after parking in the garage. Should have seen it coming, the engine didn't quite seem to be idling as smoothly as it usually does. No lights and it started up fine afterwards. Another thing I need to watch for now.

Really like this vehicle but I never had these problems with my first year build Toyota Highlander...
__________________
Reply With Quote
  #5  
Old 09-02-2012, 09:31 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: May 2011
Location: Massachusetts
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1382
hammer1234 is on a distinguished road
Re: Stall after start

Had this happen again today...needed to start and move right away and I started the vehicle and went into drive right away and it stalled. Frustrating because I can't make it happen on demand so I'm pretty sure that the dealer can't do much.

Would there be codes stored if there are no warning lights or CEL/MFLs?
__________________
Reply With Quote
  #6  
Old 04-09-2013, 08:05 AM
New Member
 
Join Date: May 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
skimmer8824 is on a distinguished road
Re: Stall after start

Hi Hammer, I have been having the exact same problem with v6 WK2. It started intermittantly stalling after startup a couple months ago. It seems to consistantly happen about a few times a week. No warnings or CEL. As far as the jeep is concerned, it thinks the car is still running. Have you had any updates on your situation?
__________________
Reply With Quote
  #7  
Old 07-29-2013, 01:02 PM
Member
My Jeep: 2013 3.6L WK2
 
Join Date: Jan 2013
Location: Crofton, MD
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 474
rakcmei is on a distinguished road
Re: Stall after start

This happens on my 2013 v6 as well. I had the dealer look at it but they could not reproduce. They cleared the codes just in case, but it has happened a few times since. I plan on taking it back, but am compiling a list of other issues (A/C, etc) before I go back.
__________________
Reply With Quote
  #8  
Old 07-30-2013, 07:38 AM
fireguy's Avatar
Member
My Jeep: 2011 WK2
 
Join Date: Jan 2011
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1226
fireguy is on a distinguished road
Re: Stall after start

I have joined the club. Have a 2011 Laredo. About a month ago it has stalled when pressing the start button. No troubles driving but a few times a week when going to start the car it tries to turn over then stalls. Need to cycle the on/off button to off then it starts right up the second time. I have nearly 24,000 miles. First real issue.
__________________
2011 WK2 Laredo X V6 Dark Charcoal
Reply With Quote
  #9  
Old 08-02-2013, 12:04 PM
Member
 
Join Date: Apr 2011
Posts: 37
Thanks: 0
Thanked 3 Times in 1 Post
Rep Power: 1141
Flocker is on a distinguished road
Re: Stall after start

Sitting at the dealership now with the same issue. Grrrr. Will post their findings.
__________________
Reply With Quote
  #10  
Old 08-05-2013, 08:58 PM
Member
 
Join Date: Dec 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 881
bigv is on a distinguished road
Re: Stall after start

Hey glad I found this post because I am having the same issue on my 2012 Jeep Grand Cherokee X package 3.6 V6 engine. Dealer cant reproduce the issue and its frustrating. This happens once or twice per week. Have to cycle the truck off before it can start again
__________________
Reply With Quote
  #11  
Old 08-06-2013, 04:52 PM
Member
 
Join Date: Dec 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 881
bigv is on a distinguished road
Re: Stall after start

Pissible fix for you... After some research it looks like the tpim needs to be replaced. I believe it runs about $1300
__________________
Reply With Quote
  #12  
Old 08-06-2013, 05:34 PM
Member
 
Join Date: Dec 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 881
bigv is on a distinguished road
Re: Stall after start

I correct myself its called tipm.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine stall Whilst Driving JoePistone Trouble Shooting/Problems/Service 24 08-19-2013 10:37 PM
Stall During Startup? litespeedz Trouble Shooting/Problems/Service 0 04-11-2011 12:28 PM
Stall while accelerating (5.7L) justin1569 Trouble Shooting/Problems/Service 13 04-01-2011 01:43 PM
Startup reverse stall? NHWK05 Grand Cherokee - WK 6 05-27-2010 09:44 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community