Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-16-2011, 01:10 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1326
brianfantana is on a distinguished road
Starting Issues

I have 2011 GC Laredo X with the V6, last month (while on vacation) driving from Missouri to Florida, we stopped for lunch about a third of the way there, got back in the car and it wouldn't start. Hit the button or turn the key (tried both), and the engine would crank, but wouldn't fire. We had it towed to the nearest Jeep dealer. When we got there, it started right up while still on the rollback. They ran it for codes and found nothing. We went on our way. It did the same thing 2 more times while on vacation.

After returning home, the problem repeated and we had it towed to the home dealership. That was on 6/2. To make a long story short, it's still there. They've replaced the crank sensor, both fuel pumps (apparently these require 2) and it's still doing the same thing. The dealer says they're stumped. They're working with Jeep tech assistance and they've given them some additional tests to run, but they say the next step might be replacing the "computer". I'm guessing this is the Power Control Module. Does anyone have any ideas?
__________________

__________________
Reply With Quote
  #2  
Old 06-16-2011, 07:35 PM
RageOfFury's Avatar
Premium Member
My Jeep: 2011 3.6L WK2
 
Join Date: Feb 2011
Location: Ottawa, Canada
Posts: 1,371
Thanks: 97
Thanked 26 Times in 24 Posts
Rep Power: 11170
RageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond reputeRageOfFury has a reputation beyond repute
Re: Starting Issues

Welcome!

Sorry to hear about your troubles. There is a TSB for this issue however :

http://wk2jeeps.com/tsb/tsb_wk2_0802411.pdf
__________________

__________________
2011 WK2 Laredo E V6 4x4
Reply With Quote
  #3  
Old 06-17-2011, 08:43 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1326
brianfantana is on a distinguished road
Re: Starting Issues

Thanks for the info on the TSB. I called the dealer and asked if that has been applied. The mechanic that's been working on it won't be in until later, but they will find out. The service guy I talked to tried to tell me that with wireless ignition problems, the engine usually won't crank at all, so this update may not apply to this problem. I disagree.
__________________
Reply With Quote
  #4  
Old 06-17-2011, 10:58 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1326
brianfantana is on a distinguished road
Re: Starting Issues

They reflashed the WIN and the problem still repeated. They will replace the PCM. We'll see if that sticks.
__________________
Reply With Quote
  #5  
Old 06-17-2011, 12:13 PM
Member
 
Join Date: May 2010
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1575
Patrick8917 is on a distinguished road
Re: Starting Issues

It seems like a majority of the problems people are having with the jeep relates to issues with the "computer". This is my opinion and is not based on data. I almost wonder if when Jeep was designing the GC the used some "Value Engineering" and went with a cheaper computer. I would assume that is a part that is specked and outsourced...thoughts?
__________________
Reply With Quote
  #6  
Old 06-17-2011, 02:08 PM
Premium Member
 
Join Date: Sep 2010
Posts: 383
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1775
bpmcgee is on a distinguished road
Re: Starting Issues

Patrick,

From what I can tell, it looks like dealers are all just throwing parts at the problems. This would make sense, because I don't think there's a factory repair manual yet.

I imagine that they're replacing a LOT of central computers (and other sensors, etc) that aren't really faulty.

B
__________________
Reply With Quote
  #7  
Old 06-18-2011, 10:02 AM
Member
 
Join Date: May 2010
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1575
Patrick8917 is on a distinguished road
Re: Starting Issues

Hi B,

I love Jeep and my last Gc served me for 10 years flawlessly. That said if they dont have a repair manual after a year of production that is sad. I will buy a new jeep in the next few months, I just hope I get one that works! When I bought my last GC in 2000 I remember a lot of people saying they had issues and that car went 200,000. I just hope that's the case this time....
__________________
Reply With Quote
  #8  
Old 06-28-2011, 04:34 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1326
brianfantana is on a distinguished road
Re: Starting Issues

Update: Computer installed, reprogrammed, problem still repeats.
__________________
Reply With Quote
  #9  
Old 06-28-2011, 04:35 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Dec 2010
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1326
brianfantana is on a distinguished road
Re: Starting Issues

Does anyone have any details about Chrysler's buy-back process? How does it work? How much do they charge per mile for usage?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow engine starting issues on 2006 Jeep Commander 5.7L Hemi Thomaskr 2005+ Jeep Commander XK 1 03-29-2011 10:14 PM
4.7 L v8 with starting issues? dmarrone1 Engine Performance/Intake/Exhaust 14 09-01-2010 09:46 PM
Starting issues JeepKid Grand Cherokee - WK 13 05-02-2010 03:39 PM
Not starting... Gunswinger Troubleshooting/Problems 8 04-03-2010 08:26 PM
2005 4.7L Starting Issues hamuel2003 Grand Cherokee - WK 9 03-01-2010 08:46 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:17 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community