Starting problems - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-23-2015, 10:37 PM
Member
 
Join Date: Dec 2011
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1851
bigv is on a distinguished road
Starting problems

I own a 2012 Jeep Grand Cherokee Laredo v6 and have been experiencing starting issues since 30k miles. I currently have just over 70k and still experiencing the same issue even after having the relay installed on my Jeep. My Jeep was not part of the recall for the tipm so I had to pay for the relay. Recently the problems have started to be come more frequent. The Jeep doesn't always start from the first attempt. It turns over and then engine shuts off even though the Jeep thinks the engine is on and it even lets me shift gears with the engine off! Another issue I'm having is after remote starting the car I get into the Jeep and press the break and push start to allow the car to drive. On two occasions it took me nearly 20 times pressing the push start before my vehicle was activated. Is there anyone out there that has these same issues even after installing the Relay? Thank you for any suggestions...

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 02-26-2015, 02:59 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Feb 2015
Posts: 56
Thanks: 2
Thanked 4 Times in 4 Posts
Rep Power: 1756
joplin-wk2-fan has a reputation beyond reputejoplin-wk2-fan has a reputation beyond reputejoplin-wk2-fan has a reputation beyond reputejoplin-wk2-fan has a reputation beyond reputejoplin-wk2-fan has a reputation beyond reputejoplin-wk2-fan has a reputation beyond reputejoplin-wk2-fan has a reputation beyond reputejoplin-wk2-fan has a reputation beyond reputejoplin-wk2-fan has a reputation beyond reputejoplin-wk2-fan has a reputation beyond reputejoplin-wk2-fan has a reputation beyond repute
Re: Starting problems

How long ago did you have the fuel pump relay replaced? If it has been a year or more... then there's a good chance the replacement relay is also starting to fail.
Reply With Quote
  #3  
Old 02-26-2015, 07:10 AM
Member
 
Join Date: Jan 2015
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 718
silverfox9142 is on a distinguished road
Re: Starting problems

You may want to consider having a new fuel filter too.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting Problems 4.7 sandkwagers Engine Performance/Intake/Exhaust 60 03-21-2012 08:06 AM
Jeep has problems starting nrlewellen47 Engine Performance/Intake/Exhaust 3 11-11-2011 10:56 PM
Starting problems vwkg Engine Performance/Intake/Exhaust 8 08-10-2011 02:27 PM
Delay in delivery is starting to cause me problems.... rdalcanto Grand Cherokee - WK2 - 3 11-22-2010 10:34 PM
Problems with 2000 4.7 v8 starting StoneCold Engine Performance/Intake/Exhaust 13 02-15-2010 11:09 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.