Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #169  
Old 11-22-2012, 10:16 PM
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Apr 2012
Location: N.S.W. Australia.
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 791
Hellipilot is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Check out the Sand + fail forum in the export section for WKJ2.

Many many pages of discussion. In there you will find some interesting reading.
One member summerised it in point form about 8-10 points I think.
Basically this sand fail occurrs:- inconsistantly, in any mode-auto/sand, in any gear (Hi or Low), any tyre pressure and to both the experienced and novice sand drivers.

Obviously a quirk with the vehicle. Some vehicles have it some do not. At this stage mine does not.
__________________

__________________
Reply With Quote
  #170  
Old 11-22-2012, 11:16 PM
Brett's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jun 2012
Location: Brisbane, Australia
Posts: 204
Thanks: 0
Thanked 12 Times in 8 Posts
Rep Power: 891
Brett is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by Hellipilot View Post
Obviously a quirk with the vehicle. Some vehicles have it some do not. At this stage mine does not.
Not quite. I had an in depth discussion with Chrysler customer support and they confirmed to me that this is purely a software issue. It is not the result of faulty sensors or hardware. There are many inputs to the drive train control module and all it needs is the "right" combination of inputs for this problem to occur. Basically it is a situation occurring that the programmers did not anticipate, I would call it a software bug.
__________________

__________________
Reply With Quote
  #171  
Old 11-23-2012, 02:16 AM
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Apr 2012
Location: N.S.W. Australia.
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 791
Hellipilot is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

As I said:
"Basically this sand fail occurrs:- inconsistantly, in any mode-auto/sand, in any gear (Hi or Low), any tyre pressure and to both the experienced and novice sand drivers.
__________________
Reply With Quote
  #172  
Old 11-23-2012, 04:17 AM
Brett's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jun 2012
Location: Brisbane, Australia
Posts: 204
Thanks: 0
Thanked 12 Times in 8 Posts
Rep Power: 891
Brett is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by Hellipilot View Post
As I said:
"Basically this sand fail occurrs:- inconsistantly, in any mode-auto/sand, in any gear (Hi or Low), any tyre pressure and to both the experienced and novice sand drivers.
I agree. However I would not say that some vehicles do not have the problem. ALL GC's that have not had the patch have this problem (they all have the same buggy software). It is just that some vehicles may not have encountered the perfect storm of conditions required to trigger the issue. It could happen to you.
__________________
Reply With Quote
  #173  
Old 11-24-2012, 05:19 PM
Member
 
Join Date: Jul 2011
Posts: 134
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1137
Gribbs is on a distinguished road
I'll add that the software fix does not work for all vehicles. Early builds are not able to be fixed without hardware fixes
__________________
Reply With Quote
  #174  
Old 11-25-2012, 04:34 PM
Mendo's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Sep 2011
Location: Queensland
Posts: 582
Thanks: 44
Thanked 23 Times in 21 Posts
Rep Power: 6169
Mendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond repute
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by Brett View Post
I agree. However I would not say that some vehicles do not have the problem. ALL GC's that have not had the patch have this problem (they all have the same buggy software). It is just that some vehicles may not have encountered the perfect storm of conditions required to trigger the issue. It could happen to you.
I disagree. I have not had the problem after a week on Fraser island in all sorts of conditions. My ESC lights up and stays on until I have driven on solid hard sand or roads for sometime. It "appears" mine is working correctly. I'll be back there for a week soon so will have another chance to test it out again. I must say a little less confident than last time but confident nonetheless. The jeep was amazing on sand the Quadralift gives an unbelievably smooth ride.
__________________
3.0L CRD Brilliant Black
Laredo w/ QuadraLift
Reply With Quote
  #175  
Old 11-25-2012, 11:02 PM
Brett's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jun 2012
Location: Brisbane, Australia
Posts: 204
Thanks: 0
Thanked 12 Times in 8 Posts
Rep Power: 891
Brett is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by Mendo View Post
I disagree. I have not had the problem after a week on Fraser island in all sorts of conditions. My ESC lights up and stays on until I have driven on solid hard sand or roads for sometime. It "appears" mine is working correctly. I'll be back there for a week soon so will have another chance to test it out again. I must say a little less confident than last time but confident nonetheless. The jeep was amazing on sand the Quadralift gives an unbelievably smooth ride.
Hey Mendo,

I had the problem only once and it occurred the very first time I had it on the beach and within 5 minutes of getting there (at the time I was not aware of the serv 4wd issue, only later to read about it here). Since then I spent 6 days on Fraser going in and out of Kingfisher inland road every day in really horrendously dry, deep soft sand and rough conditions (The quadra lift runs out of travel very easily in ORII on the deep ruts, but it's great to have the necessary height). Also I spent 5 days on Moreton island (covered almost every track at least twice) and 3 seperate trips to Teewah/Double Island. On all these trips I never had the problem again and was very impressed with the Jeep's capabilities. I am yet to venture back onto the sand now the module has been fitted.
__________________
Reply With Quote
  #176  
Old 01-08-2013, 03:05 AM
Dunecrawler's Avatar
Member
 
Join Date: May 2010
Location: Dubai
Posts: 305
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1769
Dunecrawler has a reputation beyond reputeDunecrawler has a reputation beyond repute
Re: STUCK IN SAND with 4WD malfunction

Back again...
Some of you might remember me, but for those that do not, here is a quick rundown.
I live in Dubai so I tend to do quite a bit of sand driving. I started having problems in the sand with SERV 4WD sys message and front wheel drive issues shortly after I took delivery of my Overland in Nov 2010.

After many frustrating trips to the service center they eventually said they fixed the issue with a software update. Something to do with the ABS. Remember that this was back in 2011, so it could not have been the patch/fix that you guys are now talking about.

Anyway, since then I have had the Jeep in the desert a few times without incident. Then a few months ago we went for a quick overnight trip. Basically for the first time, I tried 4WD LOW for an extended period of time, and the bloody thing AGAIN said SERV 4WD!! It was stuck in 4WD LOW until I got it back on a hard road again and needless to say I was seriously pissed off! At least it was stuck in 4WD LOW, so I was not again stranded, but still irritated.

After this I did not even mention it to Jeep and have not taken it into the desert again as I lost all faith and confidence in Jeep.
I guess I was kind of hoping that it was just a once off occurrence and that the issue would not start all over again.

Now here comes the interesting bit. The Dubai Jeep Jamboree is coming up on the 18th of January and I have decided to go along. The problem is that just about all of it will be on soft sand seeing as this is a desert. So this could be VERY bad!

However, I thought that since it is basically organized by the Jeep distributor here in Dubai that it might be worth a try and to see what happens. They are going for some kind of record I believe expecting more than 500 entries!

I was sure this was all sorted out until I had the issue with it being stuck in 4WD LOW the last time we went out there. I would obviously like to have everything possible done to prevent another embarrassing failure. Especially on the Jamboree.

So, before I go and do this, do you guys have any idea of what this latest patch/flash/fix is called? Does it have a TSB number or something?

I will keep you updated of the outcome. Could be very interesting!
__________________
-Willem
'11 WK2 Overland 5.7(Export)
Dark Charcoal, Dark/Light Frost Beige
730/1 NAV (REP)

(Built 21 Aug '10). Ordered on 22 Sept '10 and Delivered 25 Nov '10 in Dubai
Reply With Quote
  #177  
Old 01-08-2013, 06:30 AM
Brett's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jun 2012
Location: Brisbane, Australia
Posts: 204
Thanks: 0
Thanked 12 Times in 8 Posts
Rep Power: 891
Brett is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

There is no TSB for this fix yet according to Chrysler support in Australia. I have been told that it is a firmware update of the Drive Train Control Module. Apparently, specialized equipment is necessary to perform the software update on the module and most dealers do not have the required equipment. As a work around in Australia for those of us whose dealer does not have the necessary equipment, Chrysler have been swapping out the module itself with a replacement module that has been preloaded with the software fix. I'm suspecting the cost of replacing the modules is partly the reason for the delay in issuing a TSB.

We have found out here that the best way to get the problem resolved is via contact directly with Chrysler/Jeep/Dodge directly and bypass your dealer.

Hope this helps
__________________
Reply With Quote
  #178  
Old 01-08-2013, 07:14 AM
Dunecrawler's Avatar
Member
 
Join Date: May 2010
Location: Dubai
Posts: 305
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1769
Dunecrawler has a reputation beyond reputeDunecrawler has a reputation beyond repute
Thanks. Could be very difficult to get them to do anything like that here. Will see how it goes on the Jamboree.
__________________
-Willem
'11 WK2 Overland 5.7(Export)
Dark Charcoal, Dark/Light Frost Beige
730/1 NAV (REP)

(Built 21 Aug '10). Ordered on 22 Sept '10 and Delivered 25 Nov '10 in Dubai
Reply With Quote
  #179  
Old 01-08-2013, 08:10 AM
lysol's Avatar
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Dec 2012
Location: The Federal City
Posts: 317
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 807
lysol is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

I know this sounds ghetto but would putting something hard under the tires if this problem happens again confuse the Jeep into thinking it is on the hard road and maybe allow it to switch out of 4 low? Just a thought.
__________________
"I've got GREAT news! , I just saved a bunch of money on my motorcycle insurance by outrunning the cops."

'13 WK2 Overland Summit V8 (Black Leather) Mineral Grey
Reply With Quote
  #180  
Old 01-08-2013, 10:12 AM
Dunecrawler's Avatar
Member
 
Join Date: May 2010
Location: Dubai
Posts: 305
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1769
Dunecrawler has a reputation beyond reputeDunecrawler has a reputation beyond repute
I think the problem sorts itself out after some normal wheel rotation without the ABS working excessively hard.
I am just not sure if it is during braking or wheelspin that the ABS gets confused. Either way, it needs a reasonable amount of travel on a hard surface to reset the error back to normal.
__________________

__________________
-Willem
'11 WK2 Overland 5.7(Export)
Dark Charcoal, Dark/Light Frost Beige
730/1 NAV (REP)

(Built 21 Aug '10). Ordered on 22 Sept '10 and Delivered 25 Nov '10 in Dubai
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MIL (Malfunction Indicator Lamp) Andrew Interior/Exterior/Visual 23 06-13-2013 11:22 AM
Malfunction Light watchdog507 Trouble Shooting/Problems/Service 3 10-28-2011 05:16 PM
malfunction indicator light 05jgc Grand Cherokee - WK 3 08-20-2011 09:59 PM
Service 4WD System, rear wheel binding/brake stuck. RossC Grand Cherokee - WK 8 03-23-2011 04:16 PM
Dash Display Malfunction? overlander Trouble Shooting/Problems/Service 4 03-04-2011 08:23 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community