Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #193  
Old 01-10-2013, 01:54 AM
Dunecrawler's Avatar
Member
 
Join Date: May 2010
Location: Dubai
Posts: 305
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1894
Dunecrawler has a reputation beyond reputeDunecrawler has a reputation beyond repute
BTW, the record they are going for is not with the Jamboree, but with the Gulf News Desert Drive. Going for a Guinness record of 1000+ entries.
Approximately 150-200 expected for the Jamboree.
Apparently the Jamboree is not as challenging as the Gulf News drive.
__________________

__________________
-Willem
'11 WK2 Overland 5.7(Export)
Dark Charcoal, Dark/Light Frost Beige
730/1 NAV (REP)

(Built 21 Aug '10). Ordered on 22 Sept '10 and Delivered 25 Nov '10 in Dubai
Reply With Quote
  #194  
Old 01-10-2013, 02:09 AM
Dunecrawler's Avatar
Member
 
Join Date: May 2010
Location: Dubai
Posts: 305
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1894
Dunecrawler has a reputation beyond reputeDunecrawler has a reputation beyond repute
OK, they say that TSB 21-008-11 and 08-034-12 solves all the issues.
They are confident that I will not have a problem again.
Jamboree here we come!
__________________

__________________
-Willem
'11 WK2 Overland 5.7(Export)
Dark Charcoal, Dark/Light Frost Beige
730/1 NAV (REP)

(Built 21 Aug '10). Ordered on 22 Sept '10 and Delivered 25 Nov '10 in Dubai
Reply With Quote
  #195  
Old 01-10-2013, 04:12 AM
Brett's Avatar
Member
My Jeep: 2012 5.7L WK2
 
Join Date: Jun 2012
Location: Brisbane, Australia
Posts: 211
Thanks: 0
Thanked 14 Times in 10 Posts
Rep Power: 1023
Brett is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by Dunecrawler View Post
OK, they say that TSB 21-008-11 and 08-034-12 solves all the issues.
They are confident that I will not have a problem again.
Jamboree here we come!
Hmmm, the plot certainly does thicken. Both myself and others in Australia were told directly from Chrysler HQ (i.e. not just a dealer or service centre) were told that there is not yet a TSB for the fix we received.

Of the 2 TSB's you mention 1 is an air suspension related fix (whereas a lot of steel suspension vehicles here have been affected), and the other only affects vehicles manufactured before June 16 2011.

Unfortunately, what they have told you looks very similar to the what I was originally told by my dealer. In my opinion, I think that all they are doing is looking at the available TSB's and trying to "guess" what matches your reported problem.

Sorry to be negative on this, but in my opinion the TSB's you have had applied will not fix the issue - or in any case is not the fix that we have been given here in Australia. The fix we have been given here still has no TSB (atleast not as of a few weeks ago) so it is not either of the TSB related patches you have been given. Also, the problem has been occurring for vehicles manufactured after June 16 2011, and also occurs with steel suspension vehicles, which also seems to rule out both TSB's you had applied.
__________________
Reply With Quote
  #196  
Old 01-10-2013, 05:57 AM
Dunecrawler's Avatar
Member
 
Join Date: May 2010
Location: Dubai
Posts: 305
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1894
Dunecrawler has a reputation beyond reputeDunecrawler has a reputation beyond repute
Yeah, I think you are right. I think it as an improvement at best. Not the fix we are all waiting for.
Very curious to see how all the Grands do on the Jamboree. But at least I have the Dealers assurance that everything will be fine. The local dealer/distributor will also be attending as marshals. Could be interesting.
__________________
-Willem
'11 WK2 Overland 5.7(Export)
Dark Charcoal, Dark/Light Frost Beige
730/1 NAV (REP)

(Built 21 Aug '10). Ordered on 22 Sept '10 and Delivered 25 Nov '10 in Dubai
Reply With Quote
  #197  
Old 01-20-2013, 10:08 AM
Dunecrawler's Avatar
Member
 
Join Date: May 2010
Location: Dubai
Posts: 305
Thanks: 0
Thanked 3 Times in 2 Posts
Rep Power: 1894
Dunecrawler has a reputation beyond reputeDunecrawler has a reputation beyond repute
We finished the Jamboree. Few hours of dry riverbed and then few hours of very soft deep sand in the Fossil Rock area for those that are familiar with the area.

The Grand did VERY well. No problems at all. Actually embarrassed a few Cherokees and Wranglers in the Riverbed. I did not see any stock vehicles that did better than the Grand in the dunes. And that includes Landcruisers and Patrols that happen to be in the same area.
No problems with my Jeeps 4WD system, or any others that I am aware of. Only issue was one Laredo that damaged the radiators in front when coming down a bit hard/steep (need to buy some protection for that myself).

Would have loved to have 18's instead of 20's as that was the only limiting factor for me. I was a bit concerned to yet again have a tire come off the rim.
Other than that the Jeep was unstoppable! I think we surprised many of the people there.
It seems that the Jeep dealer in the UAE has a definite fix for the problem. It is another matter if they are giving me the whole story in how they solved it though.
Photos to follow...
__________________
-Willem
'11 WK2 Overland 5.7(Export)
Dark Charcoal, Dark/Light Frost Beige
730/1 NAV (REP)

(Built 21 Aug '10). Ordered on 22 Sept '10 and Delivered 25 Nov '10 in Dubai
Reply With Quote
  #198  
Old 01-21-2013, 02:35 PM
Member
 
Join Date: Apr 2012
Posts: 96
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 951
Xjrguy is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

That's great news!

Hopefully there will be an update soon for US based WK2 owners.
__________________
Reply With Quote
  #199  
Old 03-30-2013, 07:04 PM
Member
 
Join Date: Sep 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 719
brandnewslacker is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Got my first SERV 4WD error on my first trip out on Cape Henlopen, DE beach. Very disappointed and feared it would happen. I have a 2012 wk2 Laredo X with quadra trac II. I was in auto, 20psi, and going ~15 mph. Half mile on the beach I lose traction and the error code comes up.

Luckily, I had my shovel and wood boards to inch myself out onto some more packed sand to turn back around. As soon as I hit the pavement the error went away.

I'm going in to dealer to have the code scanned and see what nonsense excuse/fix they have.

I have no faith in this 4wd system since no one has gotten a concrete explanation or fix yet.

I will post my dealer's response next week.
__________________
Reply With Quote
  #200  
Old 03-31-2013, 07:42 PM
Member
 
Join Date: Dec 2011
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 991
dxrdxr is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Please do post the reply. Does anyone know if this is also a issue with the QD II?? What about the 2013 model year?? Thanks
__________________
Reply With Quote
  #201  
Old 03-31-2013, 09:06 PM
Carver's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Mar 2012
Location: Brisbane, QLD
Posts: 43
Thanks: 2
Thanked 9 Times in 4 Posts
Rep Power: 33704
Carver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond repute
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by brandnewslacker View Post

I'm going in to dealer to have the code scanned and see what nonsense excuse/fix they have.

I have no faith in this 4wd system since no one has gotten a concrete explanation or fix yet.

I will post my dealer's response next week.
When mine had the issue on Fraiser, I did the forwards/backwards wiggle to reset thing as described by the Jeep person on the phone at the time I was doing it. He said take it in and get the code read but lo a nod behold....when Jeep did the service there was "no error codes or messages"


Interested to now what your code is, if there.
__________________
Reply With Quote
  #202  
Old 03-31-2013, 10:32 PM
Member
 
Join Date: Sep 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 719
brandnewslacker is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by Carver View Post
When mine had the issue on Fraiser, I did the forwards/backwards wiggle to reset thing as described by the Jeep person on the phone at the time I was doing it. He said take it in and get the code read but lo a nod behold....when Jeep did the service there was "no error codes or messages"


Interested to now what your code is, if there.
Can you elaborate on the forwards/backwards wiggle? I thought I combed this and the other sand fail export thread, but must have missed it.
__________________
Reply With Quote
  #203  
Old 04-01-2013, 12:48 AM
Carver's Avatar
Premium Member
My Jeep: 2012 3.0L WK2
 
Join Date: Mar 2012
Location: Brisbane, QLD
Posts: 43
Thanks: 2
Thanked 9 Times in 4 Posts
Rep Power: 33704
Carver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond reputeCarver has a reputation beyond repute
Re: STUCK IN SAND with 4WD malfunction

It was, and I quote the Jeep assistance person here.....

"Back up at about 10 km/hr, put in neutral then drive, well maybe not 10, maybe walking pace"

In the end I just got into the car park behind that pub and just went forwards and backwards for a bit, so it was likely the hard bitumen road that did it
__________________
Reply With Quote
The Following User Says Thank You to Carver For This Useful Post:
  #204  
Old 04-01-2013, 10:40 AM
Member
 
Join Date: Sep 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 719
brandnewslacker is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Carter- thanks for the explanation. That wouldn't have helped me in my case as I was stuck in the sand.

Dealer just called, said they reset the abs module ( they identified this on their own) and should do the trick. Ill see if they have any additional info when I pick it up this evening.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MIL (Malfunction Indicator Lamp) Andrew Interior/Exterior/Visual 23 06-13-2013 11:22 AM
Malfunction Light watchdog507 Trouble Shooting/Problems/Service 3 10-28-2011 05:16 PM
malfunction indicator light 05jgc Grand Cherokee - WK 3 08-20-2011 09:59 PM
Service 4WD System, rear wheel binding/brake stuck. RossC Grand Cherokee - WK 8 03-23-2011 04:16 PM
Dash Display Malfunction? overlander Trouble Shooting/Problems/Service 4 03-04-2011 08:23 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community