Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-29-2012, 05:27 AM
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Mar 2012
Location: Newcastle, NSW
Posts: 41
Thanks: 11
Thanked 1 Time in 1 Post
Rep Power: 963
icrisps is on a distinguished road
Exclamation STUCK IN SAND with 4WD malfunction

My JGC Overland (AUS) is only 1 week old and I was loving every aspect of it until I got bogged down in sand with the message flashing 'Service 4wd' . Till then I was driving in Sand under the 'sand and mud' mode. A Prado had to rescue my dear GC (to my utter shame) but only to get bogged down again and again because the 4wd didn't seem to engage. My tire pressure was 15psi. Once out of sand, ( had to be towed my the Prado for 1km) the error message disappeared and it is driving fine ! I haven't rung Jeep Assist as the problem rectified by itself by the time I got mobile phone reception.
Any else has had similar issues ?
__________________

__________________
Reply With Quote
  #2  
Old 04-29-2012, 09:05 AM
Lucas J's Avatar
natural born world shaker

My Jeep: 2005 5.7L WK
 
Join Date: Aug 2011
Location: Mass
Posts: 2,692
Thanks: 127
Thanked 84 Times in 76 Posts
Rep Power: 996598
Lucas J has a reputation beyond reputeLucas J has a reputation beyond reputeLucas J has a reputation beyond reputeLucas J has a reputation beyond reputeLucas J has a reputation beyond reputeLucas J has a reputation beyond reputeLucas J has a reputation beyond reputeLucas J has a reputation beyond reputeLucas J has a reputation beyond reputeLucas J has a reputation beyond reputeLucas J has a reputation beyond repute
Re: STUCK IN SAND with 4WD malfunction

Bring it back to the dealer regardless. If for nothing else but to have a record of the incedent.
__________________

__________________


Beatrix "The Black Mamba" Build Thread
http://www.jeepgarage.org/f14/beatri...ead-42874.html
Reply With Quote
  #3  
Old 04-29-2012, 08:29 PM
Member
 
Join Date: Oct 2011
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2966
JeepJunkie has a reputation beyond reputeJeepJunkie has a reputation beyond reputeJeepJunkie has a reputation beyond reputeJeepJunkie has a reputation beyond reputeJeepJunkie has a reputation beyond reputeJeepJunkie has a reputation beyond reputeJeepJunkie has a reputation beyond reputeJeepJunkie has a reputation beyond reputeJeepJunkie has a reputation beyond reputeJeepJunkie has a reputation beyond reputeJeepJunkie has a reputation beyond repute
Re: STUCK IN SAND with 4WD malfunction

First of all, kudos to you for taking your brand new Jeep out to play in the sand.

How long were you out there for before it quit on you? I've only driven on the sand once, in a Wrangler, and after an hour or so of hard driving I could SMELL things overheating (differentials, transfer case, who knows what).

My amateur guess is something started overheating (like the clutch pack center diff?) and the GC stepped in to avoid permanent damage. Just my best guess.
__________________
Reply With Quote
The Following User Says Thank You to JeepJunkie For This Useful Post:
  #4  
Old 04-29-2012, 11:12 PM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Feb 2012
Location: Brisbane, AUS
Posts: 167
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1116
LeCheese is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Hey,
I've read about this with the new WK2 before from a few other people (not sure if it was on here or another forum) but you are not alone! I read that the exact same thing happened, where the service 4wd light came on, but then it went off again soon after. Some fixes i've heard is that when the light comes on, restart the car. If that doesnt work some people have had success by disconnecting the battery for a couple of minutes (which resets the system). I would take it to your dealer (which one by the way?) and let them know of the problem. I own a WK2 also and havent taken it offroad yet but when we do go to straddie at some point this year i really hope it doesnt happen! Props for taken yours on the sand when it was so young too
__________________
Reply With Quote
The Following User Says Thank You to LeCheese For This Useful Post:
  #5  
Old 04-29-2012, 11:57 PM
savvas's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Feb 2012
Location: Sydney, Australia
Posts: 658
Thanks: 26
Thanked 32 Times in 27 Posts
Rep Power: 164132
savvas has a reputation beyond reputesavvas has a reputation beyond reputesavvas has a reputation beyond reputesavvas has a reputation beyond reputesavvas has a reputation beyond reputesavvas has a reputation beyond reputesavvas has a reputation beyond reputesavvas has a reputation beyond reputesavvas has a reputation beyond reputesavvas has a reputation beyond reputesavvas has a reputation beyond repute
Re: STUCK IN SAND with 4WD malfunction

Jeep Australia officially launched the CRD version of the WK2 Grand Cherokee on Moreton Island last year.

Surely at an all day event on sand with something like 10 new CRD GCs on hand, at least one of them would have had this problem.
__________________
Savvas

2012 True Blue Laredo CRD
Reply With Quote
  #6  
Old 04-30-2012, 12:08 AM
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Mar 2012
Location: Newcastle, NSW
Posts: 41
Thanks: 11
Thanked 1 Time in 1 Post
Rep Power: 963
icrisps is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by savvas View Post
Jeep Australia officially launched the CRD version of the WK2 Grand Cherokee on Moreton Island last year.

Surely at an all day event on sand with something like 10 new CRD GCs on hand, at least one of them would have had this problem.
True...it means this problem is not as common as 1 in 10 but certainly has been reported on many forums a few times. In fact at the same venue.. but obviously is a coincidence.

Apparently there is a way to interogate the hardware and that may give an answer.

Will post an update once I have a chance to get it checked by the service team (Newcastle).

Thanks to everyone for the comments
__________________
Reply With Quote
  #7  
Old 04-30-2012, 12:21 AM
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Mar 2012
Location: Newcastle, NSW
Posts: 41
Thanks: 11
Thanked 1 Time in 1 Post
Rep Power: 963
icrisps is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by JeepJunkie View Post
First of all, kudos to you for taking your brand new Jeep out to play in the sand.

How long were you out there for before it quit on you? I've only driven on the sand once, in a Wrangler, and after an hour or so of hard driving I could SMELL things overheating (differentials, transfer case, who knows what).

My amateur guess is something started overheating (like the clutch pack center diff?) and the GC stepped in to avoid permanent damage. Just my best guess.
A few hours but driving for only 1-2hrs. I guess I may ahve an answer from the tech.
__________________
Reply With Quote
  #8  
Old 04-30-2012, 06:08 AM
Member
 
Join Date: Jul 2011
Posts: 134
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1290
Gribbs is on a distinguished road
Definitely a faulty module, one of my mates said it was a $5 part they replaced one his when it happened (also in Newcastle). I'm trying to figure put if it is partially driver error too, as the few people I know have had it happen to them are not very experienced sand drivers. In our circle of friends, four JFK owners, mine is the only one that hasn't has any issues, but I've also had five previous Fourbys, the rest Are on thier first. None of the, can recall if they were on high or low range, or if it happened by not engaging neutral first

Let me know what the dealer tells you, I assume you are seeing hunter prestige motors at Gateshead?

Ps, mine is the mineral grey Laredo getting around town, Crd.
__________________
Reply With Quote
The Following User Says Thank You to Gribbs For This Useful Post:
  #9  
Old 04-30-2012, 06:57 AM
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Mar 2012
Location: Newcastle, NSW
Posts: 41
Thanks: 11
Thanked 1 Time in 1 Post
Rep Power: 963
icrisps is on a distinguished road
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by Gribbs View Post
Definitely a faulty module, one of my mates said it was a $5 part they replaced one his when it happened (also in Newcastle). I'm trying to figure put if it is partially driver error too, as the few people I know have had it happen to them are not very experienced sand drivers. In our circle of friends, four JFK owners, mine is the only one that hasn't has any issues, but I've also had five previous Fourbys, the rest Are on thier first. None of the, can recall if they were on high or low range, or if it happened by not engaging neutral first

Let me know what the dealer tells you, I assume you are seeing hunter prestige motors at Gateshead?

Ps, mine is the mineral grey Laredo getting around town, Crd.
Thanks for your comments mate... Hopefully the mob in Gateshead will figure it out and I can share the wisdom...
__________________
Reply With Quote
  #10  
Old 04-30-2012, 07:53 AM
Mendo's Avatar
Member
My Jeep: 2012 3.0L WK2
 
Join Date: Sep 2011
Location: Queensland
Posts: 586
Thanks: 44
Thanked 23 Times in 21 Posts
Rep Power: 6327
Mendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond reputeMendo has a reputation beyond repute
Re: STUCK IN SAND with 4WD malfunction

Quote:
Originally Posted by Gribbs View Post
Definitely a faulty module, one of my mates said it was a $5 part they replaced one his when it happened (also in Newcastle). I'm trying to figure put if it is partially driver error too, as the few people I know have had it happen to them are not very experienced sand drivers. In our circle of friends, four JFK owners, mine is the only one that hasn't has any issues, but I've also had five previous Fourbys, the rest Are on thier first. None of the, can recall if they were on high or low range, or if it happened by not engaging neutral first

Let me know what the dealer tells you, I assume you are seeing hunter prestige motors at Gateshead?

Ps, mine is the mineral grey Laredo getting around town, Crd.
I also have had no problem, I agree user error might bring forth underlying problems. This car needs more care than more basic 4x4's might but I found it very capable. In really soft sand I found I had to go to low more than I used to in my Prado to get the engine to hold a decent revs.

I always shifted to neutral before engaging low. I used both sand and auto modes. The one issue I did have was my ESC warning light would come on (in addition to the ESC off light) I believe is was due to blocked sensors by sand because once we went through water it fixed itself.

Looking forward to hearing some conclusive results regarding this to give us all the confidence to get back out there (without tow hooks!)
__________________
3.0L CRD Brilliant Black
Laredo w/ QuadraLift
Reply With Quote
  #11  
Old 04-30-2012, 09:54 AM
moosehead's Avatar
Horseshoe for the Donkeys

My Jeep: 2011 5.7L WK2
 
Join Date: Sep 2010
Location: CO Rockies
Posts: 3,168
Thanks: 217
Thanked 97 Times in 83 Posts
Rep Power: 1620698
moosehead has a reputation beyond reputemoosehead has a reputation beyond reputemoosehead has a reputation beyond reputemoosehead has a reputation beyond reputemoosehead has a reputation beyond reputemoosehead has a reputation beyond reputemoosehead has a reputation beyond reputemoosehead has a reputation beyond reputemoosehead has a reputation beyond reputemoosehead has a reputation beyond reputemoosehead has a reputation beyond repute
Re: STUCK IN SAND with 4WD malfunction

Dunecrawler had something similar go down on the sand and got it squared away by his dealer overseas. A few threads here.

2nd Breakdown in just over 2 weeks!!!

4WD System works again!
__________________
2011 JGC Oland Hemi / Borla Catback Proto / Hemifever Tune on DS Trinity / Flyin Ryan PTB / Volant CAI / Bwoody Sway Links / BT Catch Can & Underhood Kit / Jon's Tinted Tails / SRT8 Hood, Steering Wheel, Shiftknob, Pedals / Firestone Dest AT's & Winter 18's / Focal 165 Component Fronts, Alpine PDX 5 Amp, Rockford Fosgate P3 10" Sub & Fiberglass Enclosure / PS2 Grill, Mirrors & Liftgate Strip / Tow Hooks & Skids / JW Speaker LED Foglights / Debadged, Tint, Clear Bra / Sharkfin / Vled & Putco LED's / JRoll Uber-Tech Cabin Filter / RA & Yak Roof Rack / Lit Sills, Slush & Cargo Mats
Reply With Quote
The Following User Says Thank You to moosehead For This Useful Post:
  #12  
Old 05-02-2012, 03:06 PM
Member
 
Join Date: Nov 2011
Posts: 58
Thanks: 0
Thanked 2 Times in 1 Post
Rep Power: 1173
jgiuliani has a reputation beyond reputejgiuliani has a reputation beyond reputejgiuliani has a reputation beyond reputejgiuliani has a reputation beyond repute
Re: STUCK IN SAND with 4WD malfunction

I have the same issue with my 2012 Laredo X. here is a post on another forum regarding the matter. Still no word from Jeep on a fix, they're dragging their feet. Very disappointing for a "Trail Rated" vehicle...

http://www.jeepforum.com/forum/f309/...v-4wd-1345070/
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MIL (Malfunction Indicator Lamp) Andrew Interior/Exterior/Visual 23 06-13-2013 11:22 AM
Malfunction Light watchdog507 Trouble Shooting/Problems/Service 3 10-28-2011 05:16 PM
malfunction indicator light 05jgc Grand Cherokee - WK 3 08-20-2011 09:59 PM
Service 4WD System, rear wheel binding/brake stuck. RossC Grand Cherokee - WK 8 03-23-2011 04:16 PM
Dash Display Malfunction? overlander Trouble Shooting/Problems/Service 4 03-04-2011 08:23 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community