Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #145  
Old 05-07-2013, 03:54 PM
torifile's Avatar
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jan 2013
Posts: 632
Thanks: 27
Thanked 13 Times in 9 Posts
Rep Power: 1316803
torifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond reputetorifile has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Seems like uconnect problems is either the cause or a symptom of underlying issues. Thankfully my uconnect has been solid.
__________________

__________________
Current: 2014 Overland. V8. 4x4. Black on black.
SOLD! 2010 BMW 335d.
Reply With Quote
  #146  
Old 05-08-2013, 04:07 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 5,480
Thanks: 259
Thanked 257 Times in 228 Posts
Rep Power: 1800518
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Back to shop ... same problem.

Quote:
Originally Posted by bill_de View Post
He had somebody checking it out before he even had the work order done. The found the stored codes and the computer directed them to the Star number which Milous had referred to. They took the ground wires off and cleaned up the connections. They had no problem with it being on the beach.

Holden Dodge will get all my service work.

I started my car this afternoon and all the same warning lights came on again. Plus the screen was warning about suspension (which doesn't work now) and abs brakes.

So Friday, instead of being on the beach, my Jeep will be back at the dealer. But my new lures didn't get here yet anyway.

First problem recurring and no resolution yet on second problem.
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #147  
Old 05-08-2013, 04:16 PM
AZhiCntry's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Prescott, AZ
Posts: 543
Thanks: 280
Thanked 21 Times in 20 Posts
Rep Power: 48742
AZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond repute
Re: Back to shop ... same problem.

Had veh for 3 wks and no problems. Registered Uconnect 2 days ago and now have black screen/reboots while driving, screen freezes, loss of touch controls, loss of radio signal to Sirius and who knows what else! Sucks.
__________________
2014 GC Limited V6 4x4, white w/black & frost beige, LuxII, RA4, ORA II, Cooper Discoverer AT3's. :D:D:D
Reply With Quote
  #148  
Old 05-08-2013, 07:01 PM
amc2002's Avatar
Premium Member
My Jeep: 2002 4.0L TJ
 
Join Date: Apr 2013
Location: Long Island, NY
Posts: 510
Thanks: 0
Thanked 11 Times in 11 Posts
Rep Power: 236830
amc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond repute
Quote:
Originally Posted by bill_de View Post

I started my car this afternoon and all the same warning lights came on again. Plus the screen was warning about suspension (which doesn't work now) and abs brakes.

So Friday, instead of being on the beach, my Jeep will be back at the dealer. But my new lures didn't get here yet anyway.

First problem recurring and no resolution yet on second problem.
Ugh. I hope our issues are solved soon....
__________________
Reply With Quote
  #149  
Old 05-08-2013, 08:44 PM
Premium Member
 
Join Date: Mar 2013
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 458
chukeer is on a distinguished road
Garage
Re: Those who have a 2014, any problems? or problem free?

Just took delivery of my '14 Overland yesterday...raining today...noticed condensation in both my headlights. Going to keep an eye on it and it if persists, I'm taking it in.
__________________
Reply With Quote
  #150  
Old 05-08-2013, 08:53 PM
AZhiCntry's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Prescott, AZ
Posts: 543
Thanks: 280
Thanked 21 Times in 20 Posts
Rep Power: 48742
AZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond reputeAZhiCntry has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by chukeer View Post
Just took delivery of my '14 Overland yesterday...raining today...noticed condensation in both my headlights. Going to keep an eye on it and it if persists, I'm taking it in.
This is normal. The headlights produce a lot of heat and are vented. Under certain humidity conditions you will see condensation. Turning the lights on for awhile should evaporate the condensation.
__________________
2014 GC Limited V6 4x4, white w/black & frost beige, LuxII, RA4, ORA II, Cooper Discoverer AT3's. :D:D:D
Reply With Quote
  #151  
Old 05-08-2013, 09:32 PM
xnight's Avatar
Member
 
Join Date: Mar 2013
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 461
xnight is on a distinguished road
Parked the jeep.... Went back to it.... Started it, dash was black, no gauges working.... Turn it off, restarted... Same, turned off again, restarted a second time...all back to normal. Some glitch huh?
__________________
Reply With Quote
  #152  
Old 05-09-2013, 09:47 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Dec 2011
Location: Fairfax, VA
Posts: 9
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 866
kbrown127 is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

We traded our 2011 Laredo X (with no issues to date) for a 2014 Limited on Sunday. Tuesday as we were driving home from work, we got an ABS light and traction control light along with a message saying 4wd was disabled. Brought it in that night and have not seen it since. They say they are working on it and cannot find the problem everytime we call. They have now had the car as long as we have...very frustrating!
__________________
Reply With Quote
  #153  
Old 05-09-2013, 01:21 PM
Premium Member
 
Join Date: Mar 2013
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 458
chukeer is on a distinguished road
Garage
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by AZhiCntry View Post
This is normal. The headlights produce a lot of heat and are vented. Under certain humidity conditions you will see condensation. Turning the lights on for awhile should evaporate the condensation.
I stopped over at the dealer this morning, just to have it on record that I had experienced this. They printed off and provided me with the Chrysler Bulletin on this issue.

I was told that this has been happening with a lot of the 2014 Jeeps, and Chrysler 300's with the new light design.

They said to keep an eye on it and if the lens becomes hazey or the moisture ends up staying there for a long period of time, then they'll replace the light(s).
__________________
Reply With Quote
  #154  
Old 05-09-2013, 01:43 PM
tkoui's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: NWIndiana
Posts: 43
Thanks: 12
Thanked 1 Time in 1 Post
Rep Power: 425
tkoui is on a distinguished road
Garage
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by xnight View Post
Parked the jeep.... Went back to it.... Started it, dash was black, no gauges working.... Turn it off, restarted... Same, turned off again, restarted a second time...all back to normal. Some glitch huh?

I had the same glitch two nights ago. Thus far, it hasn't happened again.
__________________
Reply With Quote
  #155  
Old 05-10-2013, 11:10 PM
Imanthony's Avatar
Member
 
Join Date: May 2013
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 386
Imanthony is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

Issues thus far (had Jeep 2 weeks today)

- Drove home from dealer - next day tire flat (had a screw in it) The dealer replaced the wheel and tire.
- iPhone 4 sync'd but then disconnected the sync. Happened twice now.
- Doors wouldnt unlock in rain. I then realized that having the key fob and my iPhone in the same pocket would confuse the fob signal to car. One separate doors seemed to unlock OK.
- Getting that same rear axel grown reported in anther post (sounds like a playing card in the spokes of a bicycle wheel.
- One morning the radio became non-responsive. Music was coming out but I couldnt change the stations or volume level.
- Tonight started car and ABS, braking system (different from ABS), airbag, and parking sensors were all disabled. Restarted car a few times and that cleared but now check engine light on.
__________________
Reply With Quote
  #156  
Old 05-11-2013, 11:29 AM
Imanthony's Avatar
Member
 
Join Date: May 2013
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 386
Imanthony is on a distinguished road
Took to dealer today. Service Rep said she has seen several issues with unset electrical connections. They would have to disconnect and reconnect them all to ensure they are properly set.

She wasn't sure about ticking noise.

Also said iPhone issue was from uconnect but she didn't think there was a fix yet.
__________________

__________________
2014 Jeep Grand Cherokee Overland - 4x2 Hemi
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any 2014 GC Problems ? TheHeartBreaker Trouble Shooting/Problems/Service 8 06-02-2013 04:25 PM
Problems Continue 2014 Summit glock17 Trouble Shooting/Problems/Service 20 05-07-2013 10:40 AM
2014 Changed Select Track (Fix for Sand problem?) lysol Interior/Exterior/Visual 2 01-17-2013 08:54 PM
Did Shudder TSB fix a problem? 2011 Shudder problems thread JoeSchmoe007 Trouble Shooting/Problems/Service 159 02-14-2011 09:11 AM
Problem w/Hands Free Phone FirePix1075 Grand Cherokee - WK2 - 11 09-23-2010 06:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community