Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #181  
Old 06-04-2013, 10:40 AM
amc2002's Avatar
Member
My Jeep: 2002 4.0L TJ
 
Join Date: Apr 2013
Location: Long Island, NY
Posts: 519
Thanks: 0
Thanked 12 Times in 12 Posts
Rep Power: 237033
amc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond reputeamc2002 has a reputation beyond repute
I am encouraged by all the reports of minor issues being fixed and all of you enjoying your vehicles.
__________________

__________________
Reply With Quote
  #182  
Old 06-04-2013, 01:03 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Dec 2012
Location: Kentucky
Posts: 55
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 748
blackknight is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by jacko15 View Post
Please elaborate about the air suspension software update. What was your symptom, and is there a tsb?
I got a message while driving one day that said "please wait, air suspension cooling down". I was not doing anything usual, air suspension was on auto. It happened 3 times on a straight 40 mile strength. I took it to the dealer and they said it showed a update was available. They did the update and it has not reappeared since. Here is the thread I started about it.

2014 Air Suspension
__________________

__________________
Reply With Quote
The Following User Says Thank You to blackknight For This Useful Post:
  #183  
Old 06-04-2013, 01:16 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2010
Location: Inland Empire, CA
Posts: 667
Thanks: 17
Thanked 16 Times in 11 Posts
Rep Power: 1152334
Specx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Nearing 4,000 miles with no issues other than the radio bugs initially.
__________________
Ordered 02/06/2013: 2014 Overland, Brilliant Black Exterior, Black Interior, 5.7 Hemi, Off-Road Adventure II, Advanced Technology Group

Vehicle Delivered to Dealer 03/25/2013 05:00 PM PDT In my garage!
Reply With Quote
  #184  
Old 06-04-2013, 02:18 PM
New Member
 
Join Date: Jun 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
TifodJuve is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

I have a 2014 GC Overland V8 and I have had a rubbing noise from the front passenger side of the vehicle since the day I picked it up from the dealership. It is not the noise that has been reported on another thread. I notice it the most if I accelerate to about 25mph and get off of the gas. I reluctantly brought it in to the dealership and they replaced the wheel bearings. The noise was still there so they tore the other side apart too and found nothing wrong. After two days of taking apart a vehicle with less that 100 miles they told me that they drove another Overland and noticed the same problem and that I need to buy new tires! My wheels were scratched in the process so make sure you keep an eye on the painted wheels when you get your tires rotated, etc. I just wanted my car back, and to get away from the horrible service dept., so I drove off without complaining about the scratches.
Has anyone else noticed this noise?
__________________
Reply With Quote
  #185  
Old 06-04-2013, 04:37 PM
Member
 
Join Date: Dec 2010
Posts: 448
Thanks: 12
Thanked 9 Times in 9 Posts
Rep Power: 3303
Keirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond reputeKeirik has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by TifodJuve View Post
I have a 2014 GC Overland V8 and I have had a rubbing noise from the front passenger side of the vehicle since the day I picked it up from the dealership. It is not the noise that has been reported on another thread. I notice it the most if I accelerate to about 25mph and get off of the gas. I reluctantly brought it in to the dealership and they replaced the wheel bearings. The noise was still there so they tore the other side apart too and found nothing wrong. After two days of taking apart a vehicle with less that 100 miles they told me that they drove another Overland and noticed the same problem and that I need to buy new tires! My wheels were scratched in the process so make sure you keep an eye on the painted wheels when you get your tires rotated, etc. I just wanted my car back, and to get away from the horrible service dept., so I drove off without complaining about the scratches.
Has anyone else noticed this noise?
Wait, they told you yer car needed new tires with less than 100 miles on it?
__________________
Had 09 HEMI Overland (totalled)
Ordered 2014 HEMI Overland max steel/black
Reply With Quote
  #186  
Old 06-04-2013, 04:50 PM
New Member
 
Join Date: Jun 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
TifodJuve is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

The service department did tell me that if I wanted to get rid of the noise to "get new tires". I had 108 miles on the vehicle when I picked it up after the service. I told them that if there was an issue with the tires that Jeep should be informed by the dealership and that there were other online threads that talked about 2014 Overland noises. She told me "not to believe everything I read online".
It goes without saying that I will never go to this dealership again and I am still looking for one that has competent people in the Seattle area. I am really upset with the issues with the vehicle and the service.
__________________
Reply With Quote
  #187  
Old 06-04-2013, 05:48 PM
padgett's Avatar
Premium Member
 
Join Date: Feb 2012
Location: Orlando
Posts: 1,558
Thanks: 0
Thanked 24 Times in 21 Posts
Rep Power: 80220
padgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond reputepadgett has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Is this a 4x4 ? I remember something about a rub on the front halfshaft on the passenger side If so you should see a clean mark on the half-shaft.
Reply With Quote
  #188  
Old 06-04-2013, 06:13 PM
New Member
 
Join Date: Jun 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
TifodJuve is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

The Overland is a 4x4. Excuse my ignorance, but where is the half- shaft and what was the remedy for the rub?
BTW, I am a long time Jeep owner but new to this forum. What a great resource!
__________________
Reply With Quote
  #189  
Old 06-05-2013, 06:43 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 931
Thanks: 0
Thanked 43 Times in 34 Posts
Rep Power: 3552
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by TifodJuve View Post

The Overland is a 4x4. Excuse my ignorance, but where is the half- shaft and what was the remedy for the rub?
BTW, I am a long time Jeep owner but new to this forum. What a great resource!
You've been a long-time Jeep owner, but don't know what a half shaft is?



The CV joint half shaft is what sends power to the wheel, and looks sort of like this...

__________________
My V6 Overland transmission shifts like crap!
Reply With Quote
  #190  
Old 06-05-2013, 01:09 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Apr 2011
Posts: 179
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1466
Yeti is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by Yeti View Post
I seem to be problem free now but after I drove it ~350 miles home from the dealer the rear end dripped what seemed like gear oil onto the garage floor where my wife normally parks. I climbed underneath to see what was going on and there was oil on the bottom of the differential. I wiped it off and it hasn't happened again in another 3-400 miles, weird huh? It's been back in my spot since then so maybe it didn't like my wife's, lol.
Parked in the wife's spot again last night and the leaks back, lol I guess I'll have to take it in for service soon, I was hoping to avoid that like almost forever!
__________________
Reply With Quote
  #191  
Old 06-06-2013, 05:25 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: Jun 2013
Location: Caribbean
Posts: 22
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 537
OverlandAzul is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

I bought a 2014 Overland 4x4 Hemi this week. I have about 300 mi on it and I love the thing. This is my first Jeep product. I am having issues with a big "clunk" when decelerating to a stop; usually travelling at less than 7 mph or so. I feel it is an issue of the ZF transmission when shifting down from 2 gear into 1st gear. It is scary; if feels like somebody just rear ended you at low speed; you feel a bump every time.

Any body else with this issue?
__________________
Reply With Quote
  #192  
Old 06-06-2013, 07:26 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 931
Thanks: 0
Thanked 43 Times in 34 Posts
Rep Power: 3552
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by OverlandAzul View Post

I bought a 2014 Overland 4x4 Hemi this week. I have about 300 mi on it and I love the thing. This is my first Jeep product. I am having issues with a big "clunk" when decelerating to a stop; usually travelling at less than 7 mph or so. I feel it is an issue of the ZF transmission when shifting down from 2 gear into 1st gear. It is scary; if feels like somebody just rear ended you at low speed; you feel a bump every time.

Any body else with this issue?
Check out my Thread...maybe it will help.

I Think I Fixed My Rough Shifting 8sp Transmission
__________________

__________________
My V6 Overland transmission shifts like crap!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any 2014 GC Problems ? TheHeartBreaker Trouble Shooting/Problems/Service 8 06-02-2013 04:25 PM
Problems Continue 2014 Summit glock17 Trouble Shooting/Problems/Service 20 05-07-2013 10:40 AM
2014 Changed Select Track (Fix for Sand problem?) lysol Interior/Exterior/Visual 2 01-17-2013 08:54 PM
Did Shudder TSB fix a problem? 2011 Shudder problems thread JoeSchmoe007 Trouble Shooting/Problems/Service 159 02-14-2011 09:11 AM
Problem w/Hands Free Phone FirePix1075 Grand Cherokee - WK2 - 11 09-23-2010 06:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.