Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #49  
Old 03-30-2013, 05:57 AM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,225
Thanks: 321
Thanked 349 Times in 305 Posts
Rep Power: 1801720
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by BigWave View Post
Bill -- FYI, it really should be "1600 miles" but after we all got the chance to test drive/QC it before it got to you, we rolled back the odometer.
Thanks for the info. I'll scratch a +1000 in the tft screen.

BTW - are you the one responsible for the chipped paint?
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!

Reply With Quote
  #50  
Old 03-30-2013, 08:48 AM
xnight's Avatar
Member
 
Join Date: Mar 2013
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 623
xnight is on a distinguished road
Quote:
Originally Posted by Scottina06 View Post

Preach it brother! I agree 100%
Amen
__________________

__________________
Reply With Quote
  #51  
Old 03-30-2013, 12:14 PM
BigWave's Avatar
Let it snow, let it snow, let it snow
My Jeep: 2014 5.7L WK2
 
Join Date: Nov 2012
Location: Metro D.C.
Posts: 511
Thanks: 217
Thanked 33 Times in 26 Posts
Rep Power: 1224
BigWave has a reputation beyond reputeBigWave has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by bill_de View Post
Thanks for the info. I'll scratch a +1000 in the tft screen.

BTW - are you the one responsible for the chipped paint?
Yeah, figured I'd do it so you wouldnt kick yourself the first time it happened to you. Very noble of me. Think of it as an early Easter present. :doh:
__________________
Current:
On tax day, I collected my Limited 4x4 V8.

Retired:
'97 Honda Accord SE.
'93 Chevy Silverado 1500 totaled by 2 deer. I hate deer.
'91 Chevy S10.
Reply With Quote
  #52  
Old 03-30-2013, 01:01 PM
jer630's Avatar
Member
My Jeep: 2014 WK2
 
Join Date: Mar 2013
Location: Greer, SC
Posts: 34
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 716
jer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond reputejer630 has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

We've been problem free at 1000 miles so far except for one freeze of the touchscreen trying to put a favorite into the Nav system. UConnect does have its awkward moments, but we've never had a ttouchscreen or anything like it before, so some of it is just us too.
__________________
Reply With Quote
  #53  
Old 03-30-2013, 10:57 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2010
Location: Inland Empire, CA
Posts: 661
Thanks: 17
Thanked 16 Times in 11 Posts
Rep Power: 1152296
Specx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

I had the strangest thing happen with the nav today. I was using it to display the map as 3D and when I got into downtown Long Beach right before it started to show the buildings as 3D, the entire system shutoff. The nav stopped navigating, music shut off, and then the startup screen came on and everything resumed like nothing happened. I don't understand what may have happened and it didn't happen again on the trip home. Anyone else have this happen and should I be worried about this becoming a bigger issue, or wait and see if it happens again?
__________________
Ordered 02/06/2013: 2014 Overland, Brilliant Black Exterior, Black Interior, 5.7 Hemi, Off-Road Adventure II, Advanced Technology Group

Vehicle Delivered to Dealer 03/25/2013 05:00 PM PDT In my garage!
Reply With Quote
  #54  
Old 03-31-2013, 12:06 AM
PMD G8's Avatar
Premium Member
 
Join Date: Nov 2010
Posts: 468
Thanks: 4
Thanked 7 Times in 6 Posts
Rep Power: 24548
PMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by jacko15 View Post
I feel sorry for folks that live in such a perfect world that one mistake, one flaw, one out of place speck of dirt, any imperfection, would cause such anguish. I don't mean to be disrespectful or nasty, but I'm clinically diagnosed with OCD, and these slight imperfections in a mass produced, high volume, extremely complicated product, even to me, don't seem as shocking as they seem to be to others here. I really don't know how to respond to someone who can be "shocked" by a paint blemish, when I look around the world and see the things I see. As has been said before on this forum, "it's tough to have to live with these 'first world' problems". I think all the perfect people out there should cut the rest of us some slack, we can't all be perfect. Like I said, I mean no disrespect, but we all really need to get our priorities in a much more accepting place.

Exactly. I'm more pissed off with the shitty ass roads that I have to drive on than a slight imperfection in the paint on my new car. He'll, I'm paying for both of them. As far as the people on here complaining over pety shit, take it with a grain of salt and then ridicule them for being a dick.
__________________
Currently:
Work: 2006 Dodge Charger Hemi, Dark Blue
Ours: 2009 Chevy Suburban LTZ, White
Mine: 2009.5 Pontiac G8 GXP, Silver
Wifes: 2014 Summit V8 4x4, Bright White/Black(Delivered 4/2/2013)
Reply With Quote
  #55  
Old 03-31-2013, 01:07 AM
demontweak's Avatar
Member
 
Join Date: Dec 2012
Location: NorCal
Posts: 38
Thanks: 2
Thanked 7 Times in 4 Posts
Rep Power: 63045
demontweak has a reputation beyond reputedemontweak has a reputation beyond reputedemontweak has a reputation beyond reputedemontweak has a reputation beyond reputedemontweak has a reputation beyond reputedemontweak has a reputation beyond reputedemontweak has a reputation beyond reputedemontweak has a reputation beyond reputedemontweak has a reputation beyond reputedemontweak has a reputation beyond reputedemontweak has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Just got home from a 1600 mile road trip. Only 2 problems with the jeep. Radio locked up once, but Nav and Climate control stayed working, after shuting off and restarting the radio went back to normal.
At 1497miles it developed a major Rattle, was under the drivers seat and was enought that I slowed to 40mph and took the first offramp i came to. Crawled all over looking for somthing. Thought it might be the inner fender slapping the frame but was still making noise when i got back on freeway. Called the closest jeep dealer and they said they would keep a tech around to look at it. They put on a lift and we were looking at it when we both saw it.........It was the part # sticker on the front driveshaft. During slow speeds it would stay coiled but when it turned at highway speeds it would uncoil and slap a bracket on the Trans.
Other than those problems i am happy with My 2014 Overland.
__________________
Reply With Quote
  #56  
Old 04-01-2013, 06:26 PM
Member
 
Join Date: Feb 2013
Location: NorCal
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 608
Skafte is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by Skafte View Post
I have a rattle in the rear somewhere that's audible when driving over some of the concrete freeways around here. The dealer is going to look at it this Saturday.
This turned out to be a non-issue. Apparently it was caused by the dealer license plate frame that was a bit loose. Haven't heard anything since this was tightened up.
__________________
2014 Bright White Overland V8
Reply With Quote
  #57  
Old 04-01-2013, 08:15 PM
Tempest's Avatar
Member
 
Join Date: Mar 2013
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 593
Tempest is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by nickm View Post
I just traded in my 2011 limited v6 for a 2014 overland v6 . I can't believe its doing the same thing with a totally different transmission. When it down shifts into 1st gear you hear and feel some kind of clunck or thump. I'm very disappointed. whoever gives the final OK after development should be fired.
Mine did that too, but has since learned out of it and is very smooth. How many miles have you driven? Give it some time.
__________________
2014 Summit V6 Deep Cherry Red/Black
Reply With Quote
  #58  
Old 04-01-2013, 11:22 PM
Kharacter Zero's Avatar
New Member
 
Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Kharacter Zero is on a distinguished road
Quote:
Originally Posted by nickm View Post
I just traded in my 2011 limited v6 for a 2014 overland v6 . I can't believe its doing the same thing with a totally different transmission. When it down shifts into 1st gear you hear and feel some kind of clunck or thump. I'm very disappointed. whoever gives the final OK after development should be fired.
This is my first Jeep. I have the Laredo V6, and I've noticed the same thing. I've had it for about 3 weeks, and it does it all the time. I just thought this was normal? Also, starting to notice when I am turning, say from a dead stop I'm a left-turn lane, as I accelerate into 2nd, there is some serious grinding going on, do you (or anyone else) have this same issue?
__________________
Reply With Quote
  #59  
Old 04-01-2013, 11:48 PM
Member
 
Join Date: Mar 2011
Posts: 64
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1367
nickm is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

I only have about 200 miles on it. It's a truly great vehicle . I just wish they would spend more time fixing the bugs before they sell them.
__________________
Reply With Quote
  #60  
Old 04-03-2013, 08:45 AM
wap2012's Avatar
Member
 
Join Date: Dec 2012
Location: Canada
Posts: 141
Thanks: 9
Thanked 6 Times in 4 Posts
Rep Power: 797
wap2012 is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

I've had a few issues... condensation in both headlights... my steering wheel shakes at 110-120km/h +... someone said maybe the wheel weights, need to be rebalanced.. Some carpet at b-pillar is loose... A flaw in my paint on the C-pillar...a round ciruclar pattern from when they sanded and buffed out dirt in paint. I had that buffed out yesterday at Body Shop... Also I had a heck of a time trying to get a gas station nozzle to fit into the capless fuel tank.... unless they need to be broken in or something.. It was unusually difficult.... need to mention when I bring it in for Serive on Thursday.... I'm a bit dissapointed so far...Also I programmed my garage door opener for the Homelink and every since that day I've had issues of my garage door opening and closing on its own... leaving my garage open... at odd times.. not very good for security reasons when I'm sleep at night only to find my garage door wide open in the morning... WTF? I also couldn't get the Jeep Homelink to accept the signal off of the actual learn button on the garage door unit. I had to use the handheld transmitter.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any 2014 GC Problems ? TheHeartBreaker Trouble Shooting/Problems/Service 8 06-02-2013 04:25 PM
Problems Continue 2014 Summit glock17 Trouble Shooting/Problems/Service 20 05-07-2013 10:40 AM
2014 Changed Select Track (Fix for Sand problem?) lysol Interior/Exterior/Visual 2 01-17-2013 08:54 PM
Did Shudder TSB fix a problem? 2011 Shudder problems thread JoeSchmoe007 Trouble Shooting/Problems/Service 159 02-14-2011 09:11 AM
Problem w/Hands Free Phone FirePix1075 Grand Cherokee - WK2 - 11 09-23-2010 06:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:25 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community