Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #85  
Old 04-11-2013, 10:26 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,195
Thanks: 214
Thanked 172 Times in 137 Posts
Rep Power: 89720
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Just a note, although it's miniscule, usb thumbdrives will draw a slight current even if the vehicle is turned off if the usb receptacle stays hot. Don't know if it does in the JGC. Anyone know?
__________________

__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #86  
Old 04-11-2013, 10:36 AM
Member
 
Join Date: Mar 2013
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 657
Amylee is on a distinguished road
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by Kharacter Zero View Post
This is my first Jeep. I have the Laredo V6, and I've noticed the same thing. I've had it for about 3 weeks, and it does it all the time. I just thought this was normal? Also, starting to notice when I am turning, say from a dead stop I'm a left-turn lane, as I accelerate into 2nd, there is some serious grinding going on, do you (or anyone else) have this same issue?

I have this same problem, and I have also had the problem with having to pair the phone each time I get in the car. The dealer is going to replace my radio unit, although I don't think this will help because it's most likely a software/UConnect problem.

I can definitely feel when my 2014 Laredo shifts from first to second, or downshifts in low gears. I don't hear a clunk but I can feel it. This is mostly in Eco mode, but have noticed it driving without Eco on as well. I am going to mention it to them when I bring it in to have the radio replaced. I also noticed twice (and it happened to be raining both times) that when I stopped and turned as I accelerated it was really thumpy (I don't know how else to describe it, really...JERKY, thats it!!!), like it was trying to shift but it took a couple of tries before it got there. Sucky.
__________________

__________________
Reply With Quote
  #87  
Old 04-11-2013, 12:46 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Richmond, VA
Posts: 78
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 696
libby2cm is on a distinguished road
Garage
Re: Those who have a 2014, any problems? or problem free?

Traded in my 2011 Durango Citadel on 3/30 for a 2014 Summit.. and love it. I liked Durango a lot, but some of the tech was lacking & uconnect issues were irritating. There was only one Summit within hundreds of miles of my dealer spec'd how I wanted (granite metallic, black interior, v6, summit) and I was very lucky to get it. They had several people make offers on it while it was sitting in lot waiting for me to pick it up, lol. Even GM was impressed by it because he hadn't seen a summit yet.

After reading some of the posts in here, I was nervous that I would run into some issues, especially given how anal I am about everything in general. However, I must say.. it's pretty much perfect. I can usually find something to b**ch about, but after 2 weeks, nothing yet. Uconnect works great, remote app for phone works great, car rides smooth, all features work, no rattles/squeaks, HK audio sounds AWESOME. Only unconfirmed issue is BT audio stream drops sometimes/randomly when playing music, but I can't pin that on UC yet, since I am using a rooted GNII with custom rom.. could just be bug in BT stack as I haven't tested audio anywhere else with it yet.

Of course, before i took delivery, I made it VERY clear that they were to hook up truck to star tool & perform all updates before I picked it up, which in itself may have prevented me from having issues. I work in IT, and there is a reason mfg's release firmware/code updates. Getting your typical mechanic to get on the same page with that mindset is still a challenge, even given how much software directly controls late model vehicles these days. I always make sure they check/perform updates when I go in for an oil change for my vehicles, and it has prooven to serve me well, even though it's a bit of a argument each time. I would suggest everyone do the same. If J2534 adapters & TA subscriptions weren't so expensive, i'd just do it myself, and I think it's ridiculous that it's so hard to keep SW up to date in a vehicle, when it's probably the cause of 80% of late model vehicle issues. There is a 3G radio in system.. would it really be that hard to implement a 'live update' sort of solution???

Anyway, enough ranting. Great truck!
__________________
Reply With Quote
  #88  
Old 04-11-2013, 11:00 PM
PMD G8's Avatar
Premium Member
 
Join Date: Nov 2010
Posts: 468
Thanks: 4
Thanked 7 Times in 6 Posts
Rep Power: 24626
PMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by Beski View Post
Wow, I have never seen a thumb drive like that before !! Can you just leave that plugged in "forever" (or at least for a few weeks) and if it's extra hot or extra cold outside ?

(I'm anal that way.....I would never leave CD's in the car overnight - and would not take them with me if I knew they would be sitting in an extra cold or extra hot car for an extended time !!)

Also, was it hard to plug in and un-plug ? I thought it was a little difficult to plug in my SD card on my test drive and I don't consider my hands extra big.
I left the old 4Gb in my wife's 2011 for at least over a year, so no problems with heat or cold, never even gave that much thought really. Much more useful and easier to use than the old Hard Drive(ripping discs took forever). All of my music is on my computer now anyways, only takes a couple of minutes to transfer it over to the thumb drive.

It's a bit difficult to get your hands on but really, I hardly ever remove it, or don't plan on it unless I download a new Album which is only once every other month or so.
__________________
Currently:
Work: 2006 Dodge Charger Hemi, Dark Blue
Ours: 2009 Chevy Suburban LTZ, White
Mine: 2009.5 Pontiac G8 GXP, Silver
Wifes: 2014 Summit V8 4x4, Bright White/Black(Delivered 4/2/2013)
Reply With Quote
  #89  
Old 04-12-2013, 12:16 AM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2010
Location: Inland Empire, CA
Posts: 672
Thanks: 17
Thanked 17 Times in 12 Posts
Rep Power: 1152386
Specx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Went out to the store and now both the USB and SD card slot aren't reading. The screen continues to say please wait and then finally it says something about the phone not being detected and take to dealer for service. On the rear view mirror, there's now a red light in the center lite up and the screen mentions something about 911. Not good and hopefully the dealer can resolve this issue.
__________________
Ordered 02/06/2013: 2014 Overland, Brilliant Black Exterior, Black Interior, 5.7 Hemi, Off-Road Adventure II, Advanced Technology Group

Vehicle Delivered to Dealer 03/25/2013 05:00 PM PDT In my garage!
Reply With Quote
  #90  
Old 04-12-2013, 08:11 AM
GCLimited's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Mass
Posts: 987
Thanks: 6
Thanked 50 Times in 37 Posts
Rep Power: 3655
GCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond reputeGCLimited has a reputation beyond repute
Garage
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by libby2cm View Post

Of course, before i took delivery, I made it VERY clear that they were to hook up truck to star tool & perform all updates before I picked it up, which in itself may have prevented me from having issues.
Good point!



I definately will be asking the for the same thing when I pick up my new Limited!
__________________
I Hate My Jeep Yet Again...
Reply With Quote
  #91  
Old 04-12-2013, 07:51 PM
BobsWK2's Avatar
Premium Member
 
Join Date: Aug 2010
Posts: 1,572
Thanks: 3
Thanked 30 Times in 26 Posts
Rep Power: 49705
BobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by GCLimited View Post
Good point!



I definately will be asking the for the same thing when I pick up my new Limited!
But how will you know if they actually did check for updates? Of course they will say they will do it. But while they are performing the PDI, I doubt it.
__________________
2014 Summit 4X4, V8
Reply With Quote
  #92  
Old 04-12-2013, 10:44 PM
garymb5150's Avatar
Member
 
Join Date: Feb 2013
Posts: 110
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 777
garymb5150 is on a distinguished road
What is the latest version and is there a way to tell if it is most up to date as we start to pick them up???
__________________
Reply With Quote
  #93  
Old 04-16-2013, 07:27 PM
Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2010
Location: Inland Empire, CA
Posts: 672
Thanks: 17
Thanked 17 Times in 12 Posts
Rep Power: 1152386
Specx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond reputeSpecx has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by Specx View Post
Went out to the store and now both the USB and SD card slot aren't reading. The screen continues to say please wait and then finally it says something about the phone not being detected and take to dealer for service. On the rear view mirror, there's now a red light in the center lite up and the screen mentions something about 911. Not good and hopefully the dealer can resolve this issue.
Took it into the dealer today and left it there for the day while I was at work. They looked at the radio, but the tech had some allergic reaction and had to go to the hospital, so he didn't get to complete the diagnostic. They said they might order a new unit, but want me to bring it back in for 10 minutes to download the data off it and read the codes. They also placed an order for a new shifter. The guy said it comes in 2 sections and the part is nearly $200, so they will have me come back in when it arrives. Since it's still new, parts aren't in stock and will take up to 2 weeks to get in. Not the best experience, but I've dealt with worse at Chrysler dealers where they do nothing and have me wait to replicate the issue before attempting any repairs
__________________
Ordered 02/06/2013: 2014 Overland, Brilliant Black Exterior, Black Interior, 5.7 Hemi, Off-Road Adventure II, Advanced Technology Group

Vehicle Delivered to Dealer 03/25/2013 05:00 PM PDT In my garage!
Reply With Quote
  #94  
Old 04-16-2013, 09:09 PM
garymb5150's Avatar
Member
 
Join Date: Feb 2013
Posts: 110
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 777
garymb5150 is on a distinguished road
Has 20 miles on it

Condensation in lights
Attached Images
File Type: jpg image-931011288.jpg (449.8 KB, 58 views)
__________________
Reply With Quote
  #95  
Old 04-17-2013, 10:14 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Richmond, VA
Posts: 78
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 696
libby2cm is on a distinguished road
Garage
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by BobsWK2 View Post
But how will you know if they actually did check for updates? Of course they will say they will do it. But while they are performing the PDI, I doubt it.
You don't really .. in fact, I suspect they ignore me 1/2 of the times I ask for it, which is why I request it at every oil change.. figure that way, i'll hopefully get at least 1 person that will be honest about it. I am about ready to just get a mongoose and do it myself.. TA is $35 for 3 days, figure I do it myself once a quarter or twice a year (and my wife's car too) and be assured it's good to go. As software dependent as these cars are now, you would think OEM's would make it easier for the DIY'r to do the updates themselves... guess that cuts in to their revenue stream though.

I bought a tactrix adapter a couple of years ago when I got my durango, but it wouldn't work in passthru mode with TA, so I returned it. Would be great if it would work though since price is right.

Wasn't there supposed to be an update coming for UC to fix some bugs and add pandora support and stuff?
__________________
Reply With Quote
  #96  
Old 04-17-2013, 10:17 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Richmond, VA
Posts: 78
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 696
libby2cm is on a distinguished road
Garage
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by garymb5150 View Post
Has 20 miles on it

Condensation in lights
Yea.. I noticied some in the driver side light on mine in the same spot as your pic , the night I picked it up. Already left dealer when I saw it, but it dried up and I haven't seen it again .. yet. Suppose i'll put it in shop if it comes back. I had to pull tailight off pass. side to fix that as well. One of the retainer studs in the back of it was 1/2 way unscrewed and kept light from sitting flush and was rubbing on lift gate when it opened. Was easy enough for me to fix though.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any 2014 GC Problems ? TheHeartBreaker Trouble Shooting/Problems/Service 8 06-02-2013 04:25 PM
Problems Continue 2014 Summit glock17 Trouble Shooting/Problems/Service 20 05-07-2013 10:40 AM
2014 Changed Select Track (Fix for Sand problem?) lysol Interior/Exterior/Visual 2 01-17-2013 08:54 PM
Did Shudder TSB fix a problem? 2011 Shudder problems thread JoeSchmoe007 Trouble Shooting/Problems/Service 159 02-14-2011 09:11 AM
Problem w/Hands Free Phone FirePix1075 Grand Cherokee - WK2 - 11 09-23-2010 06:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.