Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #97  
Old 04-17-2013, 10:32 PM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Richmond, VA
Posts: 78
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 698
libby2cm is on a distinguished road
Garage
Re: Those who have a 2014, any problems? or problem free?

MIL came on the other day when I got in to drive home from work. Whipped out bluetooth obdII dongle & torque and found it was P0456 (EVAP very small leak detected). Usually it's gas cap that can cause that ... but there is no gas cap to check ... so I ran fill funnel in/out of nozzle a few times in case maybe a switch/sensor was stuck & checked wiring harnesses/lines were visually secure under hood, cleared code and haven't seen it come back in about 15 drive cycles so far. Will keep an eye on it and put it in shop if I see it again I suppose.
__________________

__________________
Reply With Quote
  #98  
Old 04-17-2013, 11:01 PM
garymb5150's Avatar
Member
 
Join Date: Feb 2013
Posts: 110
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 780
garymb5150 is on a distinguished road
Still getting condensation inside both headlights

Gonna have to have dealer address this
Attached Images
File Type: jpg image-3498083940.jpg (366.3 KB, 53 views)
File Type: jpg image-526124024.jpg (436.6 KB, 50 views)
__________________

__________________
Reply With Quote
  #99  
Old 04-18-2013, 08:30 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,195
Thanks: 214
Thanked 172 Times in 137 Posts
Rep Power: 89722
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by garymb5150 View Post
Still getting condensation inside both headlights

Gonna have to have dealer address this
I had condensation in one headlamp enclosure when I picked up my '14 last Saturday. I pointed this out to the salesman and he told me it wasn't unusual. It was a cold and rainy day, and he said the enclosures are vented because of the heat produced by the hid lamps, and it should dry out quickly when I drove it. He did say that if it persisted, to bring it in and they would probably replace the assembly. I drove it 3 miles to my house and it was clear when I got there. I will keep an eye on it to see if it recurs, and take it in if it does.
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #100  
Old 04-18-2013, 11:20 AM
Member
My Jeep: 2014 3.6L WK2
 
Join Date: Apr 2013
Location: Richmond, VA
Posts: 78
Thanks: 1
Thanked 3 Times in 3 Posts
Rep Power: 698
libby2cm is on a distinguished road
Garage
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by jacko15 View Post
I had condensation in one headlamp enclosure when I picked up my '14 last Saturday. I pointed this out to the salesman and he told me it wasn't unusual. It was a cold and rainy day, and he said the enclosures are vented because of the heat produced by the hid lamps, and it should dry out quickly when I drove it. He did say that if it persisted, to bring it in and they would probably replace the assembly. I drove it 3 miles to my house and it was clear when I got there. I will keep an eye on it to see if it recurs, and take it in if it does.
I suppose that sounds plausible, and was thinking that at one point, but it looks pretty sealed to me. Plus if it was vented and moisture was allowed/expected to get in there, it sounds like a recipe for yellowing and dirt/mud to get into fixture. My '11 durango had HID lights and never had moisture issues..
__________________
Reply With Quote
  #101  
Old 04-18-2013, 11:45 AM
WVSpelunker's Avatar
Member
 
Join Date: Feb 2013
Posts: 88
Thanks: 6
Thanked 12 Times in 5 Posts
Rep Power: 3756
WVSpelunker has a reputation beyond reputeWVSpelunker has a reputation beyond reputeWVSpelunker has a reputation beyond reputeWVSpelunker has a reputation beyond reputeWVSpelunker has a reputation beyond reputeWVSpelunker has a reputation beyond reputeWVSpelunker has a reputation beyond reputeWVSpelunker has a reputation beyond reputeWVSpelunker has a reputation beyond reputeWVSpelunker has a reputation beyond reputeWVSpelunker has a reputation beyond repute
Garage
Re: Those who have a 2014, any problems? or problem free?

Mine had been pretty much flawless until yesterday. I had it jacked up on Tuesday and yesterday afternoon something in the front started groaning at low speeds and turns. I drove into work and to lunch without the noise, but after another errand, I started to hear it. It will also make the noise when lowering the front using QL from drive to sports mode. Not sure if it will work itself out or a trip to the dealer is needed.
__________________
Reply With Quote
  #102  
Old 04-18-2013, 11:26 PM
garymb5150's Avatar
Member
 
Join Date: Feb 2013
Posts: 110
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 780
garymb5150 is on a distinguished road
Anyone have this issue??

My nav ... Never switches to night mode. It set on auto.... But always stAys in day mode.

Any ideas?
__________________
Reply With Quote
  #103  
Old 04-19-2013, 12:10 AM
PMD G8's Avatar
Premium Member
 
Join Date: Nov 2010
Posts: 468
Thanks: 4
Thanked 7 Times in 6 Posts
Rep Power: 24629
PMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond reputePMD G8 has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Do you have your interior lights turned all the way up? Hard to explain but can the wheel freely spin or is in locked in, one notch before rolling it over to turning the interior lights on.
__________________
Currently:
Work: 2006 Dodge Charger Hemi, Dark Blue
Ours: 2009 Chevy Suburban LTZ, White
Mine: 2009.5 Pontiac G8 GXP, Silver
Wifes: 2014 Summit V8 4x4, Bright White/Black(Delivered 4/2/2013)
Reply With Quote
  #104  
Old 04-19-2013, 07:23 AM
jacko15's Avatar
Premium Member
My Jeep: 2014 3.6L WK2
 
Join Date: Feb 2013
Location: Pennsylvania's North Shore
Posts: 2,195
Thanks: 214
Thanked 172 Times in 137 Posts
Rep Power: 89722
jacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond reputejacko15 has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by garymb5150 View Post
Anyone have this issue??

My nav ... Never switches to night mode. It set on auto.... But always stAys in day mode.

Any ideas?
From the manual (I take it to mean: headlights on-night mode; headlights off-day mode):
"Display
After pressing the Display soft-key the following settings
will be available.
• Display Mode
When in this display you may select one of the auto
display settings. To change Mode status, touch and
release the Day, Night or Auto soft-key. Then touch the
arrow back soft-key.
• Display Brightness With Headlights ON
When in this display, you may select the brightness with
the headlights on. Adjust the brightness with the + and –
setting soft-keys or by selecting any point on the scale
between the + and – soft-keys. Then touch the arrow back
soft-key.
• Display Brightness With Headlights OFF
When in this display, you may select the brightness with
the headlights off. Adjust the brightness with the + and –
setting soft-keys or by selecting any point on the scale
between the + and – soft-keys. Then touch the arrow back
soft-key."
__________________
Mine: 2014 Overland 4x4 V6, ORA II, billet silver/black, Michelin LTX M/S 2's, MaxCare Lifetime, delivered 4-13-'13
Wife's Jeep: 2008 Compass Sport 4x4, 2.4L I4 DOHC, CVT, Lifetime powertrain warranty
Reply With Quote
  #105  
Old 04-19-2013, 11:36 AM
garymb5150's Avatar
Member
 
Join Date: Feb 2013
Posts: 110
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 780
garymb5150 is on a distinguished road
Thanks for the quick response...but I am still struggling w this....I took a pic....even when I check night mode and then go to "display brightness night"--- both the + and - are frayed out so I can not adjust.

And in auto .... When it is dark out...the nav stays bright....if I go in and select night mode te background turns black....but not in "auto" mode.
Attached Images
File Type: jpg image-1955379128.jpg (458.3 KB, 29 views)
__________________
Reply With Quote
  #106  
Old 04-19-2013, 12:03 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,391
Thanks: 341
Thanked 368 Times in 319 Posts
Rep Power: 1801967
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Made it to 1249 miles ... and then!

Got out on the beach for a little bit of fishing. We only drove about a mile on the beach and fished for awhile before the weather turned. Got off the beach with no problems. Then I stopped, shut the engine off, and aired up the tires.

When I restarted the car I was met with the following;

Service air suspension system
ABS light
Brakes light
Park sense off, won't turn on
Traction control off, wont turn on
Check Engine light
Speedometer and odometer not registering
Nav recalculates every minute or so telling me to make every turn, right or left


I drove home, keeping an eye on temp, oil pressure, etc. The Jeep seems to drive like it did before. (Maybe faster, I can't tell)

But it did ok on the beach. Maybe I need that door under the engine.



__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
  #107  
Old 04-19-2013, 03:11 PM
AbleRiot's Avatar
Member
 
Join Date: Mar 2013
Location: Union County, NJ
Posts: 353
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 309619
AbleRiot has a reputation beyond reputeAbleRiot has a reputation beyond reputeAbleRiot has a reputation beyond reputeAbleRiot has a reputation beyond reputeAbleRiot has a reputation beyond reputeAbleRiot has a reputation beyond reputeAbleRiot has a reputation beyond reputeAbleRiot has a reputation beyond reputeAbleRiot has a reputation beyond reputeAbleRiot has a reputation beyond reputeAbleRiot has a reputation beyond repute
Quote:
Originally Posted by bill_de View Post
Got out on the beach for a little bit of fishing. We only drove about a mile on the beach and fished for awhile before the weather turned. Got off the beach with no problems. Then I stopped, shut the engine off, and aired up the tires.

When I restarted the car I was met with the following;

Service air suspension system
ABS light
Brakes light
Park sense off, won't turn on
Traction control off, wont turn on
Check Engine light
Speedometer and odometer not registering
Nav recalculates every minute or so telling me to make every turn, right or left

I drove home, keeping an eye on temp, oil pressure, etc. The Jeep seems to drive like it did before. (Maybe faster, I can't tell)

But it did ok on the beach. Maybe I need that door under the engine.
Lol

I wonder if this has anything to do with the sensors in the entire QL system needing to re-adjust after tire get re-inflated-sort of when the TPMS resets after tires get air. ( we're those set off too!). The speedo and Odo not working at all??? How did you know how fast you were going??? This is when I prefer the old gauges coz that is just wrong.
__________________
Coming this Fall: '14 Limited 3.6L 4x4 EXT?/ INT?, LuxII, Nav
Current DD: '10 Nissan Maxima 3.5L SV Premium with Technology Package, Silver/Black
Weekend Driver: '12 Subaru Outback 2.0 Limited, AWD Slate/Black (wife's DD)
Reply With Quote
  #108  
Old 04-19-2013, 03:15 PM
bill_de's Avatar
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: Sep 2012
Posts: 6,391
Thanks: 341
Thanked 368 Times in 319 Posts
Rep Power: 1801967
bill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond reputebill_de has a reputation beyond repute
Re: Those who have a 2014, any problems? or problem free?

Quote:
Originally Posted by AbleRiot View Post
Lol

I wonder if this has anything to do with the sensors in the entire QL system needing to re-adjust after tire get re-inflated-sort of when the TPMS resets after tires get air. ( we're those set off too!). The speedo and Odo not working at all??? How did you know how fast you were going??? This is when I prefer the old gauges coz that is just wrong.
The TPMS was fine. It matched my tire gauge in every tire.

As for speed, I had my buddy stick his head out the window and watched how fast his ears flapped.

I'm starting to think about a warranty just for a rental car, but I can't seem to find the thread where somebody said to call and speak to Pat ... IIRC
__________________

__________________
If you need a shoulder to cry on ...

... pull over to the side of the road!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any 2014 GC Problems ? TheHeartBreaker Trouble Shooting/Problems/Service 8 06-02-2013 04:25 PM
Problems Continue 2014 Summit glock17 Trouble Shooting/Problems/Service 20 05-07-2013 10:40 AM
2014 Changed Select Track (Fix for Sand problem?) lysol Interior/Exterior/Visual 2 01-17-2013 08:54 PM
Did Shudder TSB fix a problem? 2011 Shudder problems thread JoeSchmoe007 Trouble Shooting/Problems/Service 159 02-14-2011 09:11 AM
Problem w/Hands Free Phone FirePix1075 Grand Cherokee - WK2 - 11 09-23-2010 06:59 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.