Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WK2 - > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-24-2013, 08:24 AM
FD12ME's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Posts: 126
Thanks: 0
Thanked 16 Times in 9 Posts
Rep Power: 917
FD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond repute
Trailer lighting not working, Fuses not pushed in...Give me some help here

I had a trailer hitch installed on my '14 WK2 yesterday. Mind you, it was pre-wired, but no hitch. I went to connect my trailer today and NO lights...its not the trailer-it lit right up for my tahoe, every light worked fine. I went to see if just perhaps Jeep had not included a fuse since my car didn't come with a hitch and found:
1. About 1/3 of the fuses were not engaged all the way (and I know Jeep does not engage them all when shipping so apparently my car was either never properly "delivered" or who knows...)
2. The trailer fuses were there, but according to the manual, one of them should be 20amp, the other 30amp. Mine had a 15amp and a 30amp.

Any ideas before I shelp over to the dealership and wait 2 hours for them to say..."uhhhh we dont know"
__________________

__________________
Reply With Quote
  #2  
Old 05-24-2013, 08:50 AM
Member
My Jeep: 2011 3.6L WK2
 
Join Date: Jan 2012
Location: Bergen County, NJ
Posts: 543
Thanks: 1
Thanked 4 Times in 3 Posts
Rep Power: 1698
Dabitz has a reputation beyond reputeDabitz has a reputation beyond reputeDabitz has a reputation beyond reputeDabitz has a reputation beyond reputeDabitz has a reputation beyond repute
Garage
Re: Trailer lighting not working, Fuses not pushed in...Give me some help here

I believe this option has to be turned on by the dealership for it to work. I'm pretty sure someone will confirm, etc.
__________________

__________________
Reply With Quote
  #3  
Old 05-24-2013, 09:17 PM
FD12ME's Avatar
Member
My Jeep: 2014 3.6L WK2
 
Join Date: May 2013
Posts: 126
Thanks: 0
Thanked 16 Times in 9 Posts
Rep Power: 917
FD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond reputeFD12ME has a reputation beyond repute
Indeed you are correct. Brought it in, problem solved. Thanks!
__________________
Reply With Quote
  #4  
Old 05-28-2013, 01:43 PM
jeelo's Avatar
Member
My Jeep: 2012 3.6L WK2
 
Join Date: Aug 2009
Location: Toronto, Canada
Posts: 137
Thanks: 0
Thanked 5 Times in 4 Posts
Rep Power: 2373
jeelo has a reputation beyond reputejeelo has a reputation beyond reputejeelo has a reputation beyond reputejeelo has a reputation beyond reputejeelo has a reputation beyond reputejeelo has a reputation beyond reputejeelo has a reputation beyond reputejeelo has a reputation beyond reputejeelo has a reputation beyond reputejeelo has a reputation beyond repute
Garage
Re: Trailer lighting not working, Fuses not pushed in...Give me some help here

Its stupid. You have to bring it in to the dealership for them to activate it. I fought with the service adviser because he wanted to charge me an hour ($135/hr + taxes) for something that would take their tech <10mins to do. Finally got him to change it to .25hr since I was already in their getting my 50k service done.
__________________
'12 Jeep Grand Cherokee Laredo X Pentastar
'08 Jeep Patriot North Edition FDI 4x4
Reply With Quote
  #5  
Old 05-28-2013, 06:04 PM
BobsWK2's Avatar
Premium Member
 
Join Date: Aug 2010
Posts: 1,574
Thanks: 3
Thanked 30 Times in 26 Posts
Rep Power: 49715
BobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond reputeBobsWK2 has a reputation beyond repute
Re: Trailer lighting not working, Fuses not pushed in...Give me some help here

Just about all late model (2011 and later) vehicles that have a tow hitch installed after the vehicle leaves the assembly line would require the tow hitch to be coded to the vehicle.
__________________
2014 Summit 4X4, V8
Reply With Quote
  #6  
Old 05-28-2013, 06:11 PM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Feb 2013
Posts: 62
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 1160
kbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond reputekbre has a reputation beyond repute
Re: Trailer lighting not working, Fuses not pushed in...Give me some help here

Quote:
Originally Posted by jeelo View Post
Its stupid. You have to bring it in to the dealership for them to activate it. I fought with the service adviser because he wanted to charge me an hour ($135/hr + taxes) for something that would take their tech <10mins to do. Finally got him to change it to .25hr since I was already in their getting my 50k service done.
That is borderline theft right there, The Jeep dealer here only charged me $30 to activate mine. No haggling required, I thought that was high.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trailer running lights not working windsurfnut Trouble Shooting/Problems/Service 7 10-23-2012 09:41 PM
04 WJ Blowing Flasher Fuses GLozier Troubleshooting/Problems 10 09-26-2011 06:41 PM
Trailer signal lights not working Canyon Dancer Trouble Shooting/Problems/Service 10 10-30-2010 07:16 AM
HVAC "Mode" Knob pushed in sam555 Troubleshooting/Problems 0 06-01-2010 10:37 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:13 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.